Reply to topic

Common problems of KDE4 using Nvidia GPUs

Dekans
Registered Member
Posts
11
Karma
0
OS
I have a weird issue.

The text in GTK or Qt3 apps is not displayed. (Except for Firefox)

ImageImage

I only happens when I enable desktop effects.

I have a Geforce 4 GO 440, 96.43.09 nvidia driver on Kubuntu Intrepid

EDIT : This is a nvidia beta driver bug, I had my answer.

Last edited by Dekans on Thu Nov 06, 2008 5:22 pm, edited 1 time in total.


Dekans, proud to be a member of KDE forums since 2008-Oct.
User avatar bcooksley
Administrator
Posts
19759
Karma
86
OS
For those of you still with problems, apparently according to here Nvidia beta 180.08 update makes things much better.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar R_Rios
Registered Member
Posts
126
Karma
0
OS
bcooksley wrote:For those of you still with problems, apparently according to here Nvidia beta 180.08 update makes things much better.


YES!

Thins are REALLY much better.

This is a MUST update.


J/K (on the square)
User avatar Moult
Global Moderator
Posts
663
Karma
2
OS
Woohoo! Nvidia-drivers update (keyworded) on Gentoo make a difference. Not as mind-blastingly fast as I would've hoped, but perhaps that's because KWin isn't as optimised as the Compiz-Fusions that I'm used to.


Moult, proud to be a member of KDE forums since 2008-Oct.
thinkMoult - source for tech, art, and animation: hilarity and interest ensured!
WIPUP.org - a unique system to share, critique and track your works-in-progress projects.
User avatar neversfelde
Global Moderator
Posts
55
Karma
0
OS
I have some problems with fonts in several application, but I can confim that performance is much better with 180.08 beta on intrepid. Tray loks goog, but only with desctop effects disabled.


neversfelde on irc.freenode.net
http://www.kubuntu-de.org
User avatar google01103
Manager
Posts
6668
Karma
25
neversfelde wrote:I have some problems with fonts in several application, but I can confim that performance is much better with 180.08 beta on intrepid. Tray loks goog, but only with desctop effects disabled.


There appears to be a known font corruption problem with the 180.08 beta
http://www.nvnews.net/vbulletin/showthr ... ?p=1852889


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar neversfelde
Global Moderator
Posts
55
Karma
0
OS
google01103 wrote:There appears to be a known font corruption problem with the 180.08 beta
http://www.nvnews.net/vbulletin/showthr ... ?p=1852889


Thank you for that information, i'll try the workaround recommended in that thread.


neversfelde on irc.freenode.net
http://www.kubuntu-de.org
User avatar KejPi
Registered Member
Posts
119
Karma
0
OS
I still have a visual glitches problem with tray (compiled from SVN on Saturday). There is still problem with icons background. When kopepe new message is recaived then the iscon animation is somehow drawn over the normal "bubble" icon. Anyone ale has this problem? Is it an NVidia problem?

I am using NVidia driver 177.80 on 7600GS card. But the is no difference with tray behaviour using 180.08.


KejPi, proud to be a member of KDE forums since 2008-Oct.
User avatar neversfelde
Global Moderator
Posts
55
Karma
0
OS
KejPi wrote:I still have a visual glitches problem with tray (compiled from SVN on Saturday).


I am using xinerama and so desctop effects are turned off. Probably tray looks better without effects?


neversfelde on irc.freenode.net
http://www.kubuntu-de.org
User avatar KejPi
Registered Member
Posts
119
Karma
0
OS
neversfelde wrote:
KejPi wrote:I still have a visual glitches problem with tray (compiled from SVN on Saturday).


I am using xinerama and so desctop effects are turned off. Probably tray looks better without effects?


Yes, it looks better but still not perfect.


KejPi, proud to be a member of KDE forums since 2008-Oct.
User avatar neversfelde
Global Moderator
Posts
55
Karma
0
OS
KejPi wrote:Yes, it looks better but still not perfect.


Did you try 180.08 without effects? looks nearly perfect here after starting all apps.


neversfelde on irc.freenode.net
http://www.kubuntu-de.org
User avatar KejPi
Registered Member
Posts
119
Karma
0
OS
neversfelde wrote:
KejPi wrote:Yes, it looks better but still not perfect.


Did you try 180.08 without effects? looks nearly perfect here after starting all apps.


No I didn't. I'll try this week and maybe post some screenshots.


KejPi, proud to be a member of KDE forums since 2008-Oct.
User avatar sayakb
Administrator
Posts
1973
Karma
12
OS
I found out that switching to XAA rendering solves some of the problems. I have two computers, one with a 945GM and other with a 965GM onboard. Edit your /etc/X11/xorg.conf file to find this section:
Code: Select all
Section "Device"
        Identifier      "Configured Video Device"
EndSection


And add a line to it to make it look like this:
Code: Select all
Section "Device"
        Identifier      "Configured Video Device"
        Option          "AccelMethod" "XAA"
EndSection


Save the file and reboot.

Last edited by sayakb on Tue Dec 02, 2008 10:23 am, edited 1 time in total.


User avatar KejPi
Registered Member
Posts
119
Karma
0
OS
neversfelde wrote:
KejPi wrote:Yes, it looks better but still not perfect.


Did you try 180.08 without effects? looks nearly perfect here after starting all apps.


Driver 177.80 with composite when all application started:
Image

Driver 177.80 with composite after twice clicking on arrow:
Image

Driver 180.08 no composite:
Image

Driver 180.08 composite when kopete message arrives:
Image

As you can see there are some problems after startup when there is someting hidden there (in my case kwallet) but it is probably not problem of graphic card driver. But there is a problem with icons drawing - it is better for 180.08 but still kopete message animation does not work with enebled effects. Without effects and 180.08 it is almost perfect.


KejPi, proud to be a member of KDE forums since 2008-Oct.
User avatar KejPi
Registered Member
Posts
119
Karma
0
OS
New NVidia beta driver 180.11 has been released. Hopefully it will fix something ;-)

http://www.nvnews.net/vbulletin/showthr ... ?p=1861825


KejPi, proud to be a member of KDE forums since 2008-Oct.

 
Reply to topic

Bookmarks



Who is online

Registered users: 1user2, 1ykos, aureotoshi, Baidu [Spider], bartoloni, Bing [Bot], Exabot [Bot], funkybomber, gdrift, gfielding, Google [Bot], jacob-em, johssw, jSim, Sogou [Bot], strag, thugo, tosky, Yahoo [Bot]