Reply to topic

I can't browse my phone with KDE Connect

User avatar jeanv
Registered Member
Posts
10
Karma
0
If I try to browse my phone through KDE Connect, Dolphin freezes for 30 seconds or so then tells me:
Code: Select all
The file or folder /home/jean/.config/kdeconnect/9a8b63987a327f12/kdeconnect_sftp/9a8b63987a327f12/storage/emulated/0 does not exist.

And indeed, /home/jean/.config/kdeconnect/9a8b63987a327f12/kdeconnect_sftp/9a8b63987a327f12 is empty when I check in the terminal.

Some infos:
  • I am on KDE Neon User Edition, up-to-date (Plasma 5.10.3, KDE Frameworks 5.35, Qt 5.9, Kernel 4.8.0)
  • The folder indeed doesn't exist even looking with the command line, so it's probably not a Dolphin problem
  • Every options in the android app is enabled (except for receive notificatons)
  • Sending files from my smartphone to my computer works
  • Notifications, multimedia control, mouse and keyboard, texts, ping... all work
Maybe I'm missing some required packages?
It seems like the filesystem is not mounted because I don't see anything mounted as sshfs with the mount command.
Any idea? Even a workaround would be appreciated, like mounting manually (I'd love to at least know the options used to mount, maybe I could try manually then), browsing through command line, etc.
aus9
Karma
0
I had similar issues and resolved mine by installing and using a third party package
viewtopic.php?f=14&t=140847
User avatar jeanv
Registered Member
Posts
10
Karma
0
Thanks for your help but my problem is not with MTP, it's with KDE Connect
aus9
Karma
0
my apols I have only just enabled kdeconnect and can see the same error message. After pairing I elected to allow notifications.

Code: Select all
groups


and notice you, assuming you want to do this as a non-root user are not part of sshusers as per
https://wiki.archlinux.org/index.php/SCP_and_SFTP

when I tried to start sshd I found no such service, YMMV
Code: Select all
systemctl list-unit-files | less  (or grep ssh)


also I found openssh-sftp-server was not installed but when I installed it it made no diff.

so um I am going bale out of this discovery as I can transfer files using my method....sorry

it looks like you "may" need to set up ssh and sftp for local user....but I am not sure
https://linuxconfig.org/how-to-install- ... el-7-start
https://wiki.archlinux.org/index.php/Secure_Shell
http://man7.org/linux/man-pages/man5/ssh_config.5.html

good luck
TomasM
Registered Member
Posts
1
Karma
0
Did you find a solution?

I had to disable the 'Share and receive' plugin on my phone.
CnZhx
Registered Member
Posts
16
Karma
0
OS
I've had this problem for more than two months (I cannot remember when it started happening) and still cannot find a solution or explanation on this. But it worked before.

P.S. Anyone knows how to reset the configurations and sets kde-connect again? Or, has anyone tried this?
emper
Registered Member
Posts
2
Karma
0
I also had trouble making a connection between my computer and phone. I have 2 computers running kubuntu 18.04. One worked fine (#1), The other computer (#2) didn't show up on the phone "available devices" and the phone didn't show up on the computer device list.
It was not a problem with firewalls.
By going through the settings and comparing the settings of #1 and #2 I saw that a difference was in the ~/config/kdeconnect/config.
I deleted ~/config/kdeconnect
Restarted kdeconnectd
And it worked,

Try deleting ~/config/kdeconnect.
dougw
Registered Member
Posts
1
Karma
0
I tried deleting ~/config/kdeconnect and it did not solve my problem.
What did work for me was to unpair my phone and establish pairing again. When I then gave permission to Filesystem Expose everything worked.
User avatar hotzek
Registered Member
Posts
10
Karma
0
OS
Same poblem here since a few days.

- Deleting ~/config/kdeconnect did not solve the problem.
- Reinstalling KDE Connect on the Phone and PC did not help
- Unpairing did not help

The only problem are the filebrowsing. All other "tools" work fine (extern mouse; ping...).
I think its more a phone-Problem. I can't access the Phone Files from differnt pc's using kde connect.

Any ideas ?
Maybe its a bug ?
domainadministrator
Registered Member
Posts
1
Karma
0
Yep, I had exactly the same problem. It was KDE Connect 1.10. Went back to 1.8.4 and hey presto!
https://www.apkmirror.com/apk/kde-community/kde-connect/kde-connect-1-8-4-release/kde-connect-1-8-4-2-android-apk-download/
drreid3
Registered Member
Posts
5
Karma
0
I'm having the same issue with file browsing. I'm on Kubuntu 16.04. I've tried the same procedure as emper to no avail. I've also upgraded to version 1.0.3 from https://launchpad.net/~webupd8team/+arc ... kdeconnect still no luck.
User avatar Gheesh
Registered Member
Posts
2
Karma
0
OS
domainadministrator wrote:Yep, I had exactly the same problem. It was KDE Connect 1.10. Went back to 1.8.4 and hey presto!
https://www.apkmirror.com/apk/kde-community/kde-connect/kde-connect-1-8-4-release/kde-connect-1-8-4-2-android-apk-download/


Downgrading the phone's KDE Connect app was the only solution that worked for me. BTW, I did not know APK Mirror but I was able to download version 1.8.4 also from https://f-droid.org (App available too)
drreid3
Registered Member
Posts
5
Karma
0
After checking the release notes for the KDE Connect Android app, it says if file browsing isn't working for you to upgrade to version 1.3.2. I haven't tried it yet. Available for download https://download.kde.org/stable/kdeconnect/
nmendoza
Registered Member
Posts
1
Karma
0
How do I install version 1.3.2 ? I tried classic compile from source following googled instructions, but I couldn't find out how...

Same problem here with Kubuntu 18.04 and Kdeconnect 1.3.1

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Exabot [Bot], Google [Bot], mekschr, nnate, nybac, peje, rejrashi, smankowski