Reply to topic

Konqueror is so much improved

john_hudson
Registered Member
Posts
549
Karma
2
OS

Konqueror is so much improved

Wed Aug 09, 2017 4:42 pm
Having just installed openSUSE Leap 42.3 I am really impressed with the work done on Konqueror. For the first time in several years, it works reliably on every website I have visited so far. There are still a few rough edges but as a web browser it is back where it used to be. All power to your elbows and keep up the good work.


John Hudson, proud to be a member of KDE forums since 2008-Oct.
wolfi323
Registered Member
Posts
1119
Karma
11
OS

Re: Konqueror is so much improved

Wed Aug 09, 2017 5:06 pm
TBH, that's rather work being done on the rendering engines that Konquorer can use... ;)
Konqueror itself is basically just an empty shell that can embed other "applications" (so-called KParts).

Although, konqueror itself does come with a new webenginepart now that uses Qt's QtWebEngine (that's based on Chromium).
But in openSUSE, we still default to the kwebkitpart, using QtWebKit, for several reasons. Which has been improved too of course, and will be even more in the future as it's development has been resurrected.
You can install webenginepart too though if you want. (and choose the preferred backend in Konqueror's settings, or even choose on the fly via the "View" menu)
User avatar SomeOldFool
Registered Member
Posts
35
Karma
0
OS

Re: Konqueror is so much improved

Thu Aug 10, 2017 6:52 pm
I have a different experience. I've used Konqueror as a file manager forever; it's more configurable by far than Dolphin, and it always opens to my preferred profile. But the newest version that comes with Fedora 26 opens to a 'malformed url' page. I can set it up as before, but the 'save profile' (web browsing, file management, etc) option is no longer there.

I can save my setup as a session, but there is also no way to make it a default session, so it still opens to the malformed url page. Once I go into the menu and click the session it opens a whole new instance of Konqueror, so I have to close the malformed instance.

I solved the above ^^^ but the double-clicking is still aggravating me.
Also there is no option for single-click any more in Konqueror, and even though I have single-click chosen in KDE global settings, I still have to double-click in Konqueror. And any Krusader mouse setting are not obeyed; it also is double-click only.
wolfi323
Registered Member
Posts
1119
Karma
11
OS

Re: Konqueror is so much improved

Mon Aug 14, 2017 12:31 pm
SomeOldFool wrote:I have a different experience. I've used Konqueror as a file manager forever;

Well, the OP was about Konquerer as *web browser* though, but ok.

it's more configurable by far than Dolphin, and it always opens to my preferred profile. But the newest version that comes with Fedora 26 opens to a 'malformed url' page. I can set it up as before, but the 'save profile' (web browsing, file management, etc) option is no longer there.

As I wrote before, Konqueror is just an empty shell, and it actually embeds dolphin for file management since 4.0.
So filemanagement should work just as well (or not) as in dolphin, and it never had more (working) options in this regard since about ten years.

You are right though that profiles have been removed from konqueror.
I understand that they were considered as not relevant anymore, I'm not a konqueror developer though.

Running something like "konqueror ~" or "kfmclient openURL" (see the output of "kfmclient --commands") should help you though.

I solved the above ^^^ but the double-clicking is still aggravating me.
Also there is no option for single-click any more in Konqueror, and even though I have single-click chosen in KDE global settings, I still have to double-click in Konqueror. And any Krusader mouse setting are not obeyed; it also is double-click only.

That's just not true.
Konqueror respects the single/double click option just fine, like dolphin does.

It is taken from the running desktop in Qt5 though (or rather from the used platform plugin).
So, KDE's "global" options only apply if you run it in a KDE desktop (i.e. Plasma).
If you are not using Plasma, you have to adjust that other desktop's options, if possible.
A side-note: some distributions configure qt5ct to automatically override the platform plugin, so if you have that installed it may very well be the reason for this.

And Krusader is a completely different application, so I don't see why you even consider its options to be respected by konqueror (or vice-versa).
If you mean that krusader has the same "problem" as konqueror, then it leads back to a general Qt5 "problem" though (and see the previous paragraph for that).
User avatar SomeOldFool
Registered Member
Posts
35
Karma
0
OS

Re: Konqueror is so much improved

Mon Aug 14, 2017 1:10 pm
"That's just not true."
It absolutely is true. In Fedora 25 the latest version of Dolphin had the option to select single or double click under preferences/general/behavior, but the version in Fedora 26 does not have that option. The only things on that tab now are about folder properties, sorting, and tooltips. I looked on all the tabs and that option is nowhere to be found. But it was there a month ago in the previous version.

I mentioned Krusader because previously I could set it to "Use KDE global selection policy' and it did. Now it doesn't obey it, hence I have only double-click in Krusader also. And by the way, I use XFCE4, and know from experience KDE apps running on that desktop DO follow KDE global settings. And I do have QT5 configuration settings to 'Activate item on single-click.
wolfi323
Registered Member
Posts
1119
Karma
11
OS

Re: Konqueror is so much improved

Mon Aug 14, 2017 7:42 pm
SomeOldFool wrote:"That's just not true."
It absolutely is true. In Fedora 25 the latest version of Dolphin had the option to select single or double click under preferences/general/behavior, but the version in Fedora 26 does not have that option.

As I wrote, this is a desktop wide option.

And as it ever was a desktop wide option, it has been removed from dolphin's (or konqueror's as a consequence) options.

And by the way, I use XFCE4

And that's your problem then.

Maybe you should consider installing qt5ct then and configure it there if possible. (AFAIK, XFCE4 doesn't provide a plugin for Qt5)
Or do something like "export QT_QPA_PLATFORMTHEME='kde'" to make the applications think they do run in a KDE desktop.

Nothing specific to Konqueror though, that is a Qt5 "problem" (it tries to adapt to the desktop, and needs a plugin for that).

And the same applies to current krusader versions.
User avatar SomeOldFool
Registered Member
Posts
35
Karma
0
OS

Re: Konqueror is so much improved

Mon Aug 14, 2017 9:03 pm
I do have qt5ct installed and configured for single-click. I also have single-click selected in XFCE settings, and KDE settings. As an experiment I booted to the plasma desktop and neither Konqueror or Dolphin will single-click there either, even with single-click selected in KDE settings. Nor will Krusader single click when set to 'Obey KDE's global selection policy'. BTW it's the same way on both my desktop and laptop machines. I think we have it narrowed down to a problem in the settings module. I did looked in ~.kde/share/config/kdeglobals and it's SingleClick=true in there.
wolfi323
Registered Member
Posts
1119
Karma
11
OS

Re: Konqueror is so much improved

Wed Aug 23, 2017 6:41 pm
Sorry for the delayed answer, I was away for a few days...

SomeOldFool wrote:I do have qt5ct installed and configured for single-click.

For qt5ct to work, you need to set QT_QPA_PLATFORMTHEME='qt5ct' .
Some distributions do that by default if you install qt5ct, but I have no idea if yours does (openSUSE does at least, no idea about Fedora).

As an experiment I booted to the plasma desktop and neither Konqueror or Dolphin will single-click there either, even with single-click selected in KDE settings.

Both should.

But only if you have the plasma-integration-plugin installed.
Sorry, forgot to mention that, but if you have Plasma installed that should be there too (if not, it's a bug in your distribution).


I think we have it narrowed down to a problem in the settings module. I did looked in ~.kde/share/config/kdeglobals and it's SingleClick=true in there.

That's the KDE4 setting, and is not respected by KF5 applications like konqueror, dolphin and krusader are now.

But maybe we narrowed it down really now.

What's in ~/.config/kdeglobals ?
You need to use systemsettings5 to configure KF5. If you use systemsettings (the KDE4 version), it won't have any effect...
User avatar SomeOldFool
Registered Member
Posts
35
Karma
0
OS

Re: Konqueror is so much improved

Wed Aug 23, 2017 10:02 pm
OK I figured it out (accidentally). In QT5 settings the 'activate items on single click' box had a gray circle in it. I decided to clear it and re-check it and when I did an actual ✔appeared in the box instead of the gray circle and now I have single-click everywhere; Konqueror, Dolphin, and Krusader. Looking at that originally it looked as if single-click was already chosen. Since clearing the box the gray circle doesn't come back; it's either an empty box or a ✔
Thanks for your time :-)

 
Reply to topic

Bookmarks



Who is online

Registered users: alfredod, apachelogger, Baidu [Spider], bartoloni, Bing [Bot], Exabot [Bot], Google [Bot], Majestic-12 [Bot], omlx, Sogou [Bot], Yahoo [Bot]