Reply to topic

KDECONNECT 1.4.0

pcdos
Registered Member
Posts
7
Karma
0

KDECONNECT 1.4.0

Fri Apr 24, 2020 2:11 pm
KDEconnect 1.4.0 does not recognize my samsung J1 ACE phone. With KDEconnect 1.3.5 I had no problems. :|
User avatar fabiom
Registered Member
Posts
16
Karma
0
OS

Re: KDECONNECT 1.4.0

Mon Apr 27, 2020 10:29 pm
I have phone samsung A10 kde connect 1.4.0 my KDE neon work fine.
pcdos
Registered Member
Posts
7
Karma
0

Re: KDECONNECT 1.4.0

Tue Apr 28, 2020 4:45 pm
I will have to buy another newer phone :'( , but for now I return to Debian 10 with KDE plasma ^-^
pcdos
Registered Member
Posts
7
Karma
0

Re: KDECONNECT 1.4.0

Tue Apr 28, 2020 8:16 pm
A friend told me to try kubuntu 19.10 and the truth is wonderful, it detects absolutely all the phones that I connect, my samsung j1, a samsung j2 and a samsung a10 from a friend. Obviously something is wrong with KDEConenct on Kubuntu 20.04. Kubuntu 19.10 has KDEConnect 1.3.5, Kubuntu 20.04 uses kdeconnect 1.4.0. Debian 10 KDE has KDEConnect 1.0.3 or 1.3.3, I don't remember why I uninstalled it to test Kubuntu 19.10, and it works very well too. Something is not right in Kdeconnect 1.4.0
User avatar claydoh
Registered Member
Posts
630
Karma
5
OS

Re: KDECONNECT 1.4.0

Tue Apr 28, 2020 10:42 pm
One thing to make sure you do, when changing versions, whether it is the app or on the desktop, is to unpair, on both systems if it does show on the PC, and clear the phone app data. Sometimes the fingerprint for the devices changes, and things don't work. since they are marked as paired but the ID does not match.

Also try pairing from the phone via the computer's ip address.

KDE Connect works fine on all three of my LG phones, including my 5 year old G4. But on occasion I have to reset the app data on them, and re-pair, particularly when I have installed a new OS, or there has been an app update, which has happened in the past week or so I believe.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
User avatar raphaelra
Registered Member
Posts
161
Karma
0
OS

Re: KDECONNECT 1.4.0

Wed Apr 29, 2020 8:11 am
claydoh wrote:KDE Connect works fine on all three of my LG phones, including my 5 year old G4.

How do you connect your phones ? Wi-Fi or Bluetooth ?
albenson
Registered Member
Posts
34
Karma
1

Re: KDECONNECT 1.4.0

Wed Apr 29, 2020 8:14 am
pcdos wrote:A friend told me to try kubuntu 19.10 and the truth is wonderful, it detects absolutely all the phones that I connect, my samsung j1, a samsung j2 and a samsung a10 from a friend. Obviously something is wrong with KDEConenct on Kubuntu 20.04. Kubuntu 19.10 has KDEConnect 1.3.5, Kubuntu 20.04 uses kdeconnect 1.4.0. Debian 10 KDE has KDEConnect 1.0.3 or 1.3.3, I don't remember why I uninstalled it to test Kubuntu 19.10, and it works very well too. Something is not right in Kdeconnect 1.4.0


My main OS is KDE Neon User Edition, which uses KDE Connect 1.4.0, and it works very well. I've been trying out Kubuntu 20.04 on the same machine, and KDE connect is having trouble. I can't transfer files with KDE Connect at all with Kubuntu 20.04 on either end. Neon to Neon works great!

Other KDE Connect functions (remote keyboard, ping, shared clipboard, etc) work with Kubuntu 20.04, but it just randomly stops working and unpairs quite often. This is over a Samba network. I keep re-pairing them, and it keeps doing this. I think it may have helped to delete the KDE connect folder from ~/.config, with the pairing issue I mean, but still no file transfers.

The above installation of Kubuntu 20.04 was upgraded from 18.04 (via 19.10, since Ubuntu has blocked upgrades from LTS to LTS until July). To rule that out as the source of the issue, I tried downloading the Kubuntu 20.04 ISO and writing that to a USB drive and booting to a live session, and it did pair just fine, but it still won't transfer any files.

It's not KDE Connect 1.4.0 at fault, though, as that is the version in Neon, and it works beautifully. Either Kubuntu modified the package somehow or some other package (Samba version?) is not the same. I had hoped that the Samba updates from yesterday would help in 20.04, but they made no difference for this issue.
User avatar claydoh
Registered Member
Posts
630
Karma
5
OS

Re: KDECONNECT 1.4.0

Wed Apr 29, 2020 11:01 am
raphaelra wrote:
claydoh wrote:KDE Connect works fine on all three of my LG phones, including my 5 year old G4.

How do you connect your phones ? Wi-Fi or Bluetooth ?


My Kdeconnect has always worked over a network connection. I am not sure if bluetooth support is official yet., or even compiled in to the software for me. I certainly don't have any options for it anywhere, and it definitely stops working or seeing devices when wifi is off.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
User avatar raphaelra
Registered Member
Posts
161
Karma
0
OS

Re: KDECONNECT 1.4.0

Wed Apr 29, 2020 12:18 pm
claydoh wrote:I am not sure if bluetooth support is official yet., or even compiled in to the software for me. I certainly don't have any options for it anywhere, and it definitely stops working or seeing devices when wifi is off.

I'm asking, because Mamarok wrote, it works for her on Kubuntu and I can't get it working on Neon. Anyway, thanks for reply :)
User avatar claydoh
Registered Member
Posts
630
Karma
5
OS

Re: KDECONNECT 1.4.0

Wed Apr 29, 2020 2:30 pm
raphaelra wrote:
claydoh wrote:I am not sure if bluetooth support is official yet., or even compiled in to the software for me. I certainly don't have any options for it anywhere, and it definitely stops working or seeing devices when wifi is off.

I'm asking, because Mamarok wrote, it works for her on Kubuntu and I can't get it working on Neon. Anyway, thanks for reply :)



Looking at the build and packaging info, it does not look like bluetooth support is enabled at compile time in Kubuntu for the desktop app, not sure if the option is enabled on the Play Store app . Mamarok may be mistaken.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
User avatar Mamarok
Manager
Posts
4847
Karma
12
OS

Re: KDECONNECT 1.4.0

Sat May 02, 2020 9:30 am
No,I am not mistaken, my bluetooth works like a charm with KDE Connect in both Kubuntu 19.10 and 20.04 :-) Never used KDE Connect over WiFi


Currently running Kubuntu 20.04, Plasma 5.18.5, Frameworks 5.68.0, Qt 5.12.8, kernel 5.4.0-42
FWIW: it is always useful to state the exact Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
pcdos
Registered Member
Posts
7
Karma
0

Re: KDECONNECT 1.4.0

Thu May 28, 2020 1:27 pm
KDEconnect 1.4.0 does not work well on WIFI networks. It does not detect any of my Samsung J1, J2, A10 phones >:(
pcdos
Registered Member
Posts
7
Karma
0

Re: KDECONNECT 1.4.0

Wed Jun 03, 2020 11:46 pm
Confirmed KDECONNECT 1.4.0 on Kubuntu not working. Install KDE Neon 20200528 and KDEconnect works fine, detect my mobiles :) Kubuntu should check what's going on.
albenson
Registered Member
Posts
34
Karma
1

Re: KDECONNECT 1.4.0

Sun Jul 19, 2020 8:42 am
Well, it does look like the dysfunctional KDE Connect could be coming to Neon too.

Ever since I upgraded to the 20.04 rebase (Neon User) for testing purposes, KDE Connect has not worked on my upgraded Neon PC either, exactly the same as the Kubuntu 20.04 installation.

I mentioned it in the thread requesting testing for Neon rebased to 20.04, but I don't know if the devs read that. It could be fixed before the rebase goes gold, but you never know.

Anyone know if there is an open bug for this?
User avatar claydoh
Registered Member
Posts
630
Karma
5
OS

Re: KDECONNECT 1.4.0

Sun Jul 19, 2020 4:27 pm
I am running Neon 20.04 via upgrade, and have had no issues with KDE Connect so far.
It is the same current version on both my 18.04 and 20.04 systems. Both work as expected.

Currently using it with:
LG V60 (Android 10, and using the Beta app for clipboard sharing support)
LG V30 (Android 8 )
LG G4 (Android 8 via Lineage OS)

Not sure if it matters, but all my phones seem to have the beta app version 1.14.2, which has a workaround for Android 10's disabling the ability to share the clipboard.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], dbergstein, dochonglo976, Google [Bot], grahm, hensem, irvingarrietavazquez, Majestic-12 [Bot], Sarah_Caterina, Sogou [Bot], Stephen Leibowitz