Reply to topic

Konqueror 4.3.4 generates QPainter errors

Krunchoote
Registered Member
Posts
11
Karma
0
OS
I'm running KDE 4.3.4 on FreeBSD-RELEASE-8.0
starting Konqueror generates this on console:

    QPainter::translate: Painter not active
    QPainter::setClipRect: Painter not active
    QPainter::hasClipping: Painter not active
    QPainter::setPen: Painter not active
    QPainter::setBrush: Painter not active
    QPainter::drawRects: Painter not active
    QPainter::font: Painter not active
    QPainter::setFont: Painter not active
    QPainter::font: Painter not active
    QPainter::setFont: Painter not active
    QPainter::setPen: Painter not active
    QPainter::hasClipping: Painter not active
    QPainter::setPen: Painter not active
    QPainter::setBrush: Painter not active
    QPainter::drawRects: Painter not active
    QPainter::hasClipping: Painter not active
    QPainter::setPen: Painter not active
    QPainter::setBrush: Painter not active
    QPainter::drawRects: Painter not active
    QPainter::hasClipping: Painter not active

Please help, I'm new to KDE.
Pconfig
Alumni
Posts
74
Karma
0
OS
That's not necessarily a real bad thing. Do you notice anything wrong when using konquerer? What window/widget style are you using?
User avatar bcooksley
Administrator
Posts
19743
Karma
85
OS
These messages are normal and can be safely ignored.


System Settings and Device Actions KCM maintainer
Image
Krunchoote
Registered Member
Posts
11
Karma
0
OS
bcooksley wrote:These messages are normal and can be safely ignored.

So for what use these messages are created?
For me it suggests there is something broken.
User avatar bcooksley
Administrator
Posts
19743
Karma
85
OS
Those messages a warnings from Qt itself. It is a known issue, however I do not think the KHTML developers have been able to resolve it at this time. Many other applications, such as Amarok also print these messages.


System Settings and Device Actions KCM maintainer
Image
kcsibk
Registered Member
Posts
1
Karma
0
OS
On my most recent installation, it IS a VERY bad thing as my console is displaying MORE than 8,000 such QPainter error lines per second!! (I logged them for 9.5 hours and had more than 28 millions lines (1+ GB).) It is certainly negatively impacting performance speed!

I'm running FreeBSD 8.1-RELEASE according to portsnap fully up-to-date with KDE 4.5.5 on a Dell Inspiron 1720 with NVIDIA GPU GeForce 8600M GT (G84).

My first question is: if the main complaint is "Painter not active", would it help to make "Painter" active?

--

Reading elsewhere, I agree that it is not a Konqueror problem, but (in my case anyway) probably just KDE's plasma-desktop - which I haven't been able to actually turn off.

For reference, here are some more recent threads regarding the issue:

Bug 174365 - kdm should limit the size of .xsession-errors
https://bugs.kde.org/show_bug.cgi?id=174365

Bug 227697 - several kde-apps are spamming .xsession-errors
https://bugs.kde.org/show_bug.cgi?id=227697

Both of these talked about avoiding running out of drive space due to rapidly expanding the .xession-errors log file (which I don't have), but I believe my system is just scrolling them on the console. But whether they're directed to /dev/null or simply scrolling off the not visible 'console', don't the excessive QPainter errors still consume precious system CPU time?
User avatar bcooksley
Administrator
Posts
19743
Karma
85
OS
Excessive QPainter errors still consume some CPU time, as the text has to be generated, written out to a i/o device, etc.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], cerien, davidemme, Earthwings, Exabot [Bot], Google [Bot], google01103, jkolodziej, k_sze, lazyit, Majestic-12 [Bot], metzman, Quardah, robson, smankowski, Soukyuu, Steve Guilford, TheraHedwig, tokiedian, Yahoo [Bot]