Reply to topic

Weirdness with GTK sounds

thedayofcondor
Registered Member
Posts
11
Karma
0

Weirdness with GTK sounds

Thu Nov 06, 2008 11:19 pm
Hi,
not sure this is the right place, but I will give it a try anyway.
Is KDE4 "importing" gnome sounds? If I minimize/maximize for example firefox in kde4 i get a very annoying "plop" sound.

In addition of being extremely annoying (I have not found a way to disable it, sound is disabled in the gnome control centre), lately, after an update, every time I max/min firefox or other non kde apps the master audio channel volume is raised to the maximum (in a weird way, kde sounds stay the same volume, kmix shows the channel volume maximised, but only "gtk sounds" are at max volume - kde sounds stay the same).

Please give me some tips, this is driving me crazy - i keep my amplifier volume very high, I prefer to control the sound with kmix than with the remote.

Than k you


thedayofcondor, proud to be a member of KDE forums since 2008-Oct.
User avatar bcooksley
Administrator
Posts
19759
Karma
87
OS

RE: Weirdness with GTK sounds

Fri Nov 07, 2008 9:24 am
Are you using KWin? these sounds can be triggered by KWin on certain events and played through KNotify. All KDE applications play notifications through KNotify, and it provides a central point for configuring all KDE application notifications.

In your case, check System Settings > Look & Feel > Notifications > System Notifications. Select "The KDE Window Manager" from the "Event source:" drop down box. Then you can see the various KWin notifications available, enable / disable them and change the sound played.

Alternatively, check to make sure Compiz is not active, or its sounds are disabled. If you want to use KWin, it can be changed in System Settings > Personal > Default Applications > Window Manager. select "Use the default KDE window manager (KWin)"


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
thedayofcondor
Registered Member
Posts
11
Karma
0

RE: Weirdness with GTK sounds

Fri Nov 07, 2008 3:16 pm
Hi,
this seems not related to kwin (I checked, i am using it) or the KDE system notifications system, as it is affecting only non native kde apps.

In gnome control panel, these sounds I am hearing are set as a default for window minimise/maximise, but they are disabled. it seems kde is loading in some way the gnome settings, but it is disregarding the fact they are disabled and it is not providing any way to turn them off. I will check more settings, but I have tried everything already (I noticed one week ago).


thedayofcondor, proud to be a member of KDE forums since 2008-Oct.
thedayofcondor
Registered Member
Posts
11
Karma
0

RE: Weirdness with GTK sounds

Fri Nov 07, 2008 7:03 pm
I solved the volume problem at least - just commenting out

### Enable flat volumes where possible
#load-module module-flat-volume

in /etc/pulse/default.pa

However, I still want to get rid of the annoying sounds.


thedayofcondor, proud to be a member of KDE forums since 2008-Oct.
User avatar bcooksley
Administrator
Posts
19759
Karma
87
OS

RE: Weirdness with GTK sounds

Fri Nov 07, 2008 9:42 pm
Since ( as far as I am aware ) KDE 4 does not import Gnome settings, it has to be Gnome ignoring it's own settings, given that it is the Gnome sounds playing, and only with Gnome applications.

I have never installed Gnome, let alone used it, so I cannot provide you with any pointers to where the setting may be. The only thing I can think of, is that you have not actually turned the notification off.

Another thing that could be happening is that the settings are not being refreshed by the Gnome applications, and are thus are still using the old settings. Try logging out then back in, and see if it still happens.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar anda_skoa
KDE Developer
Posts
783
Karma
4
OS

RE: Weirdness with GTK sounds

Sat Nov 08, 2008 11:11 am
My guess is that this is the new "sound theming" http://freedesktop.org/wiki/Specificati ... theme-spec using libcanberra http://0pointer.de/lennart/projects/libcanberra/

You might be able to get help for that on either a Mozilla forum/list, one for GNOME or at the spec/lib maintainer himself.

Cheers,
_


anda_skoa, proud to be a member of KDE forums since 2008-Oct.
ekeluo
Registered Member
Posts
10
Karma
0
OS

Re: Weirdness with GTK sounds  Topic is solved

Sat Oct 10, 2009 7:04 pm
Solution for any one still affected:
Append to ~/.gtkrc-2.0-kde4:

gtk-enable-event-sounds=0
gtk-enable-input-feedback-sounds=0
User avatar Stefan
Registered Member
Posts
15
Karma
0
OS

Re: Weirdness with GTK sounds

Wed Oct 14, 2009 11:02 am
ekeluo wrote:Solution for any one still affected:
Append to ~/.gtkrc-2.0-kde4:

gtk-enable-event-sounds=0
gtk-enable-input-feedback-sounds=0


Great! Thanks for sharing. That works perfectly.
User avatar Timo
Registered Member
Posts
51
Karma
0
OS

Re: Weirdness with GTK sounds

Sat Nov 07, 2009 12:37 pm
+1 the two lines work.

They get overwritten if anything in appearance for gtk-apps is changed in systemsettings.

Thanks for the hint.
User avatar tallship
Registered Member
Posts
1
Karma
0
OS

Re: Weirdness with GTK sounds

Wed Mar 24, 2010 12:57 pm
Stefan wrote:
ekeluo wrote:Solution for any one still affected:
Append to ~/.gtkrc-2.0-kde4:

gtk-enable-event-sounds=0
gtk-enable-input-feedback-sounds=0


Great! Thanks for sharing. That works perfectly.


Yup. Wish I had found this ages ago LOL!
User avatar Dread Knight
Registered Member
Posts
14
Karma
0
OS

Re: Weirdness with GTK sounds

Thu May 06, 2010 12:58 pm
Another way to get rid of the sounds:

Code: Select all
sudo apt-get remove libcanberra-gtk-module


Online Free Open Source PvP TBS Game - http://www.AncientBeast.com
Free Open Source Game Dev and Tutorials - http://www.FreezingMoon.org

 
Reply to topic

Bookmarks



Who is online

Registered users: alcinos, Arran, Baidu [Spider], Bing [Bot], boudewijn, Exabot [Bot], GamingAori, Google [Bot], jepe, kavisriranjan, kc1di-qrp, Rytelier, Sogou [Bot], vapip05, Yahoo [Bot]