Reply to topic

oh pulse audio and alsa, how do we get along?

chuckc
Registered Member
Posts
5
Karma
0
first of all, I never installed alsa but it seems to be default part of linux? I installed pulse audio but alsa seems to be the driver? I'm a bit confused as to how they work together.

I get very strange audio behavior in kde.

On startup, sound is muted. PulseAudio wiki suggests changing a setting in alsa mixer. I do not have alsa mixer. I dont want to install it either if I dont have to. I would like to just use pulse.

Secondly, when I get an IM from telepathy, my audio level is forced to 66% for the beep and stays at 66% after the beep. So if I'm listening to music at 100% and I get an IM my sound is reduced to 66% until I manually raise it back up to 100% but then next msg sends it right back to 66%

This is super annoying. Again, I tried the pulse wiki and it says to disable by uncommenting
/etc/pulse/default.pa

### Cork music/video streams when a phone stream is active
# load-module module-role-cork

and then restarting pulse.

this did not work.

As the wiki is failing me, I thought perhaps KDE forum might have an answer. I am running KDE on Arch Linux and using the latest version 4.13.2
I tried the Arch Forum but they have a pretty gnarly admin insisting that the wiki has all the answers and that I should not be asking such a stupid question, but I see a lot of people have issues with pulse and it can be rather complicated to pinpoint the problem and fix it, and I have been unsuccessful with the wiki for weeks and my friend who has been using linux for 10+ years can't figure it out either.

Any ideas?

TIA
wolfi323
Registered Member
Posts
461
Karma
1
OS
chuckc wrote:first of all, I never installed alsa but it seems to be default part of linux? I installed pulse audio but alsa seems to be the driver? I'm a bit confused as to how they work together.

ALSA is Linux's standard Audio system.
PulseAudio sits on top of ALSA, it actually uses ALSA to produce the sound.

On startup, sound is muted. PulseAudio wiki suggests changing a setting in alsa mixer. I do not have alsa mixer. I dont want to install it either if I dont have to. I would like to just use pulse.

alsamixer is just a small console application.
Probably you have it installed anyway.

If you don't, you can f.e. also use KMix. But you have to start it without PulseAudio support to get the ALSA mixer. So quit it and start it with:
Code: Select all
KMIX_PULSEAUDIO_DISABLE=1 kmix


Secondly, when I get an IM from telepathy, my audio level is forced to 66% for the beep and stays at 66% after the beep. So if I'm listening to music at 100% and I get an IM my sound is reduced to 66% until I manually raise it back up to 100% but then next msg sends it right back to 66%

That's a known (and annoying) problem with Phonon and PulseAudio, but neither side seems to care about it.

Try to set "flat-volumes = no" in /etc/pulse/daemon.conf, then applications should not alter the _master_ volume any more.
See also https://wiki.archlinux.org/index.php/Pu ... ication.29
chuckc
Registered Member
Posts
5
Karma
0
all of that worked thanks!

package alsa-utils has to be installed for alsa mixer. i liked your way of getting kmix to do it bc then i dont have to install a package i dont need.

thanks again!

on a side note... is gstreamer an alternative to phonon that might perhaps have less bugs?

viewtopic.php?f=19&t=84411

Is this true? Don't need pulse at all?

update: removing pulse completely led to other problems like no sound after resume from suspend. I recommend leaving pulse installed. Pulse seems to also be louder, which on a laptop can make the difference between hearing your program at all.

Also,

sudo alsactl store

supposedly saves your alsa volume level so when you reboot it wont be muted.
wolfi323
Registered Member
Posts
461
Karma
1
OS
chuckc wrote:package alsa-utils has to be installed for alsa mixer. i liked your way of getting kmix to do it bc then i dont have to install a package i dont need.

Ok, it is installed by default on openSUSE.
It's not exactly huge anyway, as I already wrote.
(alsamixer itself has ~64KB)

on a side note... is gstreamer an alternative to phonon that might perhaps have less bugs?

No.
gstreamer is something quite (but not completely) different.

But phonon doesn't do anything directly, it uses backends.
ATM, there is a VLC backend, and there is a gstreamer backend.
Both should work with or without pulseaudio, at least they do here on openSUSE.

Is this true? Don't need pulse at all?

I don't know whether _you_ need it, but KDE and most other software works fine without it.
And no, you don't need gstreamer to get rid of pulseaudio.

And that thread you linked to is 4 years old. Many things have changed since then, especially regarding pulseaudio and KDE's pulseaudio support.
The mentioned Kubuntu does also use pulseaudio in current versions f.e.
So just forget what you read there.

update: removing pulse completely led to other problems like no sound after resume from suspend. I recommend leaving pulse installed. Pulse seems to also be louder, which on a laptop can make the difference between hearing your program at all.

That's a system configuration issue.
I don't have any problems at all without having pulseaudio installed on openSUSE.

The latest skype version does only support PulseAudio though, so it is required to use that f.e.
But I don't use skype anyway.

sudo alsactl store

supposedly saves your alsa volume level so when you reboot it wont be muted.

On openSUSE there's the alsa-store.service that automatically does that when you shutdown/reboot, and the alsa-restore.service that restores the volumes on boot.
This calls "alsactl store" and "alsactl restore" respectively, yes.
User avatar bcooksley
Administrator
Posts
19743
Karma
84
OS
Please note that if you are using Pulseaudio it should take of appropriately configuring the ALSA mixers when it starts up - so performing a save/restore of those mixers shouldn't be needed (unless you've had to manually adjust them).


System Settings and Device Actions KCM maintainer
Image
chuckc
Registered Member
Posts
5
Karma
0
I'm on Arch and recently did a fresh install with kernel 3.15.3-1 and kde 4.13.2

For whatever reason, the sound was muted every start, it was not remembering my previous audio settings. It was also changing volumes per application and while receiving notifications. The above steps resolved all of my issues, thanks again!

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], chgonzalez, davidemme, Exabot [Bot], Google [Bot], koriun, La Ninje, Marchin_, MSNbot Media, rullynoer, Yahoo [Bot]