Reply to topic

JuK doesn't play mp3 files.

Dinir
Registered Member
Posts
4
Karma
0
OS

JuK doesn't play mp3 files.

Wed Mar 30, 2016 12:32 pm
I just installed ArchLinux, KDE plasma-meta package, and kde-applications group which includes this JuK player.
I put some mp3 files to the program and double clicked the song name but nothing happens. Clicking play button skips to the next song in the list.

Seems like ogg files are playing well.
`mpg123` on command line plays mp3 files well.
VLC player plays them well.
User avatar google01103
Manager
Posts
6668
Karma
25

Re: JuK doesn't play mp3 files.

Wed Mar 30, 2016 2:11 pm
I don't have Juk installed so I may not be quite correct

Juk may only use the gStreamer phonon backend and either you haven't install gStreamer or you're missing the mp3 module something like gstreamer-0_10-plugins-fluendo-mp3

VLC uses its own codecs


OpenSuse Leap 42.1 x64, Plasma 5.x

Dinir
Registered Member
Posts
4
Karma
0
OS

gstreamer-0.10-ffmpeg was the key!

Thu Mar 31, 2016 10:30 am
Though you didn't use JuK your advice solved my problem, quite correctly! :D

I searched the repository for 'gstreamer' and I found 'gstreamer-0.10-ffmpeg'. Installed this and opened JuK, and now I am listening to my mp3 files with this program!
Dinir
Registered Member
Posts
4
Karma
0
OS
Okay I once accidentally nuked my whole system so I had to reinstall the entire system.
I got to this point of JuK not playing mp3 files. This time other apps also don't play mp3.

Tested with Amarok and DeadBeeF. All failed. `amarok --debug` seems not giving any message about codecs.
I have no problem hearing sounds from websites.

I tried installing these and didn't make it work: gstreamer-ugly, gstreamer-ugly-plugins, xine-lib.
User avatar google01103
Manager
Posts
6668
Karma
25

Re: JuK doesn't play mp3 files.  Topic is solved

Sun May 01, 2016 4:18 pm
gstreamer-0.10-ffmpeg ??

https://wiki.archlinux.org/index.php/KD ... on_backend
MP3 files cannot be played when using the GStreamer Phonon backend
This can be solved by installing the GStreamer libav plugin (package gst-libav). If you still encounter problems, you can try changing the Phonon backend used by installing another such as phonon-qt4-vlc or phonon-qt5-vlc. Then, make sure the backend is preferred via System Settings > Multimedia > Phonon > Backend (tab).


OpenSuse Leap 42.1 x64, Plasma 5.x

Dinir
Registered Member
Posts
4
Karma
0
OS

This time the key was gst-libav.

Tue May 03, 2016 10:45 am
Solving the problem was as simple and strange as encountering the problem, `sudo pacman -S gst-libav` just did everything. It's so strange...
Thanks for helping me, twice. (_ _)

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Exabot [Bot], Google [Bot], rbreu, Sogou [Bot], yankoarebalo