Reply to topic

No audio in dragon player 'flatpak' version

kde-saivinoba
Registered Member
Posts
1
Karma
0
Hi,
Need help with dragonplayer flatpak. If I try to play a video from flatpak version of the dragonplayer ('Open with' option from file manager), the video plays but there is no audio. If I play the same video in 'normal' (deb) version, audio/video both work fine. So it seems to me that there is no issue with file itself or with my audio settings.

Following is flatpak info of dragonplayer.
Code: Select all
[email protected]:~$ flatpak info org.kde.dragonplayer

Dragon Player - Video player with focus on simplicity

          ID: org.kde.dragonplayer
         Ref: app/org.kde.dragonplayer/x86_64/master
        Arch: x86_64
      Branch: master
     Version: 20.04.2
     License: GPL-2.0+
      Origin: kdeapps
  Collection:
Installation: system
   Installed: 1.0 MB
     Runtime: org.kde.Platform/x86_64/5.14
         Sdk: org.kde.Sdk/x86_64/5.14

      Commit: cd7e4314141de985e3a5c448629232c27419f7eda121bea60b40fee08dba0b3e
      Parent: 833038588c3e95b147cb555956d6a7754e190ea460db223da29325ad5fa2564a
     Subject: Built on Thu Jun 18 09:41:27 CEST 2020
        Date: 2020-06-18 07:41:45 +0000


Now, if I launch the same video file from terminal with `flatpak run org.kde.dragonplayer <video-filename>` command, the video also does not play; just the player window launches without playing video and obviously no audio. Following is error I see on the terminal.

Code: Select all
[email protected]:~$ flatpak run org.kde.dragonplayer /home/sai/Videos/elementary-install-2020-06-16_08.39.12.webm
Qt: Session management error: Could not open network socket
AL lib: (EE) ALCplaybackOSS_open: Could not open /dev/dsp: No such file or directory
libGL error: MESA-LOADER: failed to retrieve device information
libGL error: Version 4 or later of flush extension not found
libGL error: failed to load driver: i915
libGL error: failed to open /dev/dri/card0: No such file or directory
libGL error: failed to load driver: i965
AL lib: (EE) ALCplaybackOSS_open: Could not open /dev/dsp: No such file or directory
Opening QUrl("file:///home/sai/Videos/elementary-install-2020-06-16_08.39.12.webm")
Couldn't start kuiserver from org.kde.kuiserver.service: QDBusError("org.freedesktop.DBus.Error.ServiceUnknown", "org.freedesktop.DBus.Error.ServiceUnknown")
Stopped state
updated actions
updated menus
set titles
seekable changed to  false
detected mimetype:  "video/webm"
Initial offset is  0
using index:  -1  returned desc has index:  -1
using index:  -1  returned desc has index:  -1
AL lib: (EE) ALCplaybackOSS_open: Could not open /dev/dsp: No such file or directory
chapters:  0  titles:  0
going from  "Loading"  to  "Stopped"
Stopped state
updated actions
updated menus
set titles


I checked under /dev and there is no /dev/dsp. Only have /dev/snd.

I added myself to the 'audio' and 'video' groups. Still no audio when launching from 'Open with' option from the file manager and no audio+no video when running from terminal.
User avatar Mamarok
Manager
Posts
4849
Karma
12
OS
Packages are made by distributions, so you need to talk to your distribution if a package doesn't work.


Currently running Kubuntu 20.04, Plasma 5.18.5, Frameworks 5.68.0, Qt 5.12.8, kernel 5.4.0-42
FWIW: it is always useful to state the exact Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bartoloni, Bing [Bot], Don B. Cilly, Google [Bot], Gregstrq, grosser, Ignacio Serantes, magkoc, martinknopp, mirass, mrvldmr, mutterhunt, Sogou [Bot], Yahoo [Bot]