Reply to topic

akonadi mysql does not have mysql database

User avatar jithin1987
Registered Member
Posts
135
Karma
0
OS
Hi,
I noticed that my akonadi logs keeps telling me that
091022 8:55:18 [Warning] Can't open and lock time zone table: Table 'mysql.time_zone_leap_second' doesn't exist trying to live without them
091022 8:55:18 [ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist

I connected to the askonadi mysqld socket and looked at the db's. it didnot have a mysql db.
Code: Select all
jithine ~  $ mysql -S /home/jithine/.local/share/akonadi/db_misc/mysql.socket -u jithine
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 11
Server version: 5.1.39-log Source distribution

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> show databases;
+--------------------+
| Database           |
+--------------------+
| information_schema |
| akonadi            |
+--------------------+
2 rows in set (0.00 sec)

mysql> Bye
jithine ~  $ mysql -S /home/jithine/.local/share/akonadi/db_misc/mysql.socket -u root
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 12
Server version: 5.1.39-log Source distribution

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> show databases;
+--------------------+
| Database           |
+--------------------+
| information_schema |
| akonadi            |
+--------------------+
2 rows in set (0.00 sec)

mysql>

Has anyone noticed this. How is it working w/o mysql database.
In the .local/share/akonadi/mysql.conf I can see that the settings have been repeated 3 times


jithin1987, proud to be a member of KDE forums since 2008-Oct.
User avatar anda_skoa
KDE Developer
Posts
778
Karma
4
OS
If I read this correctly you are using MySQL version 5.1.x

I've seen reports from people who didn't manage to get it to run at all with higher than 5.0.x

Maybe it is something in the shipped config file. We'll have to check with our MySQL expert.

Cheers,
_


anda_skoa, proud to be a member of KDE forums since 2008-Oct.
User avatar jithin1987
Registered Member
Posts
135
Karma
0
OS
Yes I am running mysql 5.1. can u provide a mysqldump of mysql database whi your akonadi instance has. May be I can try manually adding the db.


jithin1987, proud to be a member of KDE forums since 2008-Oct.
User avatar anda_skoa
KDE Developer
Posts
778
Karma
4
OS
I looks like you don't need that anyway, we'll have to find out how to not trigger the error or adapt to MySQL 5.1 requirements.

Cheers,
_


anda_skoa, proud to be a member of KDE forums since 2008-Oct.
User avatar jithin1987
Registered Member
Posts
135
Karma
0
OS
I noticed one more thing. I have akindai mysql conf files in 2 locations.

1. .config/akonadi/mysql-local.conf
2. .local/share/akonadi/mysql.conf

Initially 1st one had the same settings repeated twice and second file has same stuff repeated thrice.
I removed the double settings from 1st one and restarted akonadi server. now instead of thrice the second file has it repeated twice.

Though removing the duplicate entries did not change anything


jithin1987, proud to be a member of KDE forums since 2008-Oct.
User avatar anda_skoa
KDE Developer
Posts
778
Karma
4
OS
Can you check if this command work for you?
I.e. if running it (while Akonadi is not) makes Akonadi's startup work afterwards?

mysql_install_db --datadir=$HOME/.local/share/akonadi/db_data/

Cheers,
_


anda_skoa, proud to be a member of KDE forums since 2008-Oct.
User avatar jithin1987
Registered Member
Posts
135
Karma
0
OS
I will try it. I had to reinstall my system as my laptop crashed. Now I have to start from begining. Akonadi is not at all starting.


jithin1987, proud to be a member of KDE forums since 2008-Oct.
User avatar jithin1987
Registered Member
Posts
135
Karma
0
OS
Thanks anda_skoa it works, Now my akonadi self test logs are clean.

Now one small issue remains which I asked in another thread. to make akonadi shut down before dbus. ideally along with login manager.


jithin1987, proud to be a member of KDE forums since 2008-Oct.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Exabot [Bot], franciscoo, Google [Bot], khaledsobhy, remerson, Sogou [Bot], TheraHedwig, Yahoo [Bot]