Reply to topic

Could not access the outbox folder

wyomingpat
Registered Member
Posts
3
Karma
0
OS

Could not access the outbox folder

Tue Mar 02, 2010 3:35 pm
Ok having persisted with trying to get Kontact working I find that every now and then on loading it comes up with a new error message I have to research. I guess that updates or some other app cause these issues. Anyhow the latest is "Could not access the outbox folder" and it seems this resource has disappeared. It still shows in the local folders.

Please, how do I recreate a new outbox folder?

Pat
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Which version of KDE are you using? Trunk or 4.4 ( or below )?


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar NickElliott
Registered Member
Posts
258
Karma
3
OS
I am also seeing this on 4.4.1.

When I first open Kontact I immediately see a message to say that the Akonadi server is starting and also this error from 'Mail Dispatcher Agent - AkonadiTray':

"Could not access the outbox folder (Unknown error. (Could not fetch root collection of resource akonadi_maildir_resource_0.))."


Then sometimes after Kontact has loaded I cannot access my contacts because 'Akonadi not operational'.

If I close Kontact and re-open it everything is working as expected with no errors.

A couple of questions:

- Is this a timing issue; should the akonadi server start automatically at login or only when I first open Kontact?
- What resources should I expect to see in the config screen, because akonadi_maildir_resource_0 is not showing on my system?

Thanks

Nick


NickElliott, proud to be a member of KDE forums since 2008-Oct.
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Akonadi is started when the first application needs its services. It likely starts when you first open Kontact. Given that after closing and re-opening Kontact everything works fine, this is likely a timing issue, since Akonadi remains running until manually stopped or the user logs out.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar annew
Manager
Posts
1155
Karma
11
OS
If this is persistent, consider starting akonadi manually before starting kontact. If you install the akonadi tray icon it's quick and easy to do.

Fedora had this problem in 4.4.0. as 4.4.1 got nearer automatic start of akonadi began to work. Now in 4.4.1 it's perfect.


annew, proud to be a member of KDE forums since 2008-Oct and a KDE user since 2002.
Join us on http://userbase.kde.org
goverp
Registered Member
Posts
2
Karma
0
OS
I've recently started getting this error, and I'm on KDE 4.4.3. Or rather, About KDE says 4.4.4, about Kontact says 4.4.3. If I start Kmail separately, it says Kmail 1.13.3. I'm a bit concerned about that not being 4.4.x!, and my System Settings->Advanced->KDE Resources panel-Contacts panel doesn't look quite right, so I'll try rebuilding them.

What may be relevant, but I'm not sure, is that about the time the problem started, I installed the pre-reqs to get Kleopatra working. I set myself a public/private key pair for GPG and setup Kmail to use it.
User avatar anda_skoa
KDE Developer
Posts
783
Karma
4
OS
Just wanting to point out that at this stage, i.e. KDE PIM 4.4.x, an error as this one for outbox is of little consequence to the functioning of Kontact.

The mail dispatcher agent is a component that will be responsible for mail sending once the KDE PIM 4.5.x version is released. Don't know why it is already enabled in earlier versions.

To get rid of the error for now one can disable the mail dispatcher's autostarting.
One way to do that is to edit the installed description file, depending on the distribution usually /usr/share/akonadi/agents/maildispatcheragent.desktop

It contain a line like this
Code: Select all
X-Akonadi-Capabilities=Unique,Autostart,NoConfig


Removing the autostart part ensures it is not started again once the current instance has been stopped.
Code: Select all
X-Akonadi-Capabilities=Unique,NoConfig


To stop the currently running instance we unfortunately have to resort to using a development tool (which might not be installed by default): akonadiconsole
When started, it shows a list of Akonadi processes on its first tab. Select the mail dispatcher and clicking the remove button to stop it.

As I said above, unless the autostarting is disabled as well, Akonadi will re-add it the next time it starts up itself.

An alternative to editing the globally installed description file is to copy it to $HOME/.local/share/akonadi/agents and modify this copy.
The main difference is that this local change will then be in effect until removed, while the global edit will be overwritten during the next update to the package.

If you rather want to try to solve the error, you could try this:
- also run akonadiconsole
- remove the maildispatcher agent
- remove "local folders" if present
- check if $HOME/.kde/share/config/specialmailcollectionsrc exists and if yes, remove it
- re-add the maildispatcher through Akonadiconsole (click add, chose the maildispatcher)

The mail dispatcher should then see that it doesn't have any local folders yet, create them and store the necessary config values into the respective config file.

Cheers,
_


anda_skoa, proud to be a member of KDE forums since 2008-Oct.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], brucer, Google [Bot], robinrobin, Sogou [Bot]