Reply to topic

Contact address book not visible in Kmail

Gewitty
Registered Member
Posts
2
Karma
0
OS
I just started using Kontact and have imported all my contact details from Thunderbird. This worked OK, but I find that when I start a new email and begin to type the recipient's name, the email address is not automatically pulled from the contact list as I would expect.

I also noticed that there doesn't appear to be a 'Send Email' option in the Contact screen once an entry has been selected.

Kmail seems to be collecting email addresses from any emails I send, and if I start typing one of these, then it does auto-complete.

From reading several sources on the web, it appears that this is a known problem, but so far I have not been able to find the solution.

A proposed solution is shown in the KAddressBook 4.4 UserBase notes (KAddressBook 4.4 - KDE UserBase). This says,

"...your distribution may have already done this for you, but check SystemSettings > Advanced tab > KDE Resources. Make sure that the resources listed there are enabled, then use the 'Set as Standard' button on 'akonadi-resource Personal'. This will make the Personal Contacts addressbook available to KMail."

I've been trying to find the SystemsSettings > Advanced Tab > KDE Resources mentioned, but with no success. All I can see that looks remotely connected to the issue is if I go into System Settings > Personal Information, which has an entry for the default address book, but doesn't seem to offer any opportunity to change it.

Can anyone put me straight on how I solve this issue please?
User avatar NickElliott
Registered Member
Posts
258
Karma
3
OS
You are on the right track with System Settings > Personal Information.

From this screen select 'Contacts' in the Resources drop-down. It is here that you need to add your akondai address book resource.

If your system is like mine the 'Add' button is un-labelled, it is the one just above the 'Remove' button. Click this and select 'Akonadi Address Books' which is first in the list on my system.

Once you've added this your contact e-mail addresses should auto-complete.

There are some other settings and options in the dialogue boxes but please don't ask me to explain their significance - unfortunately the documentation does not keep pace with developments in the software. Post back here if you find out what they do!


NickElliott, proud to be a member of KDE forums since 2008-Oct.
User avatar NickElliott
Registered Member
Posts
258
Karma
3
OS
I forgot to mention...

There is no 'Send Email' option in the Contact screen, once you select an entry the details are shown in the right-hand pane - click on the e-mail address you wish to send the mail to and the compose message dialogue automatically opens.


NickElliott, proud to be a member of KDE forums since 2008-Oct.
User avatar annew
Manager
Posts
1155
Karma
11
OS
NickElliott wrote:You are on the right track with System Settings > Personal Information.


This is version-specific. IIRC it changed with KDE 4.5.

From this screen select 'Contacts' in the Resources drop-down. It is here that you need to add your akondai address book resource.

If your system is like mine the 'Add' button is un-labelled, it is the one just above the 'Remove' button. Click this and select 'Akonadi Address Books' which is first in the list on my system.


The unlabelled button must be distro specific, but yes, you are correct in its placement. I'd add that if you decide to add the old std.vcf addressbook as well as the Personal Contacts one, you should remember to click "Set as Standard" for Personal Contacts.

Once you've added this your contact e-mail addresses should auto-complete.

There are some other settings and options in the dialogue boxes but please don't ask me to explain their significance - unfortunately the documentation does not keep pace with developments in the software. Post back here if you find out what they do!


I'm not sure which setting you have in mind there. Would you like to elucidate? The only ones I can think of are on the Manage Address Book screen, where it says "By default you will be asked where to put a new Contact or Distribution List when you create them. For convenience it is also possible to configure a default folder for each of the two data items." I'd recommend checking the boxes for both of those. It saves constantly being asked.

Going back to the "collected addresses" - KMail keeps a record of recently used addresses, and those are the ones that were being seen before the address book was set up. If you go to Settings > Configure KMail > Composer page you will see a button to edit the list, so you can remove any that you don't want kept.


annew, proud to be a member of KDE forums since 2008-Oct and a KDE user since 2002.
Join us on http://userbase.kde.org
Gewitty
Registered Member
Posts
2
Karma
0
OS
Nick's solution worked. I had to make some additional settings for Akonadi, but after that, the autocomplete function worked just as it should.

This was a pretty obscure issue and not one which a former Gnome like myself would have found easily. Why Kmail does not make the association automatically during installation/set-up is a mystery. Something the developers might want to consider.

Many thanks for all the help. Much appreciated.
User avatar NickElliott
Registered Member
Posts
258
Karma
3
OS
annew wrote:I'm not sure which setting you have in mind there. Would you like to elucidate? The only ones I can think of are on the Manage Address Book screen, where it says "By default you will be asked where to put a new Contact or Distribution List when you create them. For convenience it is also possible to configure a default folder for each of the two data items." I'd recommend checking the boxes for both of those. It saves constantly being asked..

Yup, those items and also 'Synchronise Folder'. Plenty of questions "Should I, shouldn't I - what happens if I don't?" but not enough concrete answers, and I do like concrete answers!

As Gewitty said, some of the settings and options are fairly obscure. I consider myself reasonably IT literate but still find the KDE PIM configuration confusing. It's one of the apps that new users are likely to use first and I'm conscious that this sort of thing is likely to frighten them off KDE before they've given it a chance.

Gewitty wrote:Many thanks for all the help. Much appreciated.

Glad we were able to help, you can usually get things sorted out here.


NickElliott, proud to be a member of KDE forums since 2008-Oct.

 
Reply to topic

Bookmarks



Who is online

Registered users: Bing [Bot], eight-bit, Google [Bot], rblackwell, scarf, Sogou [Bot], Yahoo [Bot]