Reply to topic

postgresql incompatible driver

kdelsaux
Registered Member
Posts
1
Karma
0

postgresql incompatible driver

Tue Aug 05, 2014 1:56 pm
Hi everyone,

I try to connect to my data base driver but I get this error:

Incompatible database driver's "postgresql" version: found version 255.255, expected version 1.9.


I don't know what to do, I made some research but nothing very interesting.

my postgresql is in 9.3 version

So, what I have to do to resolve this issue ?

Thanks
User avatar bcooksley
Administrator
Posts
19759
Karma
86
OS

Re: postgresql incompatible driver

Fri Aug 15, 2014 7:55 am
Which distribution are you using, and from where did you install the Postgres driver for Kexi?


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar jstaniek
Moderator
Posts
848
Karma
2
OS

Re: postgresql incompatible driver

Fri Aug 15, 2014 9:03 pm
Hi kdelsaux!
The bug is related to how plugins versioning is implemented on Linux (in a buggy way I would say). Kexi checks carefully versions, so that defect is more probable here.

7 days ago I pushed "a fix for issue with resolving version of plugins (at least) on Linux". Good news, this is ultimate fix, not a workaround.
It's in Kexi 2.9 Pre-Alpha (git master branch) and backported to Kexi 2.8.6 (git calligra-2.8 branch), not yet released in packages. If you're able to compile Kexi, grab it, if not, expect it in the 2.8.6 release.

Hope this helps.


Best regards,
Jarosław Staniek
Image

Kexi - Open Source Visual DB Apps Builder
• Request feature or fix for Kexi here
May I help you? Please mention your app's version and OS when asking for help

 
Reply to topic

Bookmarks



Who is online

Registered users: alfredod, apachelogger, Baidu [Spider], bartoloni, Bing [Bot], Exabot [Bot], Google [Bot], Majestic-12 [Bot], omlx, Sogou [Bot], Yahoo [Bot]