Reply to topic

Snap to Grid not working ( checkboxes are enabled )

User avatar facechomp
Registered Member
Posts
1
Karma
0
OS
Snap mode works the same as no-snap mode, no matter what I try. It just won't snap to anything in this environment:
Code: Select all
Karbon
Version 2.8.5
Using KDE Development Platform 4.14.2
krita version 1:2.8.5+dfsg-1+b2
 on MATE Desktop version 1.8.1

Note: I do have "Snap to Grid" enabled under View, and "Activate angle snap" enabled under Dockers => Snap settings.
sebpe
Registered Member
Posts
50
Karma
1
You mention Karbon and Krita versions, in what application do you want to use snapping?
If you are searching for help with Krita, it is developed independently from the Calligra suite now and also has its own forum: viewforum.php?f=136

Version 2.8.5 is quite dated by now, I am using version 3.1 and snapping works fine.

That said I am not sure how similar our user interfaces are, in my snap settings docker there is one general checkbox to toggle snapping and next to that there are six specific snapping types to choose. It is important that the left checkbox is enabled in addition to some of the six snapping selectors for any snapping to happen.

There is also a spinbox with a pixel value in the snap docker, which determines the radius in which snapping is activated. If that value is too low this may be another reason why snapping does not work.

The only other cause (besides a bug in your version) I could imagine is that the grid is too narrow, if you have not already enabled grid display you can do so in the view menu to investigate this.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], boudewijn, claydoh, farid, Google [Bot], nocruoro, rhaas, tymond