Reply to topic

Ruhezustand versetzt Internetverbindung in Flugzeugmodus

plumroy
Registered Member
Posts
9
Karma
0
Hallo,
ich arbeite unter Debian 10 mit KDE. Wenn ich den Rechner in den Ruhezustand geschickt habe und wieder aufwecke, ist meine Internet-Verbindung im Flugzeugmodus.
Um wieder ins Internet zu kommen, muss ich den Rechner jedes Mal erst wieder neu starten.

Inxi über meine Netzwerkkarte:
Code: Select all
id:   
network
description:    Ethernet interface
product:    RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
vendor:    Realtek Semiconductor Co., Ltd.
physical id:    
0
bus info:    
[email protected]:03:00.0
logical name:    
enp3s0
version:    09
serial:    60:a4:4c:42:da:fc
size:    100Mbit/s
capacity:    1Gbit/s
width:    64 bits
clock:    33MHz
capabilities:    pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration:   
autonegotiation   =   off
broadcast   =   yes
driver   =   r8169
duplex   =   half
firmware   =   rtl8168f-1_0.0.5 06/18/12
ip   =   192.168.178.34
latency   =   0
link   =   yes
multicast   =   yes
port   =   MII
speed   =   100Mbit/s
resources:   
irq   :   16
ioport   :   d000(size=256)
memory   :   f0004000-f0004fff
memory   :   f0000000-f0003fff


Wenn noch andere Informationen gebraucht werden:
Debian 10, Kernel 4.19.0-6-AMD64, KDE 5.14.5
Ansonsten bitte fragen, ich habe nicht so viel Ahnung von der Materie!

Zwischendurch habe ich auch mal versucht, s2ram, s2disk oder s2both zu machen, das funktioniert auch alles, aber beim Aufwecken des Rechners wird kein Passwort abgefragt, das ist also auch keine Lösung!
Wenn jemand dazu einen Tipp hat, wäre das toll!

Grüße
plumroy
User avatar Mamarok
Manager
Posts
4847
Karma
12
OS
also du kannst doch einfach den Flugzeugmodus ausschalten: klick auf das Netzwerk-Icon in der Systembox im Panel, dort ist das Flugmodus icon und kann einfach angeklickt werden.

Sonst solltest du dir mal die Einstellungen in den Systeeinstellungen zum Powermodus ansehen, da ist vielleicht was falsch gesetzt


Currently running Kubuntu 20.04, Plasma 5.18.5, Frameworks 5.68.0, Qt 5.12.8, kernel 5.4.0-42
FWIW: it is always useful to state the exact Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
plumroy
Registered Member
Posts
9
Karma
0
Mamarok wrote:also du kannst doch einfach den Flugzeugmodus ausschalten: klick auf das Netzwerk-Icon in der Systembox im Panel, dort ist das Flugmodus icon und kann einfach angeklickt werden.

Danke für die Antwort!
Das Merkwürdige ist, dass das Kästchen, in dem ich normaler Weise den Flugzeugmodus aktivieren könnte, nach dem Aufwachen aus Standby oder dem Ruhezustand fehlt.

Mamarok wrote:Sonst solltest du dir mal die Einstellungen in den Systeeinstellungen zum Powermodus ansehen, da ist vielleicht was falsch gesetzt


Ich habe schon alles auf die Voreinstellungen zurück gesetzt, von daher weiß ich nicht, was genau ich da überprüfen müsste. Macht es Sinn, das ganze KDE zu deinstallieren und noch mal neu zu installieren? Ich habe dieses Problem bisher noch nie gehabt unter Debian und KDE.

plumroy

Edit: Mir ist gerade noch etwas eingefallen: Ich habe auch das Paket uswsusp installiert. Kann es sein, dass sich da etwas "beißt"? Also anders gefragt: Darf man hibernate, pm-utils und uswsusp parallel benutzen oder entstehen dadurch Probleme?
User avatar Mamarok
Manager
Posts
4847
Karma
12
OS
Im Power Management der Systemeinstellungen gibt es unten einen Rubrik zum WLAN, bei mir steht da alles auf "unverändert lassen" (mein System ist in Englisch, "leave unchanged", frei übersetzt). Falls bei dir dort etwas anderes steht kannst du da etwas rumschrauben. Bitte schau in allen drei Reitern, es sollte alles auf unverändert stehen.


Currently running Kubuntu 20.04, Plasma 5.18.5, Frameworks 5.68.0, Qt 5.12.8, kernel 5.4.0-42
FWIW: it is always useful to state the exact Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
plumroy
Registered Member
Posts
9
Karma
0
Das habe ich gemacht! Bei mir heißt die Option "Drahtlos". Alle 3 Optionen stehen auf "Unverändert lassen".

Inzwischen habe ich KDE komplett deinstalliert und wieder neu installiert. Bei der Deinstallation habe ich peinlich genau darauf geachtet, dass ich in Synaptic jedes Paket nicht nur "zum Entfernen" sondern zum "vollständigen Entfernen" vorgemerkt hatte. Hat mich viel Zeit gekostet, alle Pakete durch zu gehen, aber ich dachte, besser ich entferne auch alle Konfigurationsdateien!

Leider ist hatte die ganze Aktion keinen Effekt. Nach einem erneuten Standby (über das KDE-Menü links unten) war die Internetverbindung wieder im Flugzeugmodus und gekappt! :(

Suspend im terminal mit
Code: Select all
systemctl suspend
hatte den selben Effekt!

plumroy
User avatar Mamarok
Manager
Posts
4847
Karma
12
OS
Ein neueres Plasma ist keine Option? Deine Version ist ja schon recht alt...


Currently running Kubuntu 20.04, Plasma 5.18.5, Frameworks 5.68.0, Qt 5.12.8, kernel 5.4.0-42
FWIW: it is always useful to state the exact Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
plumroy
Registered Member
Posts
9
Karma
0
Mamarok wrote:Ein neueres Plasma ist keine Option? Deine Version ist ja schon recht alt...


Dann müsste ich halt von Debian stable auf Debian testing wechseln. Im Laufe der vergangenen Jahre habe ich aber gemerkt, dass ich für testing einfach zu wenig Ahnung habe. Ich bin schon etwas älter und nicht mit Computern aufgewachsen.

Es war übrigens KDE, was mich vor ein paar Jahren in die Arme von stable getrieben hat, als der KDE-Desktop unter Testing nach einem Upgrade so zerschossen war, dass zumindest ich nicht mehr am PC arbeiten konnte!

Was mich irritiert, ist, dass ich stable und KDE jetzt schon ein paar Jahre habe und seit dem Kauf von neuer Hardware vor einigen Jahren keine Probleme mit den suspends hatte.

ludger
User avatar Mamarok
Manager
Posts
4847
Karma
12
OS
Ich habe Debian nicht mehr benutzt seit es Kubuntu gibt, und habe immer die neueste Version. Ich kann mich nicht erinnern, wann ich zuletzt einen zerschossenen Desktop hatte, das ist sicher mehr als 10 Jahre her, und war mit Sicherheit mein eigener Fehler.

Wenn deine "Power Management"-Einstellungen in KDE nichts bringen, frage ich mich, ob da nicht irgendwas im darunterliegenden System falsch eingestellt ist, da wäre aber ein Debian-spezifisches Forum besser geeignet.


Currently running Kubuntu 20.04, Plasma 5.18.5, Frameworks 5.68.0, Qt 5.12.8, kernel 5.4.0-42
FWIW: it is always useful to state the exact Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
plumroy
Registered Member
Posts
9
Karma
0
Mamarok wrote:Ich habe Debian nicht mehr benutzt seit es Kubuntu gibt, und habe immer die neueste Version. Ich kann mich nicht erinnern, wann ich zuletzt einen zerschossenen Desktop hatte, das ist sicher mehr als 10 Jahre her, und war mit Sicherheit mein eigener Fehler.

Wenn deine "Power Management"-Einstellungen in KDE nichts bringen, frage ich mich, ob da nicht irgendwas im darunterliegenden System falsch eingestellt ist, da wäre aber ein Debian-spezifisches Forum besser geeignet.


Okay, das stimmt wahrscheinlich! Einstweilen vielen Dank für Deine Antworten!

plumroy
plumroy
Registered Member
Posts
9
Karma
0
Mamarok wrote:Wenn deine "Power Management"-Einstellungen in KDE nichts bringen, frage ich mich, ob da nicht irgendwas im darunterliegenden System falsch eingestellt ist, da wäre aber ein Debian-spezifisches Forum besser geeignet.

Ja, das stimmt!
Vielen Dank!
plumroy

 
Reply to topic

Bookmarks



Who is online

Registered users: alra, Baidu [Spider], Bing [Bot], boudewijn, bovender, claydoh, colstar, farid, flyingbear, Google [Bot], grinder, ipwizard, Mace68, mcoudert, quisimodo, sandro4912, Sogou [Bot], TheraHedwig, Voronwe13