Reply to topic

KDE neon - amdgpu firmware wird nicht verwendet

satara
Registered Member
Posts
1
Karma
0
Hallo,

ich nutze schon seit Jahren Debian und LinuxMint und wollte mir mal eine weitere Distro anschauen. Also habe ich mir KDE neon auf meinen Laptop installiert.

Ich habe folgende Probleme die ich einfach nicht behoben bekomme.
1. Ich kann die Bildschirmhelligkeit nicht einstellen. Der Slider ist zwar unter Akku mit vorhanden, aber es hat keine Wirkung, die Helligkeit ist immer bei 100%.
Also dachte ich, ich versuche es mal über xrandr, da bekomme ich den Fehler:
Code: Select all
xrandr: Failed to get size of gamma for output default
und die Helligkeit lässt sich darüber auch nicht einstellen. Also ist meine Annahme, dass irgendetwas nicht mit dem Grafiktreiber nicht stimmt.
Code: Select all
$inxi -G
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Picasso vendor: ASUSTeK driver: N/A bus ID: 03:00.0
           Display: x11 server: X.Org 1.20.9 driver: fbdev FAILED: ati unloaded: amdgpu,intel,modesetting,vesa
           resolution: 1920x1080~77Hz
           OpenGL: renderer: llvmpipe (LLVM 11.0.0 256 bits) v: 4.5 Mesa 20.2.6 direct render: Yes

Für das Gerät wird kein Treiber geladen und X.Org nimmt fbdev statt amdgpu
Ich habe amdgpu-pro-20.20-1098277-ubuntu-20.04 installiert.
Code: Select all
$dmesg | grep amd
[    0.000000] Linux version 5.4.0-65-generic ([email protected]) (gcc version 9.3.0 (Ubuntu 9.3.0-17ubuntu1~20.04)) #73-Ubuntu SMP Mon Jan 18 17:25:17 UTC 2021 (Ubuntu 5.4.0-65.73-generic 5.4.78)
[    0.465080] amd_uncore: AMD NB counters detected
[    0.465083] amd_uncore: AMD LLC counters detected
[    0.839901] i2c_amd_mp2 0000:03:00.7: enabling device (0000 -> 0002)
[    0.840160] i2c_amd_mp2 0000:03:00.7: MP2 device registered.
[    0.956033] [drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.
[    4.175817] [drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.


Ich hab schon viele Kernel-Parameter versucht auszuprobieren, dennoch ohne Erfolg.

Mein Laptop ist ein ASUS D509DA-EJ374T.
Die Grafikkarte ist ein AMD RX Vega 10

Vielen Dank im vorraus.

P.S. Ich hab kein Spoiler gefunden, deswegen lade ich Logs und Co. auf GitHub hoch:
https://github.com/SataraPrivate/FileSh ... r/kde-neon

Reply to topic

Bookmarks



Who is online

Registered users: andrewm, Baidu [Spider], Bing [Bot], Google [Bot], Merlimau, Sogou [Bot], ssanderson, Yahoo [Bot]