Reply to topic

Astrometry solver no longer works on my Mac

stanleyf
Registered Member
Posts
3
Karma
0
I just updated kStars from 3.0.0 to 3.2.2. Now the offline solver fails immediately after "Capture & Solve" takes a picture.
The online version works fine. But I need the offline version for where I do astrophotography.

A few interesting tidbits:
1. I re-installed v3.0.0 and it now has the same problem as v 3.2.2. No solving.
2. All these tests are using the simulators, as my telescope is in the mountains with no internet access. I came back from there because the solver wouldn't work with real frames.
3. What is really strange is that the solving DOES work on my iMac using v3.2.2; it's just failing on my Air. Exact same configuration, etc. for both.
4. Tried removing kStars entirely and re-installing it. Didn't change anything (sigh).
5. Tried playing with the Python name (v2.7 or not) as per Rob. Didn't work.

Am really at my wit's end...

stan in Brooklyn

UPDATE: I just erased the whole hard disk on my Air and re-installed a virgin version of Mojave; then re-downloaded both versions 3.0.0 and 3.2.2 of kStars. Copied the Astrometry index files from my iMac. Re-downloaded GsC. Tried each version of kStars. Result: although v3.2.2 works fine for offline and online plate solving on my iMac, only online plate-solving works for my Air. Offline immediately after taking the frame crashes with a terse message: "Error starting solver. Process crashed." It appears that offline plate solving is not even getting started...but WHY?

Son of UPDATE: I'm attaching here a printout of the log from an attempt at offline astrometry. I hope this will help someone help me...

Thanks,
stan

[2019-05-27T18:21:49.871 EDT INFO ][ org.kde.kstars.ekos.align] - "Capturing image..."
[2019-05-27T18:21:52.882 EDT INFO ][ org.kde.kstars.fits] - Loading FITS file "/private/var/folders/vd/vwnkltm92sx93mrg14plg82r0000gn/T/fitsVpiuva.fits"
[2019-05-27T18:21:52.904 EDT INFO ][ org.kde.kstars.ekos.align] - "Image received."
[2019-05-27T18:21:52.975 EDT INFO ][ org.kde.kstars.ekos.align] - "Solver iteration #1"
[2019-05-27T18:21:53.043 EDT INFO ][ org.kde.kstars.ekos.align] - "export PATH=/Applications/kstars.app/Contents/MacOS/netpbm/bin:/Applications/kstars.app/Contents/MacOS/python/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin"
[2019-05-27T18:21:53.111 EDT INFO ][ org.kde.kstars.ekos.align] - "export PYTHONPATH=/Applications/kstars.app/Contents/MacOS/python/bin/site-packages"
[2019-05-27T18:21:53.189 EDT INFO ][ org.kde.kstars.ekos.align] - "Starting solver..."
[2019-05-27T18:21:53.297 EDT INFO ][ org.kde.kstars.ekos.align] - "/Applications/kstars.app/Contents/MacOS/astrometry/bin/solve-field -O --no-plots --no-verify --resort --downsample 2 -L 19.3202 -H 26.6923 -u aw -3 57.033 -4 24.1727 -5 30 --config /Applications/kstars.app/Contents/MacOS/astrometry/bin/astrometry.cfg -W /private/var/folders/vd/vwnkltm92sx93mrg14plg82r0000gn/T/solution.wcs /private/var/folders/vd/vwnkltm92sx93mrg14plg82r0000gn/T/fitsVpiuva.fits"
[2019-05-27T18:21:53.406 EDT INFO ][ org.kde.kstars.ekos.align] - "Reading input file 1 of 1: \"/private/var/folders/vd/vwnkltm92sx93mrg14plg82r0000gn/T/fitsVpiuva.fits\"..."
[2019-05-27T18:21:53.515 EDT INFO ][ org.kde.kstars.ekos.align] - "Error starting solver: Process crashed"
[2019-05-27T18:21:53.609 EDT INFO ][ org.kde.kstars.ekos.align] - "Solver failed. Try again."
annamurphy
Registered Member
Posts
1
Karma
0
stanleyf wrote:I just updated kStars from 3.0.0 to 3.2.2. Now the offline solver fails immediately after "Capture & Solve" takes a picture.
The online version works fine. But I need the offline version for where I do astrophotography.

A few interesting tidbits:
1. I re-installed v3.0.0 and it now has the same problem as v 3.2.2. No solving.
2. All these tests are using the simulators, as my telescope is in the mountains with no internet access. I came back from there because the solver wouldn't work with real frames.
3. What is really strange is that the solving DOES work on my iMac using v3.2.2; it's just failing on my Air. Exact same configuration, etc. for both.
4. Tried removing kStars entirely and re-installing it. Didn't change anything (sigh).
5. Tried playing with the Python name (v2.7 or not) as per Rob. Didn't work.

Am really at my wit's end...

stan in Brooklyn

UPDATE: I just erased the whole hard disk on my Air and re-installed a virgin version of Mojave; then re-downloaded both versions 3.0.0 and 3.2.2 of kStars. Copied the Astrometry index files from my iMac. Re-downloaded GsC. Tried each version of kStars. Result: although v3.2.2 works fine for offline and online plate solving on my iMac, only online plate-solving works for my Air. Offline immediately after taking the frame best cold weather work glove crashes with a terse message: "Error starting solver. Process crashed." It appears that offline plate solving is not even getting started...but WHY?

Son of UPDATE: I'm attaching here a printout of the log from an attempt at offline astrometry. I hope this will help someone help me...

Thanks,
stan


No smart ideas...really

 
Reply to topic

Bookmarks



Who is online

Registered users: abury, Baidu [Spider], Bing [Bot], claydoh, dfoskett, Google [Bot], jmacleod, Majestic-12 [Bot], NMaghfurUsman, Sogou [Bot]