Reply to topic

Kcalc sometimes loses intermediate results

User avatar Section_8
Registered Member
Posts
28
Karma
0
OS
System:
Operating System: Gentoo Linux
KDE Plasma Version: 5.18.5
KDE Frameworks Version: 5.70.0
Qt Version: 5.14.2
Kernel Version: 5.4.60-gentoo
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-4790K CPU @ 4.00GHz
Memory: 15.7 GiB of RAM

Kcalc 20.04.3

For some operators - such as x^2 - kcalc loses the intermediate results in a chain of operations. For example
10^2 + 4^2 + 5^2 [enter] shows a result of 125 instead of 141.

Other operators, such as square root, also have this problem, but binary operators such as modulo, do not.
User avatar Mamarok
Manager
Posts
5469
Karma
16
OS
This sounds very much like a bug you should report on https://bugs.kde.org, the forum is the wrong place to report this.


Currently running Kubuntu Hirsute Hippo, Plasma 5.21.4, Frameworks 5.81.0, Qt 5.15.2, kernel 5.11.0-13
FWIW: it is always useful to state the exact Plasma version and distribution when asking questions, makes it easier for us to help ...
User avatar Section_8
Registered Member
Posts
28
Karma
0
OS
Sorry I didn't see this reply earlier. I tried upgrading to kcalc 20.08.2 and this isn't happening there, so it looks like they've already fixed it.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], ipwizard, kevingillmore, lesturner, lshoravi, Majestic-12 [Bot], pandiloko, Sogou [Bot], tburke, tonaxxl, Yahoo [Bot]