Reply to topic

Weird output with cantor Sage backend

User avatar TheBlackCat
Registered Member
Posts
2945
Karma
8
OS
I am having a weird problem with cantor using the sage backend. When I use the built-in sage system, I can do something like this:

Code: Select all
input: 1+1
output: 2


But when I use cantor, I get this:
Code: Select all
input: 1+1
output: \begin{eqnarray*}\newcommand{\Bold}[1]{\mathbf{#1}}2\end{eqnarray*}


No matter what I do I always get this sort of bizarre and unintelligible output.

I can't figure out why cantor alone is having such weird output. I am using openSUSE 11.2 so I had to compile sage by hand, but I don't understand why it is working for all the other ways I can interact with sage but not for cantor.


Man is the lowest-cost, 150-pound, nonlinear, all-purpose computer system which can be mass-produced by unskilled labor.
-NASA in 1965
User avatar TheBlackCat
Registered Member
Posts
2945
Karma
8
OS
It seems the problem is "typesetting using latex", when I disable that I get valid answers. Is it expected behavior to get that sort of output when latex is enabled, or am I missing something that will convert that output into something readable?


Man is the lowest-cost, 150-pound, nonlinear, all-purpose computer system which can be mass-produced by unskilled labor.
-NASA in 1965
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
This is probably a bug in the Cantor Sage backend, since Latex input shouldn't interfere in its operation.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar TheBlackCat
Registered Member
Posts
2945
Karma
8
OS
I am pretty sure it is latex output that is the problem, since the correct answer is embedded in the output.


Man is the lowest-cost, 150-pound, nonlinear, all-purpose computer system which can be mass-produced by unskilled labor.
-NASA in 1965
arieder
KDE Developer
Posts
32
Karma
0
OS
What you are seeing is the LaTex code, representing the result. For it to be correctly rendered into a good looking formula you need latex and dvips (they must be in your $PATH).


arieder, proud to be a member of KDE forums since 2008-Oct.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], benjaminl, Bing [Bot], cylverbak, Google [Bot], gui-m, ipwizard, kakosf, kde-jriddell, klorax, Mamarok, P3lor, peje, Raptor 2101, skylerjett, Snudl, zwankfr