Reply to topic

Skrooge on Maui

srgmro33
Registered Member
Posts
57
Karma
0

Skrooge on Maui

Tue Aug 30, 2016 3:50 pm
I am unable to install skrooge-kf5 on Maui.
I used the following ppa
ppa:s-mankowski/beta-kf5.
I get the following message :
skrooge-kf5 : Dépend: qtbase-abi-5-5-1 which is a virtual package, provided by:
- libqt5core5a, mais 5.7.0+dfsg-1+16.04+build5 est installé.
- libqt5core5a, mais 5.7.0+dfsg-1+16.04+build5 est installé.
Any idea of what to do ?
Thanks to all.
SM
srgmro33
Registered Member
Posts
57
Karma
0

Re: Skrooge on Maui

Wed Aug 31, 2016 8:03 am
If i understand what occured :
In Maui (Neon) qtbase-abi-5-5-1 is provided by libqt5core5a (5.7.0+dfsg-1+16.04+build5).
but in kubuntu qtbase-abi-5-5-1 is provided by libqt5core5a (5.5.1+dfsg-16ubuntu7)

So how to get around that problem ? Many thanks for your suggestions.

SM
User avatar smankowski
Moderator
Posts
1012
Karma
7
OS

Re: Skrooge on Maui

Wed Sep 07, 2016 9:18 am
My ppa is done for "normal" ubuntu distribution.
The problem is that Maui (I didn't know Maui before this thread) has a newest version of Qt.
In my ppa, Skrooge is not built on this version.

A possible solution: build Skrooge (https://techbase.kde.org/Projects/Skrooge)


Skrooge, a personal finances manager powered by KDE
Image - PayPal
srgmro33
Registered Member
Posts
57
Karma
0

Re: Skrooge on Maui

Sat Sep 10, 2016 2:41 pm
smankowski wrote:My ppa is done for "normal" ubuntu distribution.
The problem is that Maui (I didn't know Maui before this thread) has a newest version of Qt.
In my ppa, Skrooge is not built on this version.

A possible solution: build Skrooge (https://techbase.kde.org/Projects/Skrooge)

thanks for your clear answer.
Maui distribution is the new Netrunner distribution.
http://www.netrunner.com/
I actually use daily Netrunner 14.06, based on ubuntu 14.04. In this case i used Skrooge (1.12.5) got from your dedicated ppa.
I intended to move to Maui
https://mauilinux.org/
which is base this time on Neon
https://neon.kde.org/
I will have a look at the build solution, but if i understand what is happening, it will be wise to wait for plasma 5.8 which should be a LTS release of KDE plasma.
For the moment it means that skrooge wont work on Neon or Maui.

Many thanks for your interest.
SM
srgmro33
Registered Member
Posts
57
Karma
0

Re: Skrooge on Maui  Topic is solved

Wed Sep 21, 2016 4:08 am
I got a solution,
The team of Maui compile your files against Maui 1.
https://forums.mauilinux.org/showthread ... 936&page=2

I downloaded the skrooge-kf5 and the skrooge-common files and it works.
That should be usefull for a lot of users.
^-^
SM

 
Reply to topic

Bookmarks



Who is online

Registered users: ab, Baidu [Spider], Bing [Bot], claydoh, cmb, DeMus, frantesta, Google [Bot], hagdervriese, KayshiAri, koffeinfriedhof, Marius82, shmu26, Sogou [Bot], Yahoo [Bot]