Reply to topic

One Date Display Reverses Month and Day

cmb
Registered Member
Posts
13
Karma
0
In the Operations view, one of the displayed date fields reverses the month and day. In my case, I have Settings > Configure Skrooge > General > Display > Date Format set to Short Date (3/16/17). For my locale, that is mm/dd/yyyy. All dates with one exception follow that format.

In the detail panel of the Operations page, the date is shown in European format, dd/mm/yyyy. It is interesting to note that when the calendar/date selector is popped up, that date is shown correctly in the mm/dd/yyyy format. Also in the Splits details, those dates are shown correctly.

I thought this was resolved by Bug 349327-Bad date format for sub-operation display in split tab.

As mentioned in Bug 368478-Date in edit not respect settings, there are some restrictions in the date formats. (See also Date Format Incorrect.

Is there some setting I can modify so that this one exception is removed and all dates are shown in the mm/dd/yyyy format?

My Installation
Skrooge Version: 2.7.0 using KDE Frameworks 5.18.0, Qt 5.5.1 and the xcb windowing system
Operating System: Linux Mint 18.1 Cinnamon 64-bit
Locale: en_US.UTF-8

ivanthekdefan
Registered Member
Posts
65
Karma
0
OS
Are you sure that these bugs were fixed in or before Mint 18 KDE´s version?


Hi, I'm Ivan, a competent computer user (which means geek to most). I run KDE neon Developer when it works and KDE neon User when Developer doesn't work.
Hope I helped you with any problems you may have had :)
cmb
Registered Member
Posts
13
Karma
0
Note that this date display anomaly or exception still exists in Skrooge version 2.9.0 and now 2.10.3.

 
Reply to topic

Bookmarks



Who is online

Registered users: alfredod, Baidu [Spider], Bing [Bot], crozbo, dmiroshnichenko, Exabot [Bot], Google [Bot], jackdinn, Majestic-12 [Bot], nazarnirvana, nocin, paviluf, Sogou [Bot], subGlitch, Yahoo [Bot]