Reply to topic

Scrooge "Sounds" when making transactions

wind_rose_2
Registered Member
Posts
48
Karma
0
I have looked under Setting>config notifications>and have checked "play a sound " but l am still not able to have a "sound" notification when an operation is made???
Thanks
Dave
User avatar smankowski
Moderator
Posts
848
Karma
7
OS
This was a bug.
I committed the correction: https://commits.kde.org/skrooge/a97da30 ... af2a5e8c9f


Skrooge, a personal finances manager powered by KDE
Image
wind_rose_2
Registered Member
Posts
48
Karma
0
Forgive me but l am new and l do not know the process of using the information you have provided. Thanks again..Dave
User avatar smankowski
Moderator
Posts
848
Karma
7
OS
You have nothing to do. My previous post is done just to inform you that:
  • This is a bug. You can not have the expected behavior on your version
  • I found the correction
  • This will work on next version


Skrooge, a personal finances manager powered by KDE
Image
wind_rose_2
Registered Member
Posts
48
Karma
0
OK l think l understand now, the link you had provided it basically a "TO DO" list for the next version. Studying in closer l see my previous request to have an alpha numeric entry be permitted in the "Number" field.
When may expect the next version to be available?
Dave
User avatar smankowski
Moderator
Posts
848
Karma
7
OS
I think I will publish a new version before end of March.


Skrooge, a personal finances manager powered by KDE
Image
wind_rose_2
Registered Member
Posts
48
Karma
0
Good news!
Thnks
wind_rose_2
Registered Member
Posts
48
Karma
0
I have updated as per the most recent but find l am still unable to have "sounds of notification"???
User avatar smankowski
Moderator
Posts
848
Karma
7
OS
Hi,

If you are on Skrooge 2.12.0 and if your KDE settings are correct, like this:
Image
(Sorry for the French screen capture)

You should have a sound when an operation is created, in fact, when you click on "Add" button.
I tested it. It works.
Regards.


Skrooge, a personal finances manager powered by KDE
Image
wind_rose_2
Registered Member
Posts
48
Karma
0
[img]/home/dave/Pictures/Screenshot%20from%202018-03-10%2011-41-52.png[/img]

This is a screen shot which appears correct but how do l know if the KDE settings are correct?
Still no sounds. Can the sound be "Tested" from the settings page? I hear nothing sorry.
dave

https://gist.github.com/anonymous/99f2d482c14f16d6bc591d37e4ab6a6f

This is what is indicated from the Skrooge HELP>ABOUT>VERSION 2.12.0
Using:
KDE Frameworks 5.18.0
Qt 5.5.1 (built against 5.5.1)
The xcb windowing system

Do l have the wrong version??
User avatar smankowski
Moderator
Posts
848
Karma
7
OS
wind_rose_2 wrote:[img]/home/dave/Pictures/Screenshot%20from%202018-03-10%2011-41-52.png[/img]

This is a screen shot which appears correct but how do l know if the KDE settings are correct?
Still no sounds. Can the sound be "Tested" from the settings page? I hear nothing sorry.
dave

https://gist.github.com/anonymous/99f2d482c14f16d6bc591d37e4ab6a6f

This is what is indicated from the Skrooge HELP>ABOUT>VERSION 2.12.0
Using:
KDE Frameworks 5.18.0
Qt 5.5.1 (built against 5.5.1)
The xcb windowing system

Do l have the wrong version??

Hi Dave,

Yes, you can test the sound from the settings page by clicking on the "Play" icon.
Skrooge 2.12.0 is the right version.
If you have no sound from the KDE setting page, this is no normal and you should solve this issue first.
Regards.


Skrooge, a personal finances manager powered by KDE
Image
wind_rose_2
Registered Member
Posts
48
Karma
0
I have looked for any updates that l may have installed and have found when l updated Skrooge Feb 3rd this year l see that l had two packages installed for Skrooge one was
Skrooge-kf5-common and the other was Skrooge-kf5.
Both installed packages had updated from.... 2.10.5-Oubuntu~ppa1 to 2.11.0-Oubunto~ppa1...was this done correctly or should only one package have been installed?
I can not see anything for KDE Frameworks 5.18.0 other than what is shown in the Help>About> Version drop box.
Am l looking in the right place to correct the issue or must l look elsewhere?
User avatar smankowski
Moderator
Posts
848
Karma
7
OS
wind_rose_2 wrote:I have looked for any updates that l may have installed and have found when l updated Skrooge Feb 3rd this year l see that l had two packages installed for Skrooge one was
Skrooge-kf5-common and the other was Skrooge-kf5.

This is normal.
Skrooge-kf5 is the package containing the binaries of Skrooge. This package is specific for a platform.
Skrooge-kf5-common is the package containing the common files (picture, qml, xml, ...). This package is the same whatever the platform.
wind_rose_2 wrote:Both installed packages had updated from.... 2.10.5-Oubuntu~ppa1 to 2.11.0-Oubunto~ppa1...was this done correctly or should only one package have been installed?

No, you should have the 2.12.0 version.
https://skrooge.org/ubuntu_installation.
wind_rose_2 wrote:I can not see anything for KDE Frameworks 5.18.0 other than what is shown in the Help>About> Version drop box.
Am l looking in the right place to correct the issue or must l look elsewhere?


Skrooge, a personal finances manager powered by KDE
Image
wind_rose_2
Registered Member
Posts
48
Karma
0
I have updated to the 2.12.0 and removed the noted unnecessary files but still have no sound? Is there anything else l may need you to know?

dave@linuxmint18 ~ $ sudo apt-get update
[sudo] password for dave:
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://archive.canonical.com/ubuntu xenial InRelease
Hit:3 http://dl.google.com/linux/chrome/deb stable Release
Ign:4 http://mirror.unlockforus.com/linuxmint/packages sylvia InRelease
Hit:5 http://security.ubuntu.com/ubuntu xenial-security InRelease
Hit:6 https://repo.skype.com/deb stable InRelease
Hit:7 http://archive.ubuntu.com/ubuntu xenial InRelease
Hit:8 http://ppa.launchpad.net/s-mankowski/ppa-kf5/ubuntu xenial InRelease
Hit:10 http://mirror.unlockforus.com/linuxmint/packages sylvia Release
Hit:11 http://archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:12 http://archive.ubuntu.com/ubuntu xenial-backports InRelease
Reading package lists... Done
dave@linuxmint18 ~ $ sudo apt-get install skrooge-kf5
Reading package lists... Done
Building dependency tree
Reading state information... Done
skrooge-kf5 is already the newest version (2.12.0-0ubuntu1~ppa1).
The following packages were automatically installed and are no longer required:
libakonadi-kde4 libakonadiprotocolinternals1 libkcalcore4
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 13 not upgraded.
dave@linuxmint18 ~ $ sudo apt autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
libakonadi-kde4 libakonadiprotocolinternals1 libkcalcore4
0 upgraded, 0 newly installed, 3 to remove and 13 not upgraded.
After this operation, 4,605 kB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 490738 files and directories currently installed.)
Removing libakonadi-kde4 (4:4.14.10-1ubuntu2) ...
Removing libakonadiprotocolinternals1 (1.13.0-8ubuntu2) ...
Removing libkcalcore4 (4:4.14.10-1ubuntu2) ...
Processing triggers for shared-mime-info (1.5-2ubuntu0.1) ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Processing triggers for libc-bin (2.23-0ubuntu10) ...
dave@linuxmint18 ~ $
User avatar smankowski
Moderator
Posts
848
Karma
7
OS
If you have Skrooge 2.12.0 installed, it means that the issue is not more in Skrooge.
So, you must go in KDE settings and set the settings until you are able to have sound on Skrooge notification.


Skrooge, a personal finances manager powered by KDE
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Deevad, Google [Bot], kde-pedro, mahen, mcoudert, rafaellinuxuser, Sogou [Bot]