Reply to topic

Cannot open file : Wrong password

skrooge
Registered Member
Posts
4
Karma
0

Cannot open file : Wrong password

Mon Dec 03, 2018 8:08 pm
Hi guys,

Since today's update (archlinux user), I cannot open my Skrooge file. It was still working fine yesterday.

My skrooge file is protected by a password. And, since today's update it says the password is not correct so it doesn't open the file. If i click on the dialbox's eye (to see the password clear), the password is correct (not an AZERTY/QWERTY issue).

Also, I backup regularly my Skrooge file and I cannot open any of the backups (from few day to few months/years).

Here is the result of today's update (last one was 2018-11-24)
Code: Select all
[2018-12-03 19:01] [PACMAN] Running 'pacman -Syu'
[2018-12-03 19:01] [PACMAN] synchronizing package lists
[2018-12-03 19:01] [PACMAN] starting full system upgrade
[2018-12-03 19:13] [ALPM] transaction started
[2018-12-03 19:13] [ALPM] upgraded archlinux-keyring (20181122-1 -> 20181128-1)
[2018-12-03 19:13] [ALPM-SCRIPTLET] ==> Ajout des clés depuis archlinux.gpg…
[2018-12-03 19:13] [ALPM-SCRIPTLET] ==> Signature locale des clés de confiance dans le trousseau de clés…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Signature locale de la clé DDB867B92AA789C165EEFA799B729B06A680C281…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Signature locale de la clé 684148BB25B49E986A4944C55184252D824B18E8…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Signature locale de la clé 91FFE0700E80619CEB73235CA88E23E377514E00…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Signature locale de la clé AB19265E5D7D20687D303246BA1DFB64FFF979E7…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Signature locale de la clé 0E8B644079F599DFC1DDC3973348882F6AC6A4C2…
[2018-12-03 19:13] [ALPM-SCRIPTLET] ==> Importation des valeurs des propriétaires de confiance…
[2018-12-03 19:13] [ALPM-SCRIPTLET] ==> Désactivation des clés révoquées du trousseau de clés…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 7FA647CD89891DEDC060287BB9113D1ED21E1A55…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 40440DC037C05620984379A6761FAD69BA06C6A9…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé B1F2C889CB2CCB2ADA36D963097D629E437520BD…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 5357F3B111688D88C1D88119FCF2CB179205AC90…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 5559BC1A32B8F76B3FCCD9555FA5E5544F010D48…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé BC1FBE4D2826A0B51E47ED62E2539214C6C11350…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 63F395DE2D6398BBE458F281F2DBB4931985A992…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 8F76BEEA0289F9E1D3E229C05F946DED983D4366…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 4FCF887689C41B09506BE8D5F3E1D5C5D30DB0AD…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé FB871F0131FEA4FB5A9192B4C8880A6406361833…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 81D7F8241DB38BC759C80FCE3A726C6170E80477…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 5E7585ADFF106BFFBBA319DC654B877A0864983E…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 50F33E2E5B0C3D900424ABE89BDCF497A4BBCC7F…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé E7210A59715F6940CF9A4E36A001876699AD6E84…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 65EEFE022108E2B708CBFCF7F9E712E59AF5F22A…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 40776A5221EF5AD468A4906D42A1DB15EC133BAD…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 8CF934E339CAD8ABF342E822E711306E3C4F88BC…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 5696C003B0854206450C8E5BE613C09CB4440678…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 5A2257D19FF7E1E0E415968CE62F853100F0D0F0…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 9515D8A8EAB88E49BB65EDBCE6B456CAF15447D5…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 34C5D94FE7E7913E86DC427E7FB1A3800C84C0A5…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 39F880E50E49A4D11341E8F939E4F17F295AFBF4…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 66BD74A036D522F51DD70A3C7F2A16726521E06D…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 07DFD3A0BC213FA12EDC217559B3122E2FA915EC…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 44D4A033AC140143927397D47EFD567D4C7EA887…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 27FFC4769E19F096D41D9265A04F9397CDFD6BB0…
[2018-12-03 19:13] [ALPM-SCRIPTLET]   -> Désactivation de la clé 8840BD07FC24CB7CE394A07CCF7037A4F27FB7DA…
[2018-12-03 19:13] [ALPM-SCRIPTLET] ==> Mise à jour de la base de données de confiance…
[2018-12-03 19:13] [ALPM-SCRIPTLET] gpg: la prochaine vérification de la base de confiance aura lieu le 2019-03-29
[2018-12-03 19:13] [ALPM] upgraded tslib (1.17-1 -> 1.18-1)
[2018-12-03 19:13] [ALPM] upgraded libcap (2.25-2 -> 2.26-1)
[2018-12-03 19:13] [ALPM] upgraded libsystemd (239.300-2 -> 239.303-1)
[2018-12-03 19:13] [ALPM] upgraded openssl (1.1.1-1 -> 1.1.1.a-1)
[2018-12-03 19:13] [ALPM] upgraded harfbuzz (2.1.3-1 -> 2.2.0-1)
[2018-12-03 19:13] [ALPM] upgraded llvm-libs (7.0.0-1 -> 7.0.0-2)
[2018-12-03 19:13] [ALPM] upgraded pixman (0.34.0-2 -> 0.36.0-1)
[2018-12-03 19:13] [ALPM] installed libnfnetlink (1.0.1-3)
[2018-12-03 19:13] [ALPM] installed libnetfilter_conntrack (1.0.7-1)
[2018-12-03 19:13] [ALPM] upgraded iptables (1:1.8.0-1 -> 1:1.8.2-1)
[2018-12-03 19:13] [ALPM] upgraded systemd (239.300-2 -> 239.303-1)
[2018-12-03 19:13] [ALPM] upgraded kdecoration (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded breeze (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded breeze-gtk (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded libmagick (7.0.8.14-1 -> 7.0.8.15-1)
[2018-12-03 19:13] [ALPM] upgraded imagemagick (7.0.8.14-1 -> 7.0.8.15-1)
[2018-12-03 19:13] [ALPM] upgraded cups-filters (1.21.3-3 -> 1.21.4-1)
[2018-12-03 19:13] [ALPM] upgraded drkonqi (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded fuse-common (3.2.6-1 -> 3.3.0-1)
[2018-12-03 19:13] [ALPM] upgraded fuse3 (3.2.6-1 -> 3.3.0-1)
[2018-12-03 19:13] [ALPM] upgraded harfbuzz-icu (2.1.3-1 -> 2.2.0-1)
[2018-12-03 19:13] [ALPM] upgraded kactivitymanagerd (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded kde-cli-tools (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded libksysguard (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded milou (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded kscreenlocker (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded kwin (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded plasma-integration (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded v4l-utils (1.16.1-1 -> 1.16.2-1)
[2018-12-03 19:13] [ALPM] upgraded vulkan-icd-loader (1.1.85+2969+5abee6173-1 -> 1.1.92+2999+abe5c2b3c-1)
[2018-12-03 19:13] [ALPM] upgraded plasma-workspace (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded systemsettings (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded kde-gtk-config (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded kdeplasma-addons (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded kgamma5 (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded khotkeys (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded kinfocenter (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded kmenuedit (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded knetattach (5.14.3-1 -> 5.14.4-2)
[2018-12-03 19:13] [ALPM] upgraded libkscreen (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded kscreen (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded ksshaskpass (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded ksysguard (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded kwallet-pam (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded kwayland-integration (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded kwrited (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded lib32-harfbuzz (2.1.3-1 -> 2.2.0-1)
[2018-12-03 19:13] [ALPM] upgraded lib32-openssl (1:1.1.1-1 -> 1:1.1.1.a-1)
[2018-12-03 19:13] [ALPM] upgraded libmicrohttpd (0.9.60-1 -> 0.9.61-1)
[2018-12-03 19:13] [ALPM] upgraded libwbclient (4.9.2-1 -> 4.9.3-1)
[2018-12-03 19:13] [ALPM] upgraded linux (4.19.2.arch1-1 -> 4.19.4.arch1-1)
[2018-12-03 19:13] [ALPM] upgraded llvm (7.0.0-1 -> 7.0.0-2)
[2018-12-03 19:13] [ALPM] upgraded mypaint-brushes (1.3.0-2 -> 1.3.0-3)
[2018-12-03 19:13] [ALPM] upgraded nvidia (415.18-1 -> 415.18-4)
[2018-12-03 19:13] [ALPM] upgraded openssl-1.0 (1.0.2.p-1 -> 1.0.2.q-1)
[2018-12-03 19:13] [ALPM] upgraded oxygen (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded pipewire (0.2.3+17+g10ce1a02-1 -> 0.2.4-1)
[2018-12-03 19:13] [ALPM] upgraded polkit-kde-agent (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded plasma-desktop (5.14.3-1 -> 5.14.4-2)
[2018-12-03 19:13] [ALPM] upgraded plasma-sdk (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded plasma-workspace-wallpapers (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded sddm-kcm (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded smbclient (4.9.2-1 -> 4.9.3-1)
[2018-12-03 19:13] [ALPM] upgraded soundtouch (2.1.0-1 -> 2.1.2-1)
[2018-12-03 19:13] [ALPM] upgraded sqlcipher (3.4.2-1 -> 4.0.0-1)
[2018-12-03 19:13] [ALPM] upgraded systemd-sysvcompat (239.300-2 -> 239.303-1)
[2018-12-03 19:13] [ALPM] upgraded thunderbird (60.3.1-2 -> 60.3.2-1)
[2018-12-03 19:13] [ALPM] upgraded thunderbird-i18n-fr (60.3.1-1 -> 60.3.2-1)
[2018-12-03 19:13] [ALPM] upgraded user-manager (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] upgraded virtualbox-host-modules-arch (5.2.22-3 -> 5.2.22-6)
[2018-12-03 19:13] [ALPM] upgraded wildmidi (0.4.2-1 -> 0.4.3-1)
[2018-12-03 19:13] [ALPM] upgraded xdg-desktop-portal-kde (5.14.3-1 -> 5.14.4-1)
[2018-12-03 19:13] [ALPM] transaction completed
[2018-12-03 19:13] [ALPM] running '60-linux.hook'...
[2018-12-03 19:14] [ALPM] running '90-linux.hook'...
[2018-12-03 19:14] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2018-12-03 19:14] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2018-12-03 19:14] [ALPM-SCRIPTLET] ==> Starting build: 4.19.4-arch1-1-ARCH
[2018-12-03 19:14] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-12-03 19:14] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-12-03 19:14] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2018-12-03 19:14] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-12-03 19:14] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-12-03 19:14] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-12-03 19:14] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-12-03 19:14] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-12-03 19:14] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-12-03 19:14] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2018-12-03 19:14] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-12-03 19:14] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2018-12-03 19:14] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2018-12-03 19:14] [ALPM-SCRIPTLET] ==> Starting build: 4.19.4-arch1-1-ARCH
[2018-12-03 19:14] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-12-03 19:14] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-12-03 19:14] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-12-03 19:14] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-12-03 19:14] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-12-03 19:14] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-12-03 19:14] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-12-03 19:14] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-12-03 19:14] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2018-12-03 19:14] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-12-03 19:14] [ALPM] running 'detect-old-perl-modules.hook'...
[2018-12-03 19:14] [ALPM] running 'gtk-update-icon-cache.hook'...
[2018-12-03 19:14] [ALPM] running 'systemd-catalog.hook'...
[2018-12-03 19:14] [ALPM] running 'systemd-daemon-reload.hook'...
[2018-12-03 19:14] [ALPM] running 'systemd-hwdb.hook'...
[2018-12-03 19:14] [ALPM] running 'systemd-sysctl.hook'...
[2018-12-03 19:14] [ALPM] running 'systemd-sysusers.hook'...
[2018-12-03 19:14] [ALPM] running 'systemd-tmpfiles.hook'...
[2018-12-03 19:14] [ALPM] running 'systemd-udev-reload.hook'...
[2018-12-03 19:14] [ALPM] running 'systemd-update.hook'...
[2018-12-03 19:14] [ALPM] running 'texinfo-install.hook'...
[2018-12-03 19:14] [ALPM] running 'update-desktop-database.hook'...
[2018-12-03 20:37] [PACMAN] Running 'pacman -Syu'
[2018-12-03 20:37] [PACMAN] synchronizing package lists
[2018-12-03 20:38] [PACMAN] starting full system upgrade
[2018-12-03 20:38] [ALPM] transaction started
[2018-12-03 20:38] [ALPM] upgraded libqalculate (2.8.1-1 -> 2.8.2-1)
[2018-12-03 20:38] [ALPM] transaction completed
[2018-12-03 20:38] [ALPM] running 'systemd-update.hook'...


Anybody else having this issue too?

Archlinux users (hold on before updating) or delete your file's password before doing so.
User avatar smankowski
Moderator
Posts
872
Karma
7
OS
Could you generate traces by doing this from a console?
export SKGTRACE=8
skrooge > t.txt
try to open you file
Send me the t.txt file by email. (My email is in the about of Skrooge).


Skrooge, a personal finances manager powered by KDE
Image
skrooge
Registered Member
Posts
4
Karma
0

Re: Cannot open file : Wrong password

Mon Dec 03, 2018 10:13 pm
Done, thank you :*
User avatar smankowski
Moderator
Posts
872
Karma
7
OS
For information, on Arch Linux a new version of SQLCipher is deployed (4.0). This version is now compliant with the previous one used by Skrooge.
So, Skrooge is no more able to open a document if you install this new version of SQLCipher.

A correction in Skrooge has been done and will be available in future version (2.17.0).


Skrooge, a personal finances manager powered by KDE
Image
User avatar smankowski
Moderator
Posts
872
Karma
7
OS
Incident opened on Arch linux: https://bugs.archlinux.org/task/60989


Skrooge, a personal finances manager powered by KDE
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: avidscavenger, Baidu [Spider], Bing [Bot], cylverbak, Exabot [Bot], glenl, Google [Bot], thunder422, weegie, Yahoo [Bot]