Reply to topic

Skrooge 2.18.0 Will Not Start

User avatar cmb
Registered Member
Posts
24
Karma
0
OS

Skrooge 2.18.0 Will Not Start

Thu Mar 21, 2019 6:08 pm
I have been successfully running Skrooge version 2.18.0 until recently. Today when I tried to launch the program, it would not start. I see the Skrooge version 2.18.0 splash screen but the program will not run.

In a terminal I entered:
export SKGTRACE=255
skrooge > traces.txt

Skrooge now opens with the message, Your document has been restored from its temporary file. You can decide to reopen the original document. I dismiss the notice. Skrooge appear to work but I didn't not modify anything. I closed Skrooge. The traces.txt file (275 kilobytes) is available but apparently there is no mechanism to attach it to this forum posting.

If I open Skrooge from the command line without the trace (just skrooge), I receive these two (identical) warnings:
##WARNING: libpng warning: iCCP: known incorrect sRGB profile
##WARNING: libpng warning: iCCP: known incorrect sRGB profile


Skrooge will still not launch from the GUI. The splash screen just appears briefly. What should I try next?
---------
Skrooge version: 2.18.0-0ubuntu1~ppa2
sqlcipher version (from the command line): 3.15.2 2016-11-28 19:13:37 bbd85d235f7037c6a033a9690534391ffeacecc8
although Synaptic reports that the installed version of sqlcipher is 3.4.1-1build1.

Operating System: Kubuntu 18.10
KDE Plasma Version: 5.15.3
KDE Frameworks Version: 5.54.0
Qt Version: 5.11.1
Kernel Version: 4.18.0-16-generic


Charles
User avatar smankowski
Moderator
Posts
953
Karma
7
OS

Re: Skrooge 2.18.0 Will Not Start

Thu Mar 21, 2019 6:48 pm
You can try to reinstall it:
Code: Select all
sudo apt remove skrooge*
sudo apt-get install skrooge-kf5


Skrooge, a personal finances manager powered by KDE
Image
User avatar cmb
Registered Member
Posts
24
Karma
0
OS

Re: Skrooge 2.18.0 Will Not Start

Thu Mar 21, 2019 9:19 pm
smankowski wrote:You can try to reinstall it...

In a terminal, I did as you requested.
Code: Select all
$ sudo apt remove skrooge*
...
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'skrooge-kf5-common' for glob 'skrooge*'
Note, selecting 'skrooge' for glob 'skrooge*'
Note, selecting 'skrooge-common' for glob 'skrooge*'
Note, selecting 'skrooge-kf5' for glob 'skrooge*'
Package 'skrooge' is not installed, so not removed
Package 'skrooge-common' is not installed, so not removed
...
Removing skrooge-kf5 (2.18.0-0ubuntu1~ppa2) ...
Removing skrooge-kf5-common (2.18.0-0ubuntu1~ppa2) ...

Then, for good measure, I ran the autoremove.
Code: Select all
sudo apt autoremove
...
The following packages will be REMOVED:
  libgrantlee-core0 libqjson0 libsqlcipher0 python-blinker python-certifi python-fasteners python-gdata
  python-geopy python-googleapi python-html2text python-httplib2 python-jwt python-monotonic
  python-oauth2client python-oauthlib python-prettytable python-pyasn1-modules python-pycryptodome
  python-requests python-requests-oauthlib python-rsa python-sqlalchemy python-sqlalchemy-ext
  python-termcolor python-tz python-unidecode python-uritemplate python-urllib3 python-weboob sqlcipher
  sqlite3 weboob xsltproc
0 upgraded, 0 newly installed, 33 to remove and 0 not upgraded.

Finally I reinstalled Skrooge.
Code: Select all
sudo apt-get install skrooge-kf5
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  libgrantlee-core0 libqjson0 libsqlcipher0 python-blinker python-certifi python-fasteners python-gdata
  python-geopy python-googleapi python-html2text python-httplib2 python-jwt python-monotonic
  python-oauth2client python-oauthlib python-prettytable python-pyasn1-modules python-pycryptodome
  python-requests python-requests-oauthlib python-rsa python-sqlalchemy python-sqlalchemy-ext
  python-termcolor python-tz python-unidecode python-uritemplate python-urllib3 python-weboob
  skrooge-kf5-common sqlcipher sqlite3 weboob xsltproc
Suggested packages:
  python-blinker-doc python-gdata-doc python-twisted-core python-socks python-sqlalchemy-doc
  python-psycopg2 python-pymysql python-fdb python-pymssql python-ntlm python-nose sqlite3-doc
The following NEW packages will be installed:
  libgrantlee-core0 libqjson0 libsqlcipher0 python-blinker python-certifi python-fasteners python-gdata
  python-geopy python-googleapi python-html2text python-httplib2 python-jwt python-monotonic
  python-oauth2client python-oauthlib python-prettytable python-pyasn1-modules python-pycryptodome
  python-requests python-requests-oauthlib python-rsa python-sqlalchemy python-sqlalchemy-ext
  python-termcolor python-tz python-unidecode python-uritemplate python-urllib3 python-weboob
  skrooge-kf5 skrooge-kf5-common sqlcipher sqlite3 weboob xsltproc
0 upgraded, 35 newly installed, 0 to remove and 0 not upgraded.

Unfortunately there was no improvement in the loading of Skrooge. I still see just a brief appearance of the splash screen for version 2.18.0 but nothing else.


Charles
User avatar skierpage
Registered Member
Posts
15
Karma
0
OS

Re: Skrooge 2.18.0 Will Not Start

Wed Apr 10, 2019 12:23 am
Are you saying Skrooge doesn't get past the splash screen at all, or only that it doesn't run when started from the GUI?

Are you running the flatpak of Skrooge 2.18 from Flathub? That is crashing for me, but it crashes whether I start from the command line or the GUI.

If Skrooge doesn't get past the splash screen when run from the command line, there may be some informative error in the huge trace output. It's tricky to search for "err" because of all the traces containing "virtual SKGError", but you can try running something like the command

Code: Select all
grep -i '[^g]err' traces.txt


at the command line, which means "find lines in traces.txt containing 'err' that don't have a preceding 'g'.
User avatar cmb
Registered Member
Posts
24
Karma
0
OS

Re: Skrooge 2.18.0 Will Not Start

Wed Apr 10, 2019 2:28 am
When started from the GUI, I see the splash screen and some status messages. The last one is (something like), Loading plugin 25/25. Deleting plugin. Then the splash screen closes. The program does not open.

If I try to run Skrooge from the GUI a second time, the splash screen opens, shows no loading messages and immediately closes.

When started from the command line, my installation of Skrooge loads and works as expected. The terminal shows WARNING: libpng warning: iCCP: known incorrect sRGB profile twice.

Yes, I am running the flatpak of Skrooge 2.18 from Flathub.

It might not be meaningful for Skrooge started successfully from the command line but I did a trace anyway and grepped as you suggest. I only see four error instances.

Code: Select all
<virtual SKGError SKGDocument::getMessages(int, SKGDocument::SKGMessageList&, bool) RC=[ERR-3]: No database defined
<SKGError SKGObjectBase::load() RC=[ERR-8]: Load of 'doctransaction' with 'id=1' failed because it was not found in the database
<SKGError SKGObjectBase::load() RC=[ERR-8]: Load of 'doctransaction' with 'id=2' failed because it was not found in the database
<SKGError SKGObjectBase::load() RC=[ERR-8]: Load of 'doctransaction' with 'id=4' failed because it was not found in the database


Charles
User avatar smankowski
Moderator
Posts
953
Karma
7
OS

Re: Skrooge 2.18.0 Will Not Start

Fri Apr 12, 2019 7:51 pm
The message "No database defined" sounds not good. It seems that the installation is not good. The sqlcipher plugin seems to be not found.
We are building a new flatpack version in KDE repo (should be available in 1 or 2 days). You can may be test it: https://community.kde.org/Guidelines_and_HOWTOs/Flatpak


Skrooge, a personal finances manager powered by KDE
Image
User avatar cmb
Registered Member
Posts
24
Karma
0
OS

Re: Skrooge 2.18.0 Will Not Start

Wed Apr 17, 2019 10:00 pm
The new version of Skrooge became available to me just today via the KDE's Discover Software Center. I am happy to report that Skrooge now opens and runs from the GUI as expected.

By the way, the version of Skrooge on Flathub is still marked stable and when Skrooge runs it still shows a version of 2.18.0.


Charles
User avatar cmb
Registered Member
Posts
24
Karma
0
OS

Re: Skrooge 2.18.0 Will Not Start

Fri Apr 19, 2019 6:34 pm
Well it worked for a while. :( Skrooge will not start from the GUI again. The splash screen pops up for a second, them immediately closes.

I can successfully start Skrooge from a terminal. Also I am seeing the same errors in the trace as reported in my message of Tue Apr 09, 2019 6:28 pm above.
---------
Skrooge version: 2.18.0-0ubuntu1~ppa2
Operating System: Kubuntu 18.10
KDE Plasma Version: 5.15.3
KDE Frameworks Version: 5.54.0
Qt Version: 5.11.1
Kernel Version: 4.18.0-17-generic
OS Type: 64-bit


Charles
dberg918
Registered Member
Posts
16
Karma
0
OS

Re: Skrooge 2.18.0 Will Not Start

Sat Apr 20, 2019 7:18 am
The Skrooge package on Flathub hasn't exactly lived up to it's "stable" designation recently, but it seems like the KDE runtime is partially the culprit. If you're getting the Qt version errors when trying to run Skrooge, try downgrading your KDE Platform runtime. I was able to get it working again by running the following:
Code: Select all
sudo flatpak update org.kde.Platform --commit=4a85fdb18b211c6ed2f4863ad0323e5c55df391e5c74d617ad712ad483d38942

That should put you back on the previous commit of org.kde.Platform and allow the Skrooge application to run properly. Both the Flathub "stable" branch and the kdeapps "master" (nightly) branch are working on that version of the platform for me. Hopefully the Skrooge packages get updated soon to match whatever update occurred in the latest KDE runtime...
User avatar cmb
Registered Member
Posts
24
Karma
0
OS

Re: Skrooge 2.18.0 Will Not Start

Sat Apr 20, 2019 2:21 pm
dberg918 wrote:The Skrooge package on Flathub hasn't exactly lived up to it's "stable" designation recently, but it seems like the KDE runtime is partially the culprit. If you're getting the Qt version errors when trying to run Skrooge, try downgrading your KDE Platform runtime.

I was actually considering going the other way. I want to upgrade from Kubuntu 18.10 to 19.04 to pick up some improvements in the operating system.
dberg918 wrote:Both the Flathub "stable" branch and the kdeapps "master" (nightly) branch are working on that version of the platform for me.

Skrooge works well for me. It's just that I have to start it from the command line.

Just now I picked up the new version 2.19.0 of Skrooge available in Discover from Flathub. (Still labeled stable in Discover.) I tried to start it from the GUI but it would not open. The splash screen still shows 2.18.0.

Then I tried to start it from the command line and the version 2.19.0 splash screen appears. The Skrooge program then opens and runs as expected. For what it's worth, if I run a trace on the command line start, I see the same errors as noted above.

By the way, when attempting to start from the GUI, I am not using a Favorite in the Application Launcher. I start typing the name of the program in the search bar and select the item from the offered options.


Charles
User avatar smankowski
Moderator
Posts
953
Karma
7
OS
Hi,

You should not have 2 versions of Skrooge on your system.
On kubuntu, my advice is to install the last version (2.19.0 published yesterday) from my ppa: https://skrooge.org/ubuntu_installation
If you have installed a flatpak version, you should uninstall it.
Regards.


Skrooge, a personal finances manager powered by KDE
Image
User avatar cmb
Registered Member
Posts
24
Karma
0
OS

Re: Skrooge 2.18.0 Will Not Start

Sun Apr 21, 2019 4:43 pm
On my installation of Kubuntu 18.10, the Discover 5.15.4 Application Explorer shows three available sources for Skrooge.
    unbuntu-cosmic-universe offering version 2.15.0-1 (not installed)
    flathub offering version 'stable' (version 2.19.0-installed)
    snap offering version 2.18.0 (not installed)
The Synaptic program indicates that skrooge-kf5 version 2.19.0-0ubuntu1-ppa2 is installed.

The terminal command whereis -b skrooge reports:
skrooge: /usr/bin/skrooge /usr/share/skrooge

I uninstalled Skrooge as follows:
    In Discover, I selected the flathub source and then selected Remove.
    In Synaptic, I marked skrooge-kf5 and skrooge-kf5-common for removal and selected Apply.
Now the terminal command whereis -b skrooge shows only:
skrooge:

Just in case, I deleted the http://ppa.launchpad.net/s-mankowski/ppa-kf5/ubuntu/ source shown in Discover and Synaptic.
Then in a terminal, I installed the Stable KF5/Qt5 PPA with sudo add-apt-repository ppa:s-mankowski/ppa-kf5.

Checking the sources in Discover, the http://ppa.launchpad.net/s-mankowski/ppa-kf5/ubuntu has returned as expected.
Following a sudo apt-get update, I installed Skrooge with sudo apt-get install skrooge-kf5.

I can now successfully start Skrooge from the GUI. Version 2.19.0 opens and runs. Furthermore, Skrooge opens from the GUI even after a reboot.


Charles

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, davis, Google [Bot], Mamarok, Sogou [Bot], vinnywright