Reply to topic

Compiling issue with qt 5.15

User avatar JesusM
Registered Member
Posts
149
Karma
0
OS

Compiling issue with qt 5.15

Wed Jun 03, 2020 4:49 pm
Hi,

I have updated my system and a more recent qt release has been installed, causing a problem to run Skrooge:

Code: Select all
[email protected]:~$ skrooge
##FATAL: Cannot mix incompatible Qt library (5.13.2) with this library (5.15.0)
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = skrooge path = /usr/bin pid = 11939
KCrash: Arguments: /usr/bin/skrooge
KCrash: Attempting to start /usr/lib64/drkonqi

[1]+  Stopped                 skrooge

##WARNING: QSocketNotifier: Invalid socket 20 and type 'Read', disabling...
pa_write() failed while trying to wake up the mainloop: Bad file descriptor
pa_write() failed while trying to wake up the mainloop: Bad file descriptor
Invalid write to eventfd: Bad file descriptor
Code should not be reached at ../src/pulsecore/fdsem.c:199, function pa_fdsem_post(). Aborting.
Unable to start Dr. Konqi

[1]+  Exit 255                skrooge


So, I tried to build Skrooge again, hoping than rebuilding against Qt 5.15.0 would fix the problem, but then I get this:

Code: Select all
CMake Error at /usr/share/cmake-3.17/Modules/CMakeFindDependencyMacro.cmake:47 (find_package):
  Found package configuration file:

    /usr/lib64/cmake/Qt5WebKit/Qt5WebKitConfig.cmake

  but it set Qt5WebKit_FOUND to FALSE so package "Qt5WebKit" is considered to
  be NOT FOUND.  Reason given by package:

  Qt5WebKit could not be found because dependency is required to have exact
  version 5.13.x.

Call Stack (most recent call first):
  /usr/lib64/cmake/Qt5WebKitWidgets/Qt5WebKitWidgetsConfig.cmake:93 (find_dependency)
  /usr/lib64/cmake/Qt5/Qt5Config.cmake:28 (find_package)
  CMakeLists.txt:57 (FIND_PACKAGE)



I've tried to find where the exact version 5.13.x is specified to see if I was able to overpass it, but I could not, so ... any idea?

Thanks
User avatar JesusM
Registered Member
Posts
149
Karma
0
OS
Apparently when qt5-5.15.0-x86_64-1.txz was upgraded from qt5-5.13.2-x86_64-4.txz, they needed to rebuild qt5-webkit-5.212.0_alpha4-x86_64-3.txz as well.

Now it is working fine (apart from a warning because sqlcipher in the system is newer than the embedded one).

Thanks!

 
Reply to topic

Bookmarks



Who is online

Registered users: adetayo, Baidu [Spider], bbaker, Bing [Bot], claydoh, farid, Google [Bot], grahm, kde-arran, Lachu, luther, Majestic-12 [Bot], pewzers, Section_8, Sogou [Bot], spoontex, TG, YaCy [Bot]