Reply to topic

Skrooge currency entry and localization

rbruce
Registered Member
Posts
57
Karma
0
OS
I think I've found a bug with Skrooge and transaction amount of 1000 or larger. Skrooge doesn't like the comma (",") used in the US locale as a thousands separator.

I'm using Skrooge 0.9.0 on Kubuntu 11.04. (locale is USA, and I think this matters) When I go to edit the amount of a transaction, I get the snowflake in the amount box indicating it's frozen, and the <Add> and <Modify> buttons are deactivated (grayed out).

It took some investigation, but I found that it only affected amount larger that 999.99. E.g., entering (or changing) an amount of $1,200.00 to $1,200.50 Skrooge prevents the transaction from be modified or copied.

If I remove the comma, so the amount in the example becomes $1200.00, I can Add or Modify. Likewise if I replace the "," (comma) with a space for the 1000s separator, no problem ($1 200.50 works fine).

Should I file a bug report on Skrooge? I can do further investigation before that if appropriate. Or is there a setting I should be changing that I haven't thought of?
User avatar smankowski
Moderator
Posts
1011
Karma
7
OS
Hi,

I am the main developer of Skrooge.
You are right, this is a bug.
You can open it in the bug tacker.
In any case, I will correct it.

Thank you for using Skrooge.
Stephane


Skrooge, a personal finances manager powered by KDE
Image - PayPal
User avatar smankowski
Moderator
Posts
1011
Karma
7
OS
Hi,

The correction is done and delivered in git.

I am publishing a beta version 0.9.91 including this correction.

You can install it if you want:
http://skrooge.org/ubuntu_installation


Skrooge, a personal finances manager powered by KDE
Image - PayPal
rbruce
Registered Member
Posts
57
Karma
0
OS
Wow! That was fast. Thanks.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], boblundgren, boospy007, claydoh, fayl, Google [Bot], Hokasito, kde-camillem, Majestic-12 [Bot], rblackwell, Yahoo [Bot]