Reply to topic

Skrooge 0.9.1Error opening skg-file

Max_23
Registered Member
Posts
3
Karma
0
OS

Skrooge 0.9.1Error opening skg-file

Sat Sep 10, 2011 11:19 am
I try to use skrooge for after three months. But it won't open my skg-file. I get an error opening file. See error codes below.

Code: Select all
[ERR-5]: Failed to open '/home/max/documents/skrooge_doc_actueel_2009_2011.skg'.
[ERR-5]: Database migration from version 6.3 to version 6.7 failed
[ERR-5]: Database migration from version 1.1 to version 1.1 failed
[ERR-10019]: columns t_name, r_node_id are not unique Unable to fetch row
[ERR-10019]: UPDATE node SET r_node_id=0 WHERE r_node_id!=0 AND r_node_id NOT IN (SELECT DISTINCT(id) FROM node)


I use Skrooge in Opensuse 11.4 with KDE 4.6.

What to do?
BigaAl
Moderator
Posts
30
Karma
0
OS
Hi I cant help you with the SKG problem, but assume you had Skrooge working well at the start?
If yes, please try the following:
Back up your current skg file. Only after doing this, then try to revert to an earlier version which did work.
You may have already tried this, but if not it may get you back to working again. Then from there the migration to higher version should be able to be sorted by Skrooge dev guys. Thanks, Al.
User avatar smankowski
Moderator
Posts
1011
Karma
7
OS
Hi,

The problem is known I did a correction for that.
This correction is in "Feature" branch of git.
So, if you know how to build Skrooge, you can get it.

If you don't know.
The best solution is the following one.
1-Backup your document
2-Uninstall Skrooge 0.9.1
3-Install the previous version of Skrooge
4-Launch Skrooge
5-Remove all bookmarks
5-Save the document
6-Install Skrooge 0.9.1

That's all.
Regards.


Skrooge, a personal finances manager powered by KDE
Image - PayPal
Max_23
Registered Member
Posts
3
Karma
0
OS
@both: thanks for the answer.

@BigaAl: I am in no hurry to use Skrooge. I can wait at least two months for a solution in a new version. I try an old version later.

@smankowski, thanx for your answer. I learned to build a few months ago. But with a fresh install I didn't re-installed all necessary files. If I need my administration I do as both of you advise, go back to a previous version, with your extra advise to remove bookmarks.
If you have this "Feature" planned for a new version, I can wait. For at least a month or two. It is enough to do my bookkeeping once every quarter or so. Thanks for you're answers to this point.
Max_23
Registered Member
Posts
3
Karma
0
OS
I have installed version 1.0.0 from the opensuse repository. I tried earlier to install a previous version. But only 0.7.3 was available in rpm. And that version did not accept my document either.

With version 1.0.0 my skrooge document got opened again. So thanks for answering my posts earlier and for making a new version that worked on my document. Waiting helped, for me (patience is a virtue).
And direct answers from the developer is an honour.

I have something to do now. I don't like to do my administration. But Skrooge helps to keep it fun. Thanks for that.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], exahamza, Google [Bot], jkurutz, Majestic-12 [Bot], razorrob, shevchuk, Sogou [Bot], Yahoo [Bot]