Reply to topic

Disable Suspend / Screen Locker

prplmnky
Registered Member
Posts
3
Karma
0

Disable Suspend / Screen Locker

Mon Jul 01, 2013 5:16 pm
Hi everyone,

I have a device running Plasma Active 3, and I'm experience some problems with screen locking and suspend. Every time the device suspends and I press the power button, the screen locker appears but doesn't respond to the touch panel, or keyboard dock. Also, the screen locking doesn't heed the power management options in the settings app.

I would greatly appreciate it if someone could give directions on how to turn of suspend and screen locker.

Thanks!
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS

Re: Disable Suspend / Screen Locker

Tue Jul 02, 2013 7:39 am
Unfortunately I'm not sure regarding how Plasma Active's screen locker system works.
Can you check to see if a "kscreenlocker" process is running in the background.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
prplmnky
Registered Member
Posts
3
Karma
0

Re: Disable Suspend / Screen Locker

Fri Jul 19, 2013 4:32 am
bcooksley wrote:Unfortunately I'm not sure regarding how Plasma Active's screen locker system works.
Can you check to see if a "kscreenlocker" process is running in the background.


I don't see a kscreenlocker, there is a "suspend" service though.

For the time being, I modified the kernel to never do a suspend or pm suspend. After that, the screen still locks during the uxlaunch, but I can still retain control. As a side note, the screen locker no longer displays the Suspend slider.
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS

Re: Disable Suspend / Screen Locker

Fri Jul 19, 2013 10:46 am
Okay - Plasma Active must use a different mechanism to the desktop systems. The lack of the suspend slider is likely because KDE no longer detects the ability to suspend - and therefore no longer offers the option to do it.

Assuming your device is touchscreen based, this is probably a bug in the kernel touch screen driver not handling suspend properly. If you'd like to investigate it further, you could try reloading the driver (remove + reinsert) on suspend / resume.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, Dibo, Google [Bot], hsnnsnc, Majestic-12 [Bot], nocruoro