Reply to topic

import from nikon s550 ptp always has wrong file permissons

User avatar waldelf
Registered Member
Posts
333
Karma
0
OS
using the gwenview importer or simply with dolphin - it does not matter.
new files "downloaded" from the camera always get the file permissions r-r-r

i honestly have no clue why this is happening.. maybe it is this PTP thing? but it seems there is no menu entry on the camera to chose "normal" mass storage mode.

thx in advance!


Kubuntu 12.04 x64 | KDE SC 4.8
Nvidia 8800 GTS | Core2Duo E6600 | 4 GB RAM
User avatar agateau
Moderator
Posts
97
Karma
0
OS
Since the problem happen both with Gwenview importer and with Dolphin, I agree it must be a problem with the ioslave. Are you using the camera:/ ioslave?
User avatar bcooksley
Administrator
Posts
19743
Karma
85
OS
Also, are files you normally create or copy using Dolphin given the same permissions?
The source slave should not be able to influence the permissions given to the destination file - but your umask may be manipulating the resulting file permissions.


System Settings and Device Actions KCM maintainer
Image
User avatar waldelf
Registered Member
Posts
333
Karma
0
OS
hello and thank you for your answers.
the file/folder permissions of the target directory are set to read/write

i never had this problem before with other devices. i plug in the camera, klick on the device manager to open the device in dolphin, than select,copy and paste all the files to the target dir.

it looks like all the permissons are set correctly first but after half a second they change to r-r-r ..
i'm not infront of the pc right now but i will check out if this happens on other devices to as soon as possible.


Kubuntu 12.04 x64 | KDE SC 4.8
Nvidia 8800 GTS | Core2Duo E6600 | 4 GB RAM
User avatar waldelf
Registered Member
Posts
333
Karma
0
OS
oke.. i tried different devices on this pc and none of them had a similar problem.. i found out that the camera (nikon s550) stores the files with r-r-r mode on the SDcard (what is actually impossible since the card is formatted with fat32)
the camera:/ I/O-slave is used and for real none of the folders i see in dolphin really exist on the sdcard.. honestly i just don't get this "ptp" mode.

the problem is: i cant get the camera to connect in "normal" mass storage device mode.. there is no menu entry to configure the USB connection.


for now i wrote a small script that starts the "gwenview importer" and changes the permissions afterwards.. (this pc is used by an older person and has to be as easy to use as it can be)


Kubuntu 12.04 x64 | KDE SC 4.8
Nvidia 8800 GTS | Core2Duo E6600 | 4 GB RAM
User avatar bcooksley
Administrator
Posts
19743
Karma
85
OS
The PTP mode is dependent upon the camera in question unfortunately - it can expose the storage and data on it in any form it wants to (the same effect can be had with MTP as well - although that is usually fairly standard). Another possibility here might be to use a SD Card reader if you have one available.

My guess is that KDE is simply respecting the existing permissions - which in the case of the PTP protocol, backfires unfortunately when devices do not behave correctly.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], cylverbak, darktori, davidemme, eranb, Exabot [Bot], Google [Bot], kde-lunarparks, koriun, MSNbot Media, odysseus-art, rv8ter, sparhawk, veqz, vpinon, Yahoo [Bot]