Reply to topic

Cannot delete Mails from toplevel INBOX folder

thesummer
Registered Member
Posts
13
Karma
0
OS
Hello,

I started to move my email management to kmail.
I use IMAP with server-sided subscription, and my INBOX-folder has a subfolder for mailinglists.
The weird thing I noticed today is, that I can delete (i.e move to trash) messages from the "sent" folder and the "mailinglist" folder, but not from the toplevel INBOX-folder where the general mails are located. The button "Move to trash" is just disabled when I am in that folder (same is true for all other means to delete an email).

I searched in the settings dialog for a missing tick in a checkbox, but couldn't find anything which would help. Does someone came across this behaviour and knows how to fix it?

Edit:
I use Kubuntu 12.04 with KDE SC 4.11 from the backports repository.

Best regards,

Jan

Last edited by thesummer on Sun Aug 18, 2013 5:35 pm, edited 1 time in total.
contremaitre
Registered Member
Posts
70
Karma
0
I have exactly the same problem. I thought I would write a post here and saw this one.

I have several subfolder and I can delete messages from these subfolder, but the messages in the top level Inbox folder cannot be deleted, the move to trash is disabled. I checked the trash folder is well configured for this account.

So I am also looking for a solution.
thesummer
Registered Member
Posts
13
Karma
0
OS
I just noticed, I forgot to tell I use Kubuntu 12.04 with KDE SC 4.11 from the backports repository.
thesummer
Registered Member
Posts
13
Karma
0
OS
Ok. I tried it again with another email-account which has no subfolders.
There the move to trash button is active.
contremaitre
Registered Member
Posts
70
Karma
0
I can add that it is also impossible to move a mail from this folder to another. It's only possible to copy it.
I am using kmail and kde 4.10.5
thesummer
Registered Member
Posts
13
Karma
0
OS
I found this Bug #316153 and added my system configuration there. Maybe you want to add yours as well.
thesummer
Registered Member
Posts
13
Karma
0
OS
Ok. I now did the following:

I added a second imap-mailbox and created a subfolder in its inbox to test, if the fault may be at my provider.
Everything worked well, I could move and delete emails between all folders and the trash. Afterwards I deleted my main mailbox (which does not work correctly) and added it again. I used the same settings, but now it works.
Now I am confused, but it works.... ;D

Probably adding a second mailbox is not necessary, so it can solve your problems as well if you just delete and add your mailbox to akonadi again?
contremaitre
Registered Member
Posts
70
Karma
0
So it must be a configuration bug of kmail.
I would prefer a real bugfix, but your workaround is good to know. You can put it in the bug report.
thesummer
Registered Member
Posts
13
Karma
0
OS
contremaitre wrote:So it must be a configuration bug of kmail.
I would prefer a real bugfix, but your workaround is good to know. You can put it in the bug report.


That means it worked for you as well?
contremaitre
Registered Member
Posts
70
Karma
0
Didn't try, because I don't want to download all my mails again.
mujalan
Registered Member
Posts
1
Karma
0
OS
I have the same problem. Can't delete, can't move to trash from the top box. However I can drag an email from the top box to the trash folder. Seems to work okay that way.
thesummer
Registered Member
Posts
13
Karma
0
OS
mujalan wrote:I have the same problem. Can't delete, can't move to trash from the top box. However I can drag an email from the top box to the trash folder. Seems to work okay that way.


Have you tried to delete your mailbox and add it again? That worked for me.
zxq9
Registered Member
Posts
1
Karma
0
I've just run into this problem for on kmail 4.10.5 on Gentoo.

The problem seems to apply specifically to IMAP folders with subfolders. This is unfortunate since the most common way for people to organize their mail (and indeed the only way possible through some interfaces) is to create subfolders in the inbox.

The easiest remedy is to simply remove the account and re-create it. The recreated version will work fine. In this case the reason IMAP is annoying is also the reason it is wonderful: you can recreate your mail account without losing anything, but the sync time can be significant if you have tens of thousands of messages and a slow connection.

In my case this bug occurred only with account profiles where I had made a mistake setting them up the first time around (specifically, my account name set incorrectly and later corrected). I'm not sure if this is significant or a coincidence, but I thought I'd mention it. Its certainly not a server-side problem -- the same accounts worked perfectly on kmail 4.6 (on RHEL), mutt (Debian Wheezy) and Thunderbird 17 (Windows 7).

edit: I was going to note this on bugzilla, but its giving me grief about logging in and its late.
User avatar einar
Administrator
Posts
3400
Karma
7
OS
I haven't seen this in quite a while. Did this only occur when you started from KDE PIM 4.10? If you have the chance, can you test whether this works with KDE PIM 4.11?


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
diederikdehaas
Registered Member
Posts
8
Karma
0
OS
einar wrote:Did this only occur when you started from KDE PIM 4.10? If you have the chance, can you test whether this works with KDE PIM 4.11?

I've encountered this issue on a freshly installed Debian Sid system with KDE (PIM) 4.11.3.
I've just removed and re-added the (receiving) account and that seems to solve it.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], Majestic-12 [Bot], miguelrozsas, robbystephenson, Snudl, tavernsenses