Reply to topic

Google blocking KMail?

arindom
Registered Member
Posts
53
Karma
0
OS

Re: Google blocking KMail?

Sat Aug 03, 2019 2:23 pm
VA3DBJ wrote:
arindom wrote:
VA3DBJ wrote:OK, this may seem weird. I tried from scratch again. Went through the process and of course, I got the error message. But on a hunch, from a previous API change they made, I changed the Authentication from Gmail to PLAIN. Don't do a test. Just change it and save, then go back to the Receiving tab and select Gmail and hit the restart button.

Currently it is working and syncing.


Thanks a lot for sharing your experiences. Well I tried again but changing the Authentication from Gmail to Clear Text (No Plain option was there when I tried) didn't work either. It shows a message as :

"The server for account "Google Mail <Account name> refused the supplied username and password. Do you want to go to the settings, have another attempt at logging in, or do nothing?

Login failed, server replied: A000002 NO Invalid credentials ( Failure ) [ AUTHENTICATIONFAILED ]
"

If I recall correctly, I had seen this issue when I tried KDE sometime back earlier.


As of today, the work around stopped working. Forced to go back to Evolution. Tried the flatpak nightly, but can't get it to work at all, or even see my pgp keys.


I also did the same.
arindom
Registered Member
Posts
53
Karma
0
OS

Re: Google blocking KMail?

Wed Aug 07, 2019 12:53 pm
Finally got KMail working with GMail, although not the natural way but now at least I can get the mails.

# I tried with 2-way auth accounts.
# Turned on App Passwords.
# Created one for KMail.
# Now, added the Gmail account normally through OAuth.
# Error happened. Closed the OAuth window.
# Visited the mail setup page.
# Changed IMAP server to googlemail from gmail.
# Security changed to "Clear Text".

Result : The account appeared connected and mails can be viewed. I have not tried sending any mail though.

Actually, this is not something new. I have seen many got it worked this way, but somehow I couldn't make it working for my accounts. So, just thought to mention the steps, if it helps others.

Question : Is this method safe?
guhumueller
Registered Member
Posts
1
Karma
0
OS

Re: Google blocking KMail?

Sat Aug 10, 2019 9:41 am
,Problem similar to that above. Kmail indicates "offline" and cannot be switched to "online".
Will there be an update for kmail or a recommendation for a process to overcome that problem?
User avatar mykolak
Registered Member
Posts
8
Karma
0

Re: Google blocking KMail?

Tue Aug 13, 2019 11:04 am
I had LibKGAPI accessToken which expired a week ago and now it isn't refreshed. Is this same problem?
User avatar mykolak
Registered Member
Posts
8
Karma
0

Re: Google blocking KMail?

Tue Aug 13, 2019 11:11 am
guhumueller wrote:,Problem similar to that above. Kmail indicates "offline" and cannot be switched to "online".
Will there be an update for kmail or a recommendation for a process to overcome that problem?

I had the same, I've checked logs and found message about invalid token, I've checked KWalletManager→LibKGAPI→Maps→(only one entry) Key - email, Value - JSON, where expires already in the past for me, so that accessToken couldn't be used. I've switched to PLAIN auth method for now.
User avatar afogl001
Registered Member
Posts
8
Karma
0
OS

Re: Google blocking KMail?

Wed Aug 14, 2019 2:00 pm
Woohoo! Changing authentication type from "Gmail" to "PLAIN" worked for me (for BOTH my Gmail accounts)! Here's my setup if it's helpful:
- 2FA enabled via Gmail
- "App Password" supplied to Kontact/Kmail
- SSL/TLS:993:PLAIN
- Kontact 5.11.3
- KDE Neon 5.16.4

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], clavierarabes, Google [Bot], kde-wheezy, korgoroth, madjoe, Sogou [Bot], Yahoo [Bot]