Reply to topic

Kontact will not store GPG password in Kwallet

iookde
Registered Member
Posts
12
Karma
0
I am using Kontact with an email account that uses GPG. Everytime I start my PC I have to enter the password which is very long. I do not want this. I believe that KDE can store this password in Kdewallet but it doesn't seem to work.

When I open Kontact and click on an email, I get a rather aggressive dialog box prompting me to enter the password to decrypt the email. At the bottom there is a checkbox:

"Save in password manager"

I check this box and enter the password. The password is accepted however the password is never stored in Kwallet.

I did some research and I believe that the dialog box that is being displayed here is called "pinentry-kwallet" and it is called from the gpg-agent daemon.

From this page man page:
http://manpages.ubuntu.com/manpages/xen ... let.1.html

it appears that this dialogue box should be capable of taking my GPG password and storing it in Kwallet as described here:
pinentry-kwallet replaces the regular pinentry-program stanza set in ~/.gnupg/gpg-agent.conf
and looks up the passphrases requested in the KWallet first, falling back to pinentry only
if not found. The user is given the option to store it in the KWallet afterwards."


This never works however. If I check the box to save the password, I get this message in the journalctl:
gnome-keyring-daemon[1134]: asked to register item /org/freedesktop/secrets/collection/Default_5fkeyring/7, but it's already registered


When I open Kdewallet I can see that kontact is currently connected and authorized to access the wallet but it never saves the password.

I am migrating to KDE from Evolution on Gnome and I believe that Seahorse took care of this for me. I entered my GPG password once and remembered it which is what I want.

Can someone familiar with these systems confirm the Kontact has the ability to integrate with gpg-agent and store the entered password in Kdewallet? Is this a bug? Has anyone else experienced this?
iookde
Registered Member
Posts
12
Karma
0
If anyone finds this message after struggling countless hours like I did, I finally found the solution myself.

The key is that KDE is actually missing a component "pinentry-kwallet" which can be installed from the package "kwalletcli"

Once this is installed you can configure gpg-agent.conf with the following line:
pinentry-program /usr/bin/pinentry-kwallet

Then when you enter your password the next time, you will have the option to store your password in kwallet.

Gnome has seahorse which takes care of this out of the box so anyone trying KDE may be frustrated and surprised that this doesn't work. Perhaps the KDE developers can fix this for the future.

 
Reply to topic

Bookmarks



Who is online

Registered users: Bing [Bot], Google [Bot], Sogou [Bot]