Reply to topic

Losing tagged mails; restoration from old db possible?

alvanx
Registered Member
Posts
136
Karma
1
OS
Hi, I've been having massive problems ever since the upgrade to 4.8 (in fact there seems to be a major problem every couple of months). But that is (or was) a different story.

Anyways, as there was no solution in sight and, strictly following Murphy's Law, I was not able to restore backups either, I started a new Akonadi database. However, now I have lost several emails that were tagged as "to do"! I don't think I lost all of them (I found a few older ones), but certainly a majority. It is not that the emails lost their tags, they cannot be found. Apparently, Akonadi had some sinister plans for these emails and had moved them out of my $HOME/.local/share/local-mail directory. Fortunately, I have my old database backed up, so I could restore it somehow. If I knew that the emails are in there. Or would they be in the Nepomuk database since Nepomuk handles the tagging? (I had also started a new Nepomuk database.)

Can anybody help me out? Is there some way to pull an email out of the Akonadi database? Or were else could those mails be?

EDIT: Oh yeah, and then there is the fact that I actually tagged a new message as "to do" (the standard tag) and it disappeared before my eyes! Is there any explanation for that?

Last edited by alvanx on Mon Feb 06, 2012 11:17 am, edited 1 time in total.
User avatar einar
Administrator
Posts
3402
Karma
7
OS
Tags are stored into Nepomuk, as you hinted. So that's why you lost them by removing the pre-existing Nepomuk database.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
alvanx
Registered Member
Posts
136
Karma
1
OS
But I am talking about the actual emails, not just the tags. The tagged emails vanished! It's not just that they lost their tags, but rather that I cannot find a majority of my emails anymore that had been tagged previouosly.

Also notice the edit to my first post just a minute ago. I actually tagged a message and it disappeared before my eyes! This akonadi setup should be a default setup. The only thing I had retained from the old database was the akonadiserverrc.

Last edited by alvanx on Mon Feb 06, 2012 2:25 pm, edited 1 time in total.
User avatar einar
Administrator
Posts
3402
Karma
7
OS
That's a weird bug. Is the message lost or just not visible in KMail?


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
alvanx
Registered Member
Posts
136
Karma
1
OS
How can I find out? Is there some way to check this? The only way I can think of, a strigi search of my mail directory, won't work until it has been Indexed, and the indexer is still not finished creating the database.

However, I can tell you that the amount of files in the subfolder of my mail directory equals the number of emails that are in this folder in Kmail.

EDIT: I have tried to reproduce the disappearing of emails by tagging them. I was not able to. I am also able to restore the lost messages from webmail. I might just file a bug report about this at some point and be done with it.
alvanx
Registered Member
Posts
136
Karma
1
OS
And I had the problem again. After successfully tagging several (5 or so) messages, I had another one that I tried to tag and it got deleted. There was also a notification that said (paraphrase from German): "Local Folders: Changing the tag of the email has failed."

This is a bad bug.

Searching .xsession-errors for something meaningful. I haven't found anything so far. I just don't know what to look for.

EDIT: I see there's already a bug report for it. Good!
User avatar multimedia
Registered Member
Posts
38
Karma
0
OS
There is another bugreport with a clear instruction how to reproduce this error.

Bug 291899 - Kmail deletes mail marked as ham after new start

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Evil-Roach, Google [Bot], kde-deshmukh, Sogou [Bot], YaCy [Bot]