Reply to topic

in 4.14 - external keyboard / numlock turns on laptop too.

User avatar tyreed
Registered Member
Posts
40
Karma
0
OS
Hello,
in KDE, from suse 9 KDE 3 to openSuse12.3 / KDE 4.11.x, when I connected an external (PS2 or USB) keyboard to my laptop, I could turn on (activate) the number pad (numlock) on the full size external keyboard WithOut affecting my Laptop keyboard. (who wants numlocks on, on their laptop... Yuck).
So, Why is this happening in opensuse 13.2 / KDE 4.14.3, x86_64 and how do I stop it?
shorter version: I want to be able to turn on numerpad, on my external keyboard without it affecting the numlock on my Laptop too.

Thank you in advance,
Reed.
User avatar tyreed
Registered Member
Posts
40
Karma
0
OS
what i found, messing around is only a work around, but as the phrase indicates, it works.
In System Settings > Input Devices > Keyboard Settings > Advanced (tab) > [check: 'configure keyboard options'] > 'Miscellaneous compatibility options' > 'Numeric keypad keys always enter digits (as in Mac OS).
This, I assume because of the keycodes are Far from the Laptop key layout, without numlock on, is very different... letters not arrows.
Anyways, it works as a 'work around'..

Reed.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], danro, Google [Bot], leolist, Sogou [Bot], Sylvanticus