Reply to topic

how do I use the plasma on screen keyboard widget?

mrpraline
Registered Member
Posts
4
Karma
0
Hi,

I've recently started using a Wacom cintiq tablet and I want to use the plasma on screen keyboard widget to enter some command text using the pen. The tablet is working fine otherwise, I have no problems using the pen and screen in any way.

However when it comes to the virtual keyboard, I'm confused, it does not seem to do what I expect. I can bring up the widget on the desktop, but I cannot get it show on top of an application nor can I enter any text. For example: I open firefox (or any other application) and now I want to enter some text in the search bar so I click in the search bar of firefox and then want to start clicking on keys to enter text.

First problem: How do I get the widget visual on top of Firefox? I tried to attach a keyboard shortcut ( Ctrl+K) to the widget, but that doesn't seem to do anything. So next i try shrinking firefox so that the on screen keyboard is at least visible. But then:

Second problem: How do I make it to enter text? Clicking on keys in the widget merely seems to change focus to the widget, no text seems to be entered anywhere.

My system is linux mint 17.1 running KDE 4.14.2
wolfi323
Registered Member
Posts
1121
Karma
11
OS
Add it to the panel and use it from there.

Or install kvkbd and use that.
mrpraline
Registered Member
Posts
4
Karma
0
wolfi323 wrote:Add it to the panel and use it from there.

Adding to the panel technically works, but I get a really distorted keyboard widget. The panel is about 15% of the screen width and stretched out over the complete height of the screen. Any idea how to fix that?

wolfi323 wrote:Or install kvkbd and use that.

Actually this was my first plan but unfortunately that is not packaged in mint (ubuntu) anymore.
see https://bugs.launchpad.net/ubuntu/+source/kvkbd/+bug/1276140
wolfi323
Registered Member
Posts
1121
Karma
11
OS
mrpraline wrote:
wolfi323 wrote:Add it to the panel and use it from there.

Adding to the panel technically works, but I get a really distorted keyboard widget. The panel is about 15% of the screen width and stretched out over the complete height of the screen. Any idea how to fix that?

Yes, I noticed that too.

You should be able to resize it like any other plasmoid: Open it by clicking on it with the mouse, then move the mouse to a corner (the mouse pointer should change its shape) and click-drag it to the preferred size.
mrpraline
Registered Member
Posts
4
Karma
0
Thanks Wolfi!

That did the trick. Not the most obvious or user friendly solution, but at least it works.
Now I need to find a way to make it pop up by pressing one of the cintiq´s function buttons...
wolfi323
Registered Member
Posts
1121
Karma
11
OS
mrpraline wrote:That did the trick. Not the most obvious or user friendly solution, but at least it works.

Yes, the applet should have a sane default size. I would actually call that a bug... ;)

Now I need to find a way to make it pop up by pressing one of the cintiq´s function buttons...

Well, if those "function buttons" create standard keypresses, you should be able to set it as shortcut for the applet by right-clicking on it and choosing "Keyboard Settings"->"Keyboard Shortcut" (or similar).
Sanette
Registered Member
Posts
32
Karma
0
OS
just in case someone is still interested in this topic
in my experience, onboard is much better than the kde plasma widget.

even though it's made for gnome, it integrates well with KDE. And it's in the Mint repositories
(tested with Mint KDE 4.13.3)

The only thing that doesn't work, unfortunately, is automatic popup of the keyboard when a text widget appears,
and integration with the session login (so that you can enter your login/password)

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], bobbywibowo, Google [Bot], Majestic-12 [Bot], ramskulls, vinnywright