Reply to topic

Cannot set a compose key

tk
Registered Member
Posts
7
Karma
0

Cannot set a compose key

Thu Jul 20, 2017 12:00 pm
I'm using KDE Frameworks 5.36 and Plasma 5.8.7 on Kubuntu 16.04. I can't get compose keys to work with a US English keyboard.

I've tried lots of different compose key settings System Settings->Input Devices->Keyboard->Advanced->Position of Compose key. But no matter what I pick (caps lock, right win, left win, right alt or whatever) it simply doesn't work. Typing the compose key then e= for the Euro sign for example just types out 'e='.

Does anyone know what I have to do to actually enable compose keys in KDE?
tk
Registered Member
Posts
7
Karma
0

Re: Cannot set a compose key  Topic is solved

Tue Jul 25, 2017 11:55 am
Well the problem was fixed when I removed these 4 files from ~/.kde/share/config/ :
kcminputrc kglobalshortcutsrc khotkeysrc kinputrc

The current version of KDE puts these files under ~/.config. It's a bit irritating though that having the old, unused files there (which will always be the case if you don't manually clear out your ~/.kde/share/config/ when you upgrade from a previous version) causes bugs like this.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], benjaminl, Bing [Bot], cylverbak, Google [Bot], gui-m, ipwizard, kakosf, kde-jriddell, klorax, Mamarok, P3lor, peje, Raptor 2101, skylerjett, Snudl, zwankfr