Reply to topic

Need help building KDevelop for debugging (Please)

stewartj
Registered Member
Posts
6
Karma
0
Hello
I'm trying to build KDevelop for debugging and I'm following the build instructions on page:
http://kfunk.org/2016/02/16/building-kd ... ntu-15-10/
and
https://community.kde.org/KDevelop/HowToCompile_v5

I have a "16.04.1-Ubuntu" installed.

When I attempt to build KDevelop (for debugging) I get the following errors: (see below).
It seems to be complaining about "compatible versions" and I can't find any instructions on the internet to help resolve this issue.

Any help would be greatly appreciated, thank you!

Build command:
kdesrc-build --debug libkomparediff2 kdevelop-pg-qt kdevelop

And some error output:


CMake Warning at /home/stewart/kde/usr/share/ECM/find-modules/FindKF5.cmake:74 (find_package):
Could not find a configuration file for package "KF5CoreAddons" that is
compatible with requested version "5.28.0".

The following configuration files were considered but not accepted:

/usr/lib/x86_64-linux-gnu/cmake/KF5CoreAddons/KF5CoreAddonsConfig.cmake, version: 5.18.0

Call Stack (most recent call first):
CMakeLists.txt:28 (find_package)


-- Could NOT find KF5CoreAddons , checked the following files:
/usr/lib/x86_64-linux-gnu/cmake/KF5CoreAddons/KF5CoreAddonsConfig.cmake (version 5.18.0)

CMake Warning at /home/stewart/kde/usr/share/ECM/find-modules/FindKF5.cmake:74 (find_package):
Could not find a configuration file for package "KF5Codecs" that is
compatible with requested version "5.28.0".

The following configuration files were considered but not accepted:

/usr/lib/x86_64-linux-gnu/cmake/KF5Codecs/KF5CodecsConfig.cmake, version: 5.18.0

Call Stack (most recent call first):
CMakeLists.txt:28 (find_package)


-- Could NOT find KF5Codecs , checked the following files:
/usr/lib/x86_64-linux-gnu/cmake/KF5Codecs/KF5CodecsConfig.cmake (version 5.18.0)

CMake Warning at /home/stewart/kde/usr/share/ECM/find-modules/FindKF5.cmake:74 (find_package):
Could not find a configuration file for package "KF5Config" that is
compatible with requested version "5.28.0".

The following configuration files were considered but not accepted:

/usr/lib/x86_64-linux-gnu/cmake/KF5Config/KF5ConfigConfig.cmake, version: 5.18.0

Call Stack (most recent call first):
CMakeLists.txt:28 (find_package)


-- Could NOT find KF5Config , checked the following files:
/usr/lib/x86_64-linux-gnu/cmake/KF5Config/KF5ConfigConfig.cmake (version 5.18.0)

CMake Warning at /home/stewart/kde/usr/share/ECM/find-modules/FindKF5.cmake:74 (find_package):
Could not find a configuration file for package "KF5XmlGui" that is
compatible with requested version "5.28.0".

The following configuration files were considered but not accepted:

/usr/lib/x86_64-linux-gnu/cmake/KF5XmlGui/KF5XmlGuiConfig.cmake, version: 5.18.0
User avatar scummos
Global Moderator
Posts
1132
Karma
7
OS
Try also building KCoreAddons. The version from your system is too old.

At this point, you probably need to build most things by yourself.


I'm working on the KDevelop IDE.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bigboss97, Bing [Bot], drookie, Exabot [Bot], Google [Bot], keyths