Reply to topic

Can't add Konsole to ToolView as button unchecks itself

arsenii
Registered Member
Posts
2
Karma
0
Hello people,

I have used an AppImage of KDevelop for a while and loved it partially because of the Konsole as it made developing/running C-programs easy. Today I downloaded the 5.5.0 version through apt on Ubuntu 20.04, and I cannot access or add the Konsole to the Toolview. When i go to Settings > Configure KDevelop > Plugins > Select Konsole Integration and finally press apply after checking the box, the box unchecks itself and I cannot add Konsole to the ToolView. Has anyone else encountered this issue and know how to solve this? Doing the same procedure on the AppImage lets me add Konsole to the ToolView.
User avatar scummos
Global Moderator
Posts
1168
Karma
7
OS
Hi,

this behaviour usually means that the plugin fails to load. You can look at KDevelop's terminal output, maybe it gives a clue. The most likely reason is though that you need to have konsole installed from your package manager.

Greetings!


I'm working on the KDevelop IDE.
arsenii
Registered Member
Posts
2
Karma
0
Thank you scummos for the answer and the issue is solved. It was the case that the Konsole Integration plugin was not loading, as going to Help > Loaded Plugins revealed. For anyone else stumbling upon this issue on Ubuntu, I managed to fix it by going to Ubuntu Software and finding Konsole there and downloading it. After restarting KDevelop, I was able to follow the previous steps without the button unchecking itself and all functionality is working. I assume the steps are similar depending on your Linux distribution and that it stems form that APT does not install all plugins.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], benderclark, Bing [Bot], dbergstein, Google [Bot]