Reply to topic

KDevelop PPA or Build Instructions?

User avatar MadMartian
Registered Member
Posts
13
Karma
0

KDevelop PPA or Build Instructions?

Tue Feb 23, 2021 5:02 pm
Is there a PPA for the latest KDevelop builds? Ubuntu's repo only has a very old version of KDevelop available, and I prefer to avoid using AppImages if I don't have to. If there is no PPA is it straightforward to build KDevelop from source?

Best regards
LptpraNiLlfp
Registered Member
Posts
4
Karma
0
OS
PPA:
https://launchpad.net/~kdenlive/+archiv ... ive-stable
idk if this works
As for build instruction
Code: Select all
git clone https://invent.kde.org/multimedia/kdenlive
cd kdenlive/
git checkout v20.12.2 # or any other version you prefer, default branch should probably  be nightly i guess

mkdir build
cd build/
cmake-gui -S .. -B . #native compiler, configure and generate
make -j5 #or cores + 1 or any number

./bin/kdenlive

sudo make install #optional if you want to install it



I did built this on my Gentoo install successfully without any problem (probably because of I had dependencies installed already).
Idk if this can help but here is a dependency graph of kdenlive v20.12.2 on Gentoo (Many of the packages could be xxxx-dev on ubuntu)
Code: Select all
 * dependency graph for kde-apps/kdenlive-20.12.2
 `--  kde-apps/kdenlive-20.12.2  [~amd64 keyword]
   `--  dev-cpp/rttr-0.9.6  (dev-cpp/rttr) amd64
   `--  dev-qt/qtconcurrent-5.15.2  (>=dev-qt/qtconcurrent-5.15.2) amd64
   `--  dev-qt/qtdbus-5.15.2  (>=dev-qt/qtdbus-5.15.2) amd64
   `--  dev-qt/qtdeclarative-5.15.2  (>=dev-qt/qtdeclarative-5.15.2) amd64
   `--  dev-qt/qtgui-5.15.2-r1  (>=dev-qt/qtgui-5.15.2) amd64  [gles2-only=]
   `--  dev-qt/qtmultimedia-5.15.2  (>=dev-qt/qtmultimedia-5.15.2) amd64
   `--  dev-qt/qtnetwork-5.15.2-r1  (>=dev-qt/qtnetwork-5.15.2) amd64
   `--  dev-qt/qtquickcontrols2-5.15.2  (>=dev-qt/qtquickcontrols2-5.15.2) amd64
   `--  dev-qt/qtsvg-5.15.2  (>=dev-qt/qtsvg-5.15.2) amd64
   `--  dev-qt/qtwidgets-5.15.2  (>=dev-qt/qtwidgets-5.15.2) amd64
   `--  dev-qt/qtxml-5.15.2  (>=dev-qt/qtxml-5.15.2) amd64
   `--  kde-frameworks/karchive-5.77.0  (>=kde-frameworks/karchive-5.75.0) amd64
   `--  kde-frameworks/kbookmarks-5.77.0  (>=kde-frameworks/kbookmarks-5.75.0) amd64
   `--  kde-frameworks/kcompletion-5.77.0  (>=kde-frameworks/kcompletion-5.75.0) amd64
   `--  kde-frameworks/kconfig-5.77.0  (>=kde-frameworks/kconfig-5.75.0) amd64
   `--  kde-frameworks/kconfigwidgets-5.77.0  (>=kde-frameworks/kconfigwidgets-5.75.0) amd64
   `--  kde-frameworks/kcoreaddons-5.77.0  (>=kde-frameworks/kcoreaddons-5.75.0) amd64
   `--  kde-frameworks/kcrash-5.77.0  (>=kde-frameworks/kcrash-5.75.0) amd64
   `--  kde-frameworks/kdbusaddons-5.77.0  (>=kde-frameworks/kdbusaddons-5.75.0) amd64
   `--  kde-frameworks/kdeclarative-5.77.0  (>=kde-frameworks/kdeclarative-5.75.0) amd64
   `--  kde-frameworks/kguiaddons-5.77.0  (>=kde-frameworks/kguiaddons-5.75.0) amd64
   `--  kde-frameworks/ki18n-5.77.0  (>=kde-frameworks/ki18n-5.75.0) amd64
   `--  kde-frameworks/kiconthemes-5.77.0  (>=kde-frameworks/kiconthemes-5.75.0) amd64
   `--  kde-frameworks/kio-5.77.0-r2  (>=kde-frameworks/kio-5.75.0) amd64
   `--  kde-frameworks/kitemviews-5.77.0  (>=kde-frameworks/kitemviews-5.75.0) amd64
   `--  kde-frameworks/kjobwidgets-5.77.0  (>=kde-frameworks/kjobwidgets-5.75.0) amd64
   `--  kde-frameworks/knewstuff-5.77.0-r1  (>=kde-frameworks/knewstuff-5.75.0) amd64
   `--  kde-frameworks/knotifications-5.77.0  (>=kde-frameworks/knotifications-5.75.0) amd64
   `--  kde-frameworks/knotifyconfig-5.77.0  (>=kde-frameworks/knotifyconfig-5.75.0) amd64
   `--  kde-frameworks/kservice-5.77.0  (>=kde-frameworks/kservice-5.75.0) amd64
   `--  kde-frameworks/ktextwidgets-5.77.0  (>=kde-frameworks/ktextwidgets-5.75.0) amd64
   `--  kde-frameworks/kwidgetsaddons-5.77.0  (>=kde-frameworks/kwidgetsaddons-5.75.0) amd64
   `--  kde-frameworks/kxmlgui-5.77.0-r1  (>=kde-frameworks/kxmlgui-5.75.0) amd64
   `--  kde-frameworks/solid-5.77.0  (>=kde-frameworks/solid-5.75.0) amd64
   `--  media-libs/mlt-6.24.0-r1  (>=media-libs/mlt-6.20.0) amd64  [ffmpeg frei0r kdenlive(+) melt(+) qt5 sdl xml]
   `--  kde-frameworks/kfilemetadata-5.77.0  (>=kde-frameworks/kfilemetadata-5.75.0) amd64
   `--  kde-frameworks/purpose-5.77.0-r1  (>=kde-frameworks/purpose-5.75.0) amd64
   `--  media-libs/libv4l-1.20.0  (media-libs/libv4l) amd64
   `--  dev-qt/qtwebengine-5.15.2  (>=dev-qt/qtwebengine-5.15.2) amd64
   `--  dev-util/desktop-file-utils-0.26-r1  (dev-util/desktop-file-utils) amd64
   `--  x11-misc/shared-mime-info-2.0-r2  (x11-misc/shared-mime-info) amd64
   `--  dev-qt/qttest-5.15.2  (dev-qt/qttest) amd64
   `--  dev-qt/qtcore-5.15.2-r2  (dev-qt/qtcore) amd64
   `--  dev-qt/qtquickcontrols-5.15.2  (>=dev-qt/qtquickcontrols-5.15.2) amd64
   `--  media-video/ffmpeg-4.3.1  (media-video/ffmpeg) amd64  [encode sdl X]
   `--  kde-frameworks/breeze-icons-5.77.0-r1  (kde-frameworks/breeze-icons) amd64
   `--  kde-frameworks/oxygen-icons-5.77.0  (kde-frameworks/oxygen-icons) amd64
   `--  kde-frameworks/kf-env-5  (>=kde-frameworks/kf-env-4) amd64
   `--  sys-devel/gettext-0.21  (sys-devel/gettext) amd64
   `--  dev-util/ninja-1.10.1  (dev-util/ninja) amd64
   `--  dev-util/cmake-3.18.5  (dev-util/cmake) amd64
   `--  x11-base/xorg-server-1.20.10-r3  (x11-base/xorg-server) ~amd64  [xvfb]
   `--  x11-apps/xhost-1.0.8  (x11-apps/xhost) amd64
   `--  kde-frameworks/kdoctools-5.77.0  (>=kde-frameworks/kdoctools-5.75.0) amd64
   `--  kde-frameworks/extra-cmake-modules-5.77.0  (>=kde-frameworks/extra-cmake-modules-5.75.0) amd64

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], kkmks, Majestic-12 [Bot], Sogou [Bot], suchiss, YaCy [Bot], Yahoo [Bot]