Reply to topic

cmake does not find optional postgres packages as installed

User avatar inksi
Registered Member
Posts
71
Karma
0
OS
Building Kexi 2.9.1 on Mint 17.1 on new machine.

Running cmake I get the message:
Code: Select all
"The following optional packages could not be located on your system. libpq ... "

see line 288 & following in cmake.log
libpq-dev & libpq5 are installed along with libpqxx3-dev & libpqxx-3.1 . All uptodate.

The result is that although Kexi is built and runs, creating access to a database on a remote server offers only MySQL and Sybase options.

see http://goo.gl/g6vthX for CMakeCache.txt
see http://goo.gl/miQWcN for cmake.log

Please advise.
Ian

Last edited by inksi on Sat Mar 14, 2015 3:57 pm, edited 1 time in total.
piggz
Moderator
Posts
13
Karma
0
OS
According to the log, libpq was not found....

What distro/version are you running?

inksi wrote:Building Kexi 2.9.1 on Mint 17.1 on new machine.

Running cmake I get the message:
Code: Select all
"The following optional packages could not be located on your system. libpq ... "

see line 288 & following in cmake.log
libpq-dev & libpq5 are installed along with libpqxx3-dev & libpqxx-3.1 . All uptodate.

The result is that although Kexi is built and runs, creating access to a database on a remote server offers only MySQL and Sybase options.

see http://goo.gl/g6vthX for CMakeCache.txt
see http://goo.gl/miQWcN for cmake.log

The result is that although Kexi is built and runs, creating access to a database on a remote server offers only MySQL and Sybase options.

Please advise.
Ian
User avatar inksi
Registered Member
Posts
71
Karma
0
OS
Hi. Piggz

As noted, running Mint Linux 17.1 (Rebecca). We do have libpq installed along with other necessary postgresql bits as far as I can see.

Running apt-get says uptodate and latest version installed for all four libraries mentioned. Is there some other option to verify this directly?

Ian
User avatar inksi
Registered Member
Posts
71
Karma
0
OS
The answer and solution was that there was a missing dependancy. Thank you for sleuthing this out, pigzz.

Needed was postgresql-server-dev-9.3

Once installed the build went ahead with no issues.

I will take action to get this inserted into the Calligra/Building document as a matter of urgency.

Ian

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, cmb, cylverbak, Google [Bot], JesusM, kevjon, scummos, smankowski, Sogou [Bot], YaCy [Bot]