Reply to topic

unable to compile Calligra

leleu
Registered Member
Posts
20
Karma
0

unable to compile Calligra

Sat Jun 13, 2015 2:13 pm
Hi,

downloaded calligra-latest.tar.gz of 7/6 and using directory structure as per https://community.kde.org/Calligra/Buil ... nded_setup I receive however
Code: Select all
-- Found Qt-Version 4.8.6 (using /usr/bin/qmake-qt4)
-- Found Qt-Version 4.8.6 (using /usr/bin/qmake-qt4)
CMake Error at /usr/share/kde4/apps/cmake/modules/MacroEnsureOutOfSourceBuild.cmake:17 (MESSAGE):
  Compiling Calligra inside the source directory is not possible.  Please
  refer to the build instruction
  http://community.kde.org/Calligra/Building/Building_Calligra
Call Stack (most recent call first):
  CMakeLists.txt:189 (macro_ensure_out_of_source_build)

found some googles, but did not seem relevant ones.

What else should I test ?

thanks
User avatar jstaniek
Moderator
Posts
928
Karma
2
OS

Re: unable to compile Calligra

Sat Jun 13, 2015 9:39 pm
Hi Robert,
Short answer: please build in a so called build dir, not in the source dir.

Long answer: Building any software inside of the source dir is not a good practice (unless you're very well paid to do so... people are paid to do many strange things :) ).
So we've added a special check. Please make sure you're in the build dir; from https://community.kde.org/Calligra/Buil ... d_Calligra there are:
Code: Select all
cd $HOME/kde4/build/calligra
[...]
cmake ...
[...]
make install


Best regards,
Jarosław Staniek
Image

KEXI - Open Source Visual DB Apps Builder
• Request feature or fix for KEXI here
May I help you? Please mention your app's version and OS when asking for help
leleu
Registered Member
Posts
20
Karma
0

Re: unable to compile Calligra

Sun Jun 14, 2015 8:55 am
Thanks


I just followed «Option 2: download a repository tarball» which landed in my home, and unpacked same place as ~/calligra

now I've added the required kde4 arborescence

I guess I should put something in /home/leleu/kde4/src/ but what exactjy ? the whole unpacked calligra directory, or its content ?

and then shall indeed be in a terminal of the empty HOME/kde4/build/calligra to run cmake.... ?
leleu
Registered Member
Posts
20
Karma
0

Re: unable to compile Calligra

Wed Jun 17, 2015 11:00 am
So I have unpacked as /home/leleu/kde4/src/calligra/ and tried to compile....and cmake doesn't find Qt4 which I just reintalled (4.8.6) to be sure

Code: Select all
[email protected]:~/kde4/build/calligra > cmake -DCMAKE_INSTALL_PREFIX=$HOME/kde4/inst $HOME/kde4/src/calligra       -DCMAKE_BUILD_TYPE=RelWithDebInfo
-- Release build: TRUE
-- --------------------------------------------------------------------------
-- Configured with product set "ALL"
-- --------------------------------------------------------------------------
CMake Error at /usr/share/kde4/apps/cmake/modules/FindQt4.cmake:886 (MESSAGE):
  Could NOT find QtCore.  Check
  /home/leleu/kde4/build/calligra/CMakeFiles/CMakeError.log for more details.
Call Stack (most recent call first):
  /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:425 (find_package)
  /usr/share/cmake-2.8/Modules/FindKDE4.cmake:95 (find_package)
  CMakeLists.txt:259 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/leleu/kde4/build/calligra/CMakeFiles/CMakeOutput.log".
See also "/home/leleu/kde4/build/calligra/CMakeFiles/CMakeError.log".
User avatar jstaniek
Moderator
Posts
928
Karma
2
OS

Re: unable to compile Calligra

Wed Jun 17, 2015 10:40 pm
@Robert please install as noted:
https://community.kde.org/Calligra/Buil ... pendencies

Qt 4.7.0 or newer (recommended) with development files (headers, etc.)


Best regards,
Jarosław Staniek
Image

KEXI - Open Source Visual DB Apps Builder
• Request feature or fix for KEXI here
May I help you? Please mention your app's version and OS when asking for help
leleu
Registered Member
Posts
20
Karma
0

Re: unable to compile Calligra  Topic is solved

Tue Jun 30, 2015 9:04 pm
To get rid from all the files in my old Mint17, I now try with a new Mint17 Rebecca.
I noticed that
«On opensuse the development package is called libkde4-devel; on Ubuntu and Debian it is called kdelibs5-dev.»
However when I tried to install this kdelibs5-dev the relevant internet address (91.189.91.15 80) is 404.....

after googling I eventually found that the culprit is linux-libc-dev_3.13.0-54.91

I succeeded to install this lib (upgrading the package list).

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], garyf, Google [Bot], hbalk, rwayland, Samiur, sarar, Sogou [Bot]