Reply to topic

undefined data in reports

tmae
Registered Member
Posts
8
Karma
0

undefined data in reports

Fri May 17, 2019 6:12 pm
Whenever I delete data from a field in a record on my form, it appears on my corresponding report not as a blank cell but as "undefined." I then have to open the master table, search for the spot where that piece of data used to be, select the blank cell, then manually "delete" it using the context menu. Then if I go back to the report, "undefined" is no longer there. I have to do this every time I make deletions on an existing record. If I make 10 deletions on a record, I then have to find those 10 items in the corresponding table to make the deletions stick. I've tried deleting, cutting, and "clearing" the form data without success. This problem only appears on a report when entered from a form, not from a table.
This is a real waste of time. Am I missing something? Is there a workaround?

Thanks,
tmae
kexi 3.1
User avatar jstaniek
Moderator
Posts
922
Karma
2
OS

Re: undefined data in reports

Fri May 17, 2019 9:01 pm
Hi Tmae,
"undefined" looks like a result of evaluating of a program in the Javascript language so it might be possible that the field in question is consisted of such expression. To get it resolved faster there's one way, send a sample database with similar report having this behavior - to bugs.kde.org or if it's more confidential, to me.


Best regards,
Jarosław Staniek
Image

KEXI - Open Source Visual DB Apps Builder
• Request feature or fix for KEXI here
May I help you? Please mention your app's version and OS when asking for help

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], boudewijn, ChameleonScales, danasenhansen, duns, Exabot [Bot], Google [Bot], jackjo, Kawaii Specter, keyths, niccolove, peje, Petra-Kathi, polsson, stanleyf, surt, tymond