Reply to topic

Double-click to open folders in Dolphin

User avatar elav
Registered Member
Posts
53
Karma
0
OS
Making the transition to Plasma5 has been chaos. First, they take away things KDE4 to give support only Plasma5 only, and now, in the process, they are also removing things Dolphin. Using Plasma 5.4 in Manjaro, and I find the option to open files and folders with two clicks in Dolphin.

Is that option was removed? >:(
User avatar google01103
Manager
Posts
6668
Karma
25


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar elav
Registered Member
Posts
53
Karma
0
OS
google01103 wrote:


:o Why he was taken from Dolphin? Now it is not intuitive. Thank you anyway..
User avatar google01103
Manager
Posts
6668
Karma
25
it was not in Dolphin settings in KDE 4



OpenSuse Leap 42.1 x64, Plasma 5.x

metzman
Registered Member
Posts
171
Karma
3
OS
google01103 wrote:it was not in Dolphin settings in KDE 4

Actually it was, and still is, using Dolphin Version 15.04.0 / KDE Development Platform 4.14.10
Settings -> Configure Dolphin -> Navigation - Mouse
User avatar elav
Registered Member
Posts
53
Karma
0
OS
metzman wrote:
google01103 wrote:it was not in Dolphin settings in KDE 4

Actually it was, and still is, using Dolphin Version 15.04.0 / KDE Development Platform 4.14.10
Settings -> Configure Dolphin -> Navigation - Mouse


Nop..

Image
luebking
Karma
0
What do you mean by "intuitive" - that's a global setting. Doesn't seem intuitive to "changed something in dolphin and now my system behaves weirdly"

Afaics it was removed here (after having dolphin writing *into* the global settings):
https://bugs.kde.org/show_bug.cgi?id=343418
metzman
Registered Member
Posts
171
Karma
3
OS
elav wrote:
metzman wrote:
google01103 wrote:it was not in Dolphin settings in KDE 4

Actually it was, and still is, using Dolphin Version 15.04.0 / KDE Development Platform 4.14.10
Settings -> Configure Dolphin -> Navigation - Mouse


Nop..


Odd... I still have it under the settings indicated.

Image
User avatar google01103
Manager
Posts
6668
Karma
25
I don't have it in Dolphin 15.08.1 - so maybe it is dependent on the version

question is was the removal deliberate or a bug

I posted a bug https://bugs.kde.org/show_bug.cgi?id=353645


OpenSuse Leap 42.1 x64, Plasma 5.x

metzman
Registered Member
Posts
171
Karma
3
OS
google01103 wrote: ... question is was the removal deliberate or a bug ...

I think we both missed luebking's comment ;)
luebking wrote:Afaics it was removed here (after having dolphin writing *into* the global settings):
https://bugs.kde.org/show_bug.cgi?id=343418
User avatar elav
Registered Member
Posts
53
Karma
0
OS
luebking wrote:What do you mean by "intuitive" - that's a global setting. Doesn't seem intuitive to "changed something in dolphin and now my system behaves weirdly"

Afaics it was removed here (after having dolphin writing *into* the global settings):
https://bugs.kde.org/show_bug.cgi?id=343418


Simple. It is assumed that if the open files and folders by double-clicking is an action that affects mainly Dolphin, should be the option in Dolphin. But it may be a bug, what I'm reading in the comments below.
benmitnick
Registered Member
Posts
1
Karma
0
no it's not a bug just option moved in

Code: Select all
System Settings => Input Devices => Mouse :)
giampaolo44
Registered Member
Posts
1
Karma
0
A bit late to the party, yet it is still somehow relevant.

I am sure it made sense moving it, since having dolphin that writes over system settings was not particularly sensible.

But I would raise two questions:
a) wasn't/wouldn't it be possible to place a link to the appropriate tab of the System, in Dolphin's behavior tab?
b) in case a) wasn't feasible, at least a mention of where the setting can be changed would probably be a nice feature.

By the way, for those who ended up using Gnome but are still fond of Dolphin: the setting can be changed by using Kde's System settings. In my setup it still shows up by searching Kde.

Cheers
vanderzwan
Registered Member
Posts
1
Karma
0
EDIT: Fixed it (for me at least). First, open ~/.config/kdeglobals in your favourite text editor, for example:
Code: Select all
kate ~/.config/kdeglobals &

(this may be a different location on your machine, but this was where I found it in KDE Neon in June 2018). Then scroll down to [KDE] and add the following line:
Code: Select all
SingleClick=false


Settings didn't take hold until a reboot - perhaps logging out/in is enough though.
-----

Hello. Sorry to dredge up this topic again. I'm running KDE Neon. Every solution on the internet that I can find tells me to look under the Mouse settings in system settings

The problem is, said icons submenu is not showing up:
Image

(ironically, if I search for it in the start menu, the mouse settings page does show up)

Image

I'm going to assume this is a bug, but until that is fixed: is there a way to manually change this in some text config file?
User avatar Rog131
Registered Member
Posts
828
Karma
10
Click Behavior

Bug 377310 - Single/double click option is inappropriately located in the mouse settings : https://bugs.kde.org/show_bug.cgi?id=377310
--> Single/Double Click Option at Workspace KCM: https://phabricator.kde.org/D12946
This patch adds the single/double click option to
the Workspace KCM.


With the Plasma 5.13 or later:
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], BobF, Google [Bot], MSN [Bot], Sogou [Bot], Zeikcied