Reply to topic

No icons at all

Horus
Registered Member
Posts
286
Karma
0
OS

Re: No icons at all

Thu Oct 15, 2015 7:30 am
Code: Select all
% echo $DBUS_SESSION_BUS_ADDRESS
unix:path=/run/user/1000/bus

with or without export QT_QPA_PLATFORMTHEME="kde" in .zshenv. If that line put in .xinitrc it has no effect. The variable is not set, okular works, dolphin has no icons.

but only with:

Code: Select all
[email protected] ~ % dolphin
"Session bus not found\nTo circumvent this problem try the following command (with Linux and bash)\nexport $(dbus-launch)"

[email protected] ~ % okular
okular(1437)/kdeui (kdelibs): Session bus not found
To circumvent this problem try the following command (with Linux and bash)
export $(dbus-launch)
KCrash: Application 'okular' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
KCrash: Connect sock_file=/home/florian/.kde4/socket-asaru/kdeinit4__0


nm-applet or the dunst notification server are all working, since they are using d-bus.

After some time after boot (like 5 minutes) the KDE apps seem to start whatever was missing and it works (okular starts, dolphin has icons).

I had a .zshenv with some content before, if that's what you mean.

I assume that Qt supports that way of starting d-bus, KDE Plasma 4 works on that machine in another x-session.

Sorry, I'm really puzzled...

Thanks!
luebking
Karma
0

Re: No icons at all

Thu Oct 15, 2015 2:42 pm
I assume you'll start "something™" Qt5 related with the session login and that "something™" now loads the KDE QPA - and that "somehow™" screws the dbus connection for everything else.

Since you seem to use a customized session, you'll have to check yourself, I suggest to
Code: Select all
sudo lsof | grep KDEPlatformTheme.so


right after login (from an xterm, not konsole ;-)
Horus
Registered Member
Posts
286
Karma
0
OS

Re: No icons at all

Wed Oct 21, 2015 8:40 am
luebking wrote:I assume you'll start "something™" Qt5 related with the session login and that "something™" now loads the KDE QPA - and that "somehow™" screws the dbus connection for everything else.

Since you seem to use a customized session, you'll have to check yourself, I suggest to

Not really a customized session, I just used the session entry that came with i3:

Code: Select all
[email protected] ~ % cat /usr/share/xsessions/i3.desktop
[Desktop Entry]
Name=i3
Comment=improved dynamic tiling window manager
Exec=i3
TryExec=i3
Type=Application
X-LightDM-DesktopName=i3
DesktopNames=i3


Code: Select all
sudo lsof | grep KDEPlatformTheme.so


right after login (from an xterm, not konsole ;-)


That returns no open file, directly after reboot in an xterm, as well as with kmail, dolphin and konsole loaded.
Horus
Registered Member
Posts
286
Karma
0
OS

Re: No icons at all

Sun Dec 20, 2015 7:36 pm
Ok, I bring up that issue again, because after the recent upgrade of KMail to KF5 this problem strikes me much more harder, KMail too has lost all of it's icons.

Is there any help besides abolishing every KDE application as soon as it's ported to KF5? :-(

EDIT: Ok, while the QT_QPA_PLATFORMTHEME=kde thing somehow works for dolphin (after dbus was started manually (for KDE, notification and networkmanager were dbus fine before) it makes KMail not even start up but end up in a infinite loop

Code: Select all
QSystemTrayIcon::setVisible: No Icon set

https://bugs.kde.org/show_bug.cgi?id=355992
Horus
Registered Member
Posts
286
Karma
0
OS

Re: No icons at all

Sun Dec 20, 2015 8:18 pm
Ok, it seems I was able to solve it, using the information from viewtopic.php?f=224&t=128101#p346943

Set
Code: Select all
QT_QPA_PLATFORMTHEME=qt5ct
e.g. in your ~/.pam_environment, install qt5ct and use that to configure icons etc.
yeupou
Registered Member
Posts
1
Karma
0

Re: No icons at all

Sun Jun 05, 2016 1:03 pm
qt5ct is not packaged for my system.

kmail stills works and dolphin was working until yesterday (system upgrade) with XDG_CURRENT_DESKTOP=kde dolphin

I'm using fluxbox. What should I be looking for? Seems very complicated these days to choose which component we want to use. It is not as if KDE/Plasma was #1 desktop on the planet but still it looks like KDE/whatevernewname can afford to loose users that arent satistified with it as a whole. :(

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], Kresimir, Majestic-12 [Bot]