Reply to topic

kdialog freezing

joebolin
Registered Member
Posts
2
Karma
0
OS

Re: kdialog freezing

Thu Feb 06, 2014 8:30 pm
This is because of Chrome's processes acting up. You will have extreme slowness when opening Dolphin file browser when this issue pops up. To get around it you must 1) close Chrome, and 2) issue the following command
Code: Select all
killall -9 /opt/google/chrome/chrome
. The issue will go away as soon as the offending processes have been killed.

It's a royal pain.
viovino
Registered Member
Posts
1
Karma
0

Re: kdialog freezing

Fri Mar 20, 2015 2:02 pm
It also happens to me.
Kdialog takes minutes in chrome and chromium but not for example in firefox (but I am not sure whether firefox uses kdialog(?)).
Any tip to get rid of the problem?
kaengo
Registered Member
Posts
3
Karma
0

Re: kdialog freezing

Tue Feb 27, 2018 10:47 pm
same is happening to me! (CentOS 7)

It occured, after I had tried to hide devices in ,Places' in the side bar of dolphin.
I have very much smb devices but all worked fine more than one year ...
(Yes, only, if the server was running, but that was no problem ...)

I tried to remove the ,dolphin' folder and the dolphinrc file,
but no success.

Now, dolphin is freezing for 5 min, when I start it,
and some 'file open' and 'file save as' dialogs ale also freezing
(in chrome for example and in veracrypt, not in firefox..)

With this problem I can't use my system with benefit...

Is there a possibility to reset the settings of these dialogs?

Greetings,
Holger
kaengo
Registered Member
Posts
3
Karma
0

Re: kdialog freezing

Wed Feb 28, 2018 1:52 pm
OK,
I got it for me
I deleted (renamed) the folders kfile and kfileplaces in ~/.kde/share/apps
Now, all is working again.
I won't try again to modify the device list .....


Greetings
Kängo
ccellist
Registered Member
Posts
1
Karma
0

Re: kdialog freezing

Thu Jan 10, 2019 2:56 pm
This is an old post, and I'm a nobody, but I thought I would provide my 2 cents.

The only workaround I've identified is to ensure you have no NFS mounts in /etc/fstab. This is particularly helpful if you have a laptop experiencing this issue. Mount your NFS mounts manually when you're part of the network that contains them otherwise you will find yourself in no end of trouble with NFS mounts, and not just with KDE.

As an aside, I totally get that this isn't a KDE problem and as I've mentioned, if you've got NFS mounts automatically set up in fstab on a mobile device then you're just asking for trouble. However, it is never acceptable for a program, especially one so tied into the client side of the OS to just hang when a mount isn't there. Is there no way to tell KDE to just time out and move on? I have zero knowledge of how KDE interacts with the kernel so this is a genuine question on my part.

Many thanks to the community for all the great work being put on this.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], bovender, claydoh, compatico, Exabot [Bot], Google [Bot], Sogou [Bot], szutmael, WCSN, Yahoo [Bot]