Reply to topic

Can't use typographic symbols

User avatar greatperson
Registered Member
Posts
75
Karma
0
OS

Can't use typographic symbols

Fri Jan 18, 2013 10:32 am
I'm using latest stable Kubuntu and KDE 4.9.5. Since a recent update (4.9.4 -> 4.9.5, I think) I noticed that I can't now use typographic symbols. They were configured to be typed when I press Right Alt. I haven't changed this configuration for a long time. fter the problem appeared, I tried to check and uncheck some checkboxes, so I'm not sure that now I have a correct configuration.

After a reboot, the feature started work again, and then stopped again.

These are checkboxes which are checked in System Settings -> Input Devices -> Keyboard -> Advanced:

- Key sequence to kill the X server
--- Control + Alt + Backspace
- Key to choose 3rd level
--- Right Alt
- Key(s) to change layout
--- Alt+Shift
- Miscellaneous compatibility options
--- Enable extra typography characters

All other checkboxes are unchecked.
User avatar greatperson
Registered Member
Posts
75
Karma
0
OS

Re: Can't use typographic symbols

Fri Jan 18, 2013 10:38 am
Hmmm... I changed «Right Alt» to «Right Win», and it now works.

Is there anybody who has typography characters working on Right Alt in KDE 4.9.5?
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS

Re: Can't use typographic symbols

Thu Feb 07, 2013 9:53 am
Just in case it was some form of propagation issue, does switching it back to Right Alt now still lead to the function not working properly?


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar greatperson
Registered Member
Posts
75
Karma
0
OS

Re: Can't use typographic symbols

Sun Feb 10, 2013 7:22 am
Yes, the problem is still here.

I've just updated to KDE 4.10, nothing changed.

In addition, I noticed that I can't type «z» when using Right Win as typography switcher: I have to press Left Win + Z to get a simple letter «z» typed (while capital Z is still typed normally with Shift + Z).

UPD. I have the same behavior with Russian letter «я» which is on the same key as «z».

UPD2. Sorry, the latter problem doesn't depend on which typography switching method I use, e.g. Right Alt or Right Win.
User avatar greatperson
Registered Member
Posts
75
Karma
0
OS

Re: Can't use typographic symbols

Sun Feb 10, 2013 7:39 am
Hmm. When I try to quickly type something like «azzazazzzazzazzazzz», it works. I don't know how to explain this, but the Z key seems to have problem only when pressed first when no other key is pressed. That's why Win+Z and Shift+Z allow typing.

My keyboard is «Microsoft Wireless Laser Keyboard 6000 v2.0». Unfortunately, I don't have another keyboard to test. :(
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS

Re: Can't use typographic symbols

Sun Feb 10, 2013 11:00 pm
Can you check to see if some other application or system is attempting to use the Right Alt key?
I suspect you are dealing with some process which is itself trying to use the Right Alt key for it's own purposes, and that is interfering in your use of it for typographic symbols.

I would recommend checking global application shortcuts in System Settings first (as this is the only place in KDE where such interference could be coming from).


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar greatperson
Registered Member
Posts
75
Karma
0
OS

Re: Can't use typographic symbols

Tue Feb 12, 2013 8:03 am
bcooksley wrote:attempting to use the Right Alt key

Right Alt separately? Seriously? :o
I don't understand how can it be possible to configure.
And I haven't found any shortcuts containing «Right Alt», even with other keys.
User avatar greatperson
Registered Member
Posts
75
Karma
0
OS

Re: Can't use typographic symbols

Tue Feb 12, 2013 8:05 am
I'm not sure if this is relevant, but...
I used to use ksuperkey for a while, but I don't use it now. Could it change something permanently in keys mapping?..
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS

Re: Can't use typographic symbols

Wed Feb 13, 2013 5:15 am
Potentially, depending on how it worked.

Can you try to reproduce the issue under a new user, just to make sure?


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar greatperson
Registered Member
Posts
75
Karma
0
OS
Sorry, sorry, sorry. :<
This topic should be removed and forgotten since it isn't something KDE-related.

Both issues were just strange hardware problems: I have now found another keyboard and solved everything. The old keyboard was just trying to tell me that it was too old. :-)

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], blue-on, blue_bullet, claydoh, colstar, funkyskywalker, Google [Bot], jmacleod, koffeinfriedhof, kyrawertho, lcornell, Lenny McLennington, magkoc, ostroffjh, paule, quisimodo, Sogou [Bot], steveblezy