Reply to topic

How to tell an application which KWallet to use (local or...

anonymousleopard
Karma
0
Currently I have SFTP passwords for LAN stored in my wallet. Dolphin uses that data. For some it decided to store them in the general wallet and not in the local one.

I want to:

- have LAN/local passwords in the local wallet
- have other passwords (e.g. the ones for chromium) in the non-local wallet

How can I do this?
anonymousleopard
Karma
0
Any chance for reply? I hope I am in the right place to ask.
User avatar google01103
Manager
Posts
6668
Karma
25
not exactly sure but:

in systemsettings you can set a default wallet and wallet for local passwords

in kwalletmanager[5] you can disconnect an application from a wallet


OpenSuse Leap 42.1 x64, Plasma 5.x

anonymousleopard
Karma
0
google01103 wrote:not exactly sure but:

in systemsettings you can set a default wallet and wallet for local passwords

in kwalletmanager[5] you can disconnect an application from a wallet


I know that but it still doesn't answer the question. All apps try to use the default wallet. So far I have not seen an app which would use the local one.

In other words I see no option to say explicitly to an app "You should use this wallet", e.g. say to Chromium "you must use the default wallet" and say to Dolphin "you must use the local wallet".
jltrinchard
Registered Member
Posts
1
Karma
0
Yeah, there doesn't seem to be any solution to this. I'm using Fedora 29, KDE 5. My local wallet, 'local', uses bluefish, and my other wallet, 'other', uses that GPG keypair method.

For example, here's what I've tried to get chromium to only use the local kwallet, called 'local':

Changing settings in /home/user/.config/kwalletrc
- set local=chromium under [Auto Allow]
- obviously, setting default wallet to local works, but that's no good if you wish to separate programs' access to your wallets. Everything only wants to access the default wallet, instead of the local wallet.

I've temporarily set the default wallet to 'local', gave chromium access, changed a password, verified that it was saved within 'local', then switched default to 'other' wallet. Chromium then asks to access 'other' and won't bother with trying to access 'local' after it's been denied access to 'other'.

I'd expect that setting chrome to be auto-denied for the 'other' wallet won't work since when you manually deny it, chromium doesn't look for the wallet called 'local'.

I've tested the CHROMIUM_DISTRO_FLAGS in /usr/lib64/chromium-browser/chromium-browser.sh, such that --password-store=kwallet, --password-store=detect, or simply deleting the line. Regardless, Chromium keeps looking for the default wallet.
anonymousleopard
Karma
0
jltrinchard,

thanks for sharing your experience. I have given up using kwallet a long time ago. seahorse seems to give better control (although it has its own peculiarities too).

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bartoloni, Bing [Bot], daharas, Exabot [Bot], Google [Bot], Google Adsense [Bot], mathpfvr, skierpage, Sogou [Bot]