Reply to topic

Mouse: This is kind of a deal breaker

CWM030
Registered Member
Posts
5
Karma
0
Hi Folks!

Coming from a windows environment, I am use to DOUBLE CLICKING to open everything.

I am using Neo KDE just installed it today and I have set the mouse options to DOUBLE CLICK.

But when I click on icons on the desktop, they still open with a single click instead of double clicking which is VERY annoying because it opens double instances of programs or folders.

But if I open Dolphin, the mouse setting responds to how I have it setup in the control panel. it takes 2 clicks to open folders.

I dont understand why it works correctly in some spots of the OS, and not in others?

This is driving me crazy!

Ideas?

Thanks,
Christopher
User avatar claydoh
Registered Member
Posts
473
Karma
5
OS
If you right-click on your desktop, go to Desktop Settings, and change the Layout from the default "Desktop" to "Folder View" your settings will work as desired.

What is happening here is that, while Windows is using an actual file directory for the desktop layout to display files and folders, Plasma (and others) do not. What you have on your desktop are widgets as opposed to actual files. In this case there are application launcher widgets as opposed to actual application shortcut files, which explains why the double-click setting does not work apply. Luckily in KDE's Plasma we are able to switch from the standard default to the classic desktop style.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
CWM030
Registered Member
Posts
5
Karma
0
claydoh wrote:If you right-click on your desktop, go to Desktop Settings, and change the Layout from the default "Desktop" to "Folder View" your settings will work as desired.

What is happening here is that, while Windows is using an actual file directory for the desktop layout to display files and folders, Plasma (and others) do not. What you have on your desktop are widgets as opposed to actual files. In this case there are application launcher widgets as opposed to actual application shortcut files, which explains why the double-click setting does not work apply. Luckily in KDE's Plasma we are able to switch from the standard default to the classic desktop style.



No dice, I did exactly what you said and its still doing the one click on the desktop icons.

Chris
CWM030
Registered Member
Posts
5
Karma
0
claydoh wrote:If you right-click on your desktop, go to Desktop Settings, and change the Layout from the default "Desktop" to "Folder View" your settings will work as desired.

What is happening here is that, while Windows is using an actual file directory for the desktop layout to display files and folders, Plasma (and others) do not. What you have on your desktop are widgets as opposed to actual files. In this case there are application launcher widgets as opposed to actual application shortcut files, which explains why the double-click setting does not work apply. Luckily in KDE's Plasma we are able to switch from the standard default to the classic desktop style.



SEE IMAGE BELOW:

http://imgur.com/a/vg3sy
CWM030
Registered Member
Posts
5
Karma
0
claydoh wrote:If you right-click on your desktop, go to Desktop Settings, and change the Layout from the default "Desktop" to "Folder View" your settings will work as desired.

What is happening here is that, while Windows is using an actual file directory for the desktop layout to display files and folders, Plasma (and others) do not. What you have on your desktop are widgets as opposed to actual files. In this case there are application launcher widgets as opposed to actual application shortcut files, which explains why the double-click setting does not work apply. Luckily in KDE's Plasma we are able to switch from the standard default to the classic desktop style.



Now I found out if I set my desktop up this way..... http://imgur.com/a/KXTnY

Icons only open by double clicking them.

My only problem is how come I cant move them inside that box to where I want them? Say... Settings at the bottom of the container instead of up there right next to chrome?


Thanks,
CM
User avatar claydoh
Registered Member
Posts
473
Karma
5
OS
I do not know why it is not working, as it worked fine when I tested it out.

Actually I think I have figured it out, I don't normally have icons on my desktops so i created them while in Folder View mode. Creating them from within the standard Desktop creates a widget, which will still be present even when switching to Folder View mode so they won't have any of the properties that a file would. Try creating new ones while in Folder View mode and see if they follow the correct behavior, which they should as they are actual shortcut files as opposed to the widgets.

Your last image shows the Folder View widget. The Folder View desktop layout is basically a full-screen version of this widget.


If you are not sure which is which, the shortcut files will be readily movable while widgets need a long-click to bring up the "handle"

Sorry this is slightly convoluted :( , though at least to my addled mind it is logical, but only once you have the data needed.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
CWM030
Registered Member
Posts
5
Karma
0
claydoh wrote:I do not know why it is not working, as it worked fine when I tested it out.

Actually I think I have figured it out, I don't normally have icons on my desktops so i created them while in Folder View mode. Creating them from within the standard Desktop creates a widget, which will still be present even when switching to Folder View mode so they won't have any of the properties that a file would. Try creating new ones while in Folder View mode and see if they follow the correct behavior, which they should as they are actual shortcut files as opposed to the widgets.

Your last image shows the Folder View widget. The Folder View desktop layout is basically a full-screen version of this widget.


If you are not sure which is which, the shortcut files will be readily movable while widgets need a long-click to bring up the "handle"

Sorry this is slightly convoluted :( , though at least to my addled mind it is logical, but only once you have the data needed.




What I did was while in FOLDER view I opened the K menu and then went to say INTERNET put my mouse over chrome then dragged it out to the desktop then it pops up says MOVE HERE? LINK HERE? I hit link.

Chris
User avatar claydoh
Registered Member
Posts
473
Karma
5
OS
I do not know. Mine all work using both drag-and-drop, as well as right-click, all combinations ??? ???


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
chaossadept
Registered Member
Posts
2
Karma
0
Thanks! Your advice helped me a lot! I solved my problem. Right, i've deleted icons that I created for 'desctop', and created them again. After it double click works fine!


claydoh wrote:I do not know why it is not working, as it worked fine when I tested it out.

Actually I think I have figured it out, I don't normally have icons on my desktops so i created them while in Folder View mode. Creating them from within the standard Desktop creates a widget, which will still be present even when switching to Folder View mode so they won't have any of the properties that a file would. Try creating new ones while in Folder View mode and see if they follow the correct behavior, which they should as they are actual shortcut files as opposed to the widgets.

Your last image shows the Folder View widget. The Folder View desktop layout is basically a full-screen version of this widget.


If you are not sure which is which, the shortcut files will be readily movable while widgets need a long-click to bring up the "handle"

Sorry this is slightly convoluted :( , though at least to my addled mind it is logical, but only once you have the data needed.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], danro, DeathTBO, Google [Bot], Majestic-12 [Bot], Sylvanticus, TristanDee