Reply to topic

How to change Krusader's icon set in root mode?

User avatar Crotalidae
Registered Member
Posts
3
Karma
0
I just recently installed Kubuntu 17.04, having gone from version 16.10. When I installed the new system, Krusader's icons changed, and I don't especially like the icon set it is using. It's using the Breeze icon set, and I much prefer the Oxygen icon set (the same ones used on this site for folder graphics: Image).

Unfortunately, I've tried quite a few things to change it, and nothing seems to work. Changing the icons settings under systemsettings5, via sudo or kdesudo doesn't work. Nothing I've done affects Krusader's look at all. I've actually tried Qt5ct, and that doesn't seem to help either; it also plays havoc with my icons -- after using it, I'd have all of my menu icons, as well as the ones on my toolbars completely disappear. I managed to reverse the problem by uninstalling it, though.

This is frustrating. How I am supposed to change Krusader's icon set?
User avatar Rog131
Registered Member
Posts
828
Karma
10
The application should use the user's (in this case the user is the root) icon set.

The icons are set at the kdeglobals configuration file.

At here, setting /root/.config/kdeglobals icons theme to oxygen:
Code: Select all
sudo kwriteconfig5 --file /root/.config/kdeglobals --group Icons --key Theme oxygen

Clearing the the root icon cache - removing: /root/.cache/icon-cache.kcache

...and the Krusader is using the Oxygen icons:

Image


Note !
The distribution version numbers only mean something to the distribution users.
This was with:
Code: Select all
$ krusader -v
krusader 2.6.0 "Stiff Challenges"
User avatar Crotalidae
Registered Member
Posts
3
Karma
0
Thanks, I appreciate the help, although I have found an alternative solution. I edited my sudoers file to add this environment
variable:

Code: Select all
Defaults env_keep += "KDE_SESSION_VERSION KDE_FULL_SESSION=true"


and I also found that launching KDE programs with "kdesudo -c "HOME=$HOME command" works to get them to use the proper icon set in KDE.

Here's where I found this info: https://bugs.kde.org/show_bug.cgi?id=353263#c12

Although, I may just do what you suggested anyway. Thanks for the help...
duns
Registered Member
Posts
63
Karma
0
OS
The problem was solved in Kubuntu 17.04, but come back again with Kubuntu 18.04: none of the solutions proposed up to now works
duns
Registered Member
Posts
63
Karma
0
OS
Solved: use kdesu instead (kdesu -c "KDE_SESSION_VERSION=5 KDE_FULL_SESSION=true dbus-launch krusader"), after symlinking it in usr/local/bin.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], hsnnsnc, Yahoo [Bot]