Reply to topic

KDE Connect won't send files

jarrr
Registered Member
Posts
8
Karma
0

KDE Connect won't send files

Sat Oct 13, 2018 5:02 pm
Desktop: Fedora 28, KDE spin, all patches up to date. Using KDE Connect. Due to problems, uninstalled and reinstalled KDE Connect. I enabled the ports in the firewall for both TCP and UDP.

Mobile: Samsung GS8, all patches up to date. Due to problems, uninstalled and reinstalled KDE Connect.

I was having problems trying to transfer a file from the phone to the desktop. It would get halfway or three quarters the way through, and just hang there. Based on advice from another forum, I tried uninstalling and reinstalling KDE Connect on both the desktop and the phone. I re-ran the firewall port enable script.

Now when I try to transfer a file from the phone to the deskop, it just hangs. The desktop notifier in the tray says "Receiving file over KDE Connect", and names the file, but the progress meter bar keeps just running back and forth. No file or part of file appears in the Downloads/ directory.

Remote input works correctly, so there is definitely communications there. Send ping works from the phone to the desktop. If I go on the desktop KDE Connect and browse files, I can see all of the pictures in my Camera/ directory on the phone, and copy the same ones that failed in the Send Files step above.

I also run KDE Connect on a laptop, also running Fedora 28 KDE spin. The same problem happens there, leading me to believe that something is wrong on the phone end.

Suggestions? Thanks
JimR
User avatar skierpage
Registered Member
Posts
15
Karma
0
OS

Re: KDE Connect won't send files

Sat Jun 29, 2019 11:44 pm
Me too, exactly this. There's no file in ~/Downloads. ps shows ssh and sshfs subprocesses of kdeconnect, both stalled. journalctl shows (from latest to earliest)
Code: Select all
kdeconnectd[2525]: QDBusAbstractAdaptor: Cannot relay signal SftpPlugin::packetReceived(NetworkPacket): Unregistered input type in parameter list: NetworkPacket
plasmashell[2507]: file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/JobDelegate.qml:163:13: Unable to assign [undefined] to bool
plasmashell[2507]: Could not find service for job "Job 4" with app name "org.kde.kdeconnectd"
plasmashell[2507]: Could not find service for job "Job 4" with app name "org.kde.kdeconnectd"
fedlaptop plasmashell[2507]: Could not find service for job "Job 2" with app name "org.kde.kdeconnectd"
fedlaptop kdeconnectd[2525]: Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)

I don't think I've ever got KDE Connect's Send files to work. I usually just plug in over USB and in Android's USB Preferences set "Use USB for" to "File Transfer" so I can browse the phone with mtp: in Dolphin.

 
Reply to topic

Bookmarks



Who is online

Registered users: abalfoort, alcinos, Baidu [Spider], Bing [Bot], blue_bullet, boudewijn, dtalmadge, Google [Bot], gvigroux, Jay 5gzmn, jmacleod, Majestic-12 [Bot], Sogou [Bot], TheraHedwig, TristanDee, veryprofessionaldodo, victus_maestro, wizonesolutions